]> git.pld-linux.org Git - packages/frotz.git/commitdiff
- by Lukasz Pawelczyk (havner)
authorAdam Gołębiowski <adamg@pld-linux.org>
Wed, 13 Aug 2003 13:40:00 +0000 (13:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    frotz-configfix.patch -> 1.1
    frotz-makefilefix.patch -> 1.1
    frotz-wrapper -> 1.1

frotz-configfix.patch [new file with mode: 0644]
frotz-makefilefix.patch [new file with mode: 0644]
frotz-wrapper [new file with mode: 0644]

diff --git a/frotz-configfix.patch b/frotz-configfix.patch
new file mode 100644 (file)
index 0000000..29de0f6
--- /dev/null
@@ -0,0 +1,40 @@
+diff -urN /root/1/frotz-2.43/doc/frotz.conf-big frotz-2.43/doc/frotz.conf-big
+--- /root/1/frotz-2.43/doc/frotz.conf-big      Sat Oct 28 19:43:07 2000
++++ frotz-2.43/doc/frotz.conf-big      Tue Aug 12 16:11:41 2003
+@@ -16,13 +16,13 @@
+ foreground    white
+ # Set background color                (default "blue" if in color mode)
+-background    blue
++background    black
+ # Set error-reporting mode    (default "once")
+ errormode     once
+ # Set path to search for game files (no default)
+-zcode_path    /usr/local/games/zcode
++zcode_path    /usr/share/games/zcode
+ # Use plain ASCII only                (default "no")
+ ascii         no
+@@ -60,16 +60,16 @@
+ # Force color mode            (default "no")
+ # Useful for use with supposedly current flavors of Unix that still don't
+ # understand what the "xterm-color" terminal type is.
+-force_color   no
++#force_color  no
+ # Set screen height           (default is detected height)
+-screen_height 24
++#screen_height        24
+ # Set screen width            (default is detected screen width)
+-screen_width  80
++#screen_width 80
+ # Set script width            (default is screen width)
+-script_width  80
++#script_width 80
+ # Set context lines           (default "0")
+ context_lines 0
diff --git a/frotz-makefilefix.patch b/frotz-makefilefix.patch
new file mode 100644 (file)
index 0000000..b57f070
--- /dev/null
@@ -0,0 +1,32 @@
+diff -urN frotz-2.43/Makefile /usr/local/1install/rpm/BUILD/frotz-2.43/Makefile
+--- frotz-2.43/Makefile        Mon Oct 28 02:21:52 2002
++++ /usr/local/1install/rpm/BUILD/frotz-2.43/Makefile  Tue Aug 12 02:36:05 2003
+@@ -7,24 +7,24 @@
+ # Define your optimization flags.  Most compilers understand -O and -O2,
+ # Standard (note: Solaris on UltraSparc using gcc 2.8.x might not like this.)
+ #
+-OPTS = -O2 
++OPTS = -O2 -I/usr/include/ncurses
+ # Pentium with gcc 2.7.0 or better
+ #OPTS = -O2 -fomit-frame-pointer -malign-functions=2 -malign-loops=2 \
+ #-malign-jumps=2
+ # Define where you want Frotz installed.  Usually this is /usr/local
+-PREFIX = /usr/local
++PREFIX = /usr
+ MAN_PREFIX = $(PREFIX)
+ #MAN_PREFIX = /usr/local/share
+-CONFIG_DIR = $(PREFIX)/etc
++#CONFIG_DIR = $(PREFIX)/etc
+ #CONFIG_DIR = /etc
+ # Define where you want Frotz to look for frotz.conf.
+ #
+-CONFIG_DIR = /usr/local/etc
++CONFIG_DIR = /etc
+ #CONFIG_DIR = /etc
+ #CONFIG_DIR = /usr/pkg/etc
+ #CONFIG_DIR =
diff --git a/frotz-wrapper b/frotz-wrapper
new file mode 100644 (file)
index 0000000..53035ee
--- /dev/null
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+GAME=/usr/share/games/zcode/`basename $0`.z5
+
+if [ -f $GAME ]; then
+       frotz $GAME
+else
+       echo "This game does not exist."
+fi
This page took 0.11105 seconds and 4 git commands to generate.