]> git.pld-linux.org Git - packages/frottle.git/blame - frottle.spec
- new
[packages/frottle.git] / frottle.spec
CommitLineData
e1e5c179
AM
1Summary: Packet Scheduling and QoS for Wireless Networks
2Name: frottle
3Version: 0.2.1
4Release: 1
5License: GPL
6Group: Networking/Daemons
7Source0: http://dl.sourceforge.net/frottle/%{name}-%{version}.tar.gz
8# Source0-md5: eb18d7490fbc874fcecb1f4686f2707a
9Source1: %{name}.init
10Source2: %{name}.sysconfig
11URL: http://frottle.sourceforge.net/
12BuildRequires: iptables-devel
13Requires(post,preun): /sbin/chkconfig
14BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16%description
17Frottle (Freenet throttle) is an open source GNU GPL project to
18control traffic on wireless networks. Such control eliminates the
19common hidden-node effect even on large scale wireless networks.
20Frottle is currently only available for Linux wireless gateways using
21iptables firewalls, with plans to develop a windows client in the
22future.
23
24Frottle works by scheduling the traffic of each client, using a master
25node to co-ordinate actions. This eliminates collisions, and prevents
26clients with stronger signals from receiving bandwidth bias.
27
28%prep
29%setup -q
30
31%build
32CPPFLAGS="-I%{_includedir}/libipq"
33%configure
34%{__make}
35
36%install
37rm -rf $RPM_BUILD_ROOT
38install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d}
39
40%{__make} install \
41 DESTDIR=$RPM_BUILD_ROOT \
42
43install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
44install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
45
46install frottle.conf.sample $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%post
52/sbin/chkconfig --add %{name}
53if [ -f /var/lock/subsys/%{name} ]; then
54 /etc/rc.d/init.d/%{name} restart >&2
55else
56 echo "Run \"/etc/rc.d/init.d/%{name} start\" to start frottle daemon."
57fi
58
59%preun
60if [ "$1" = "0" ]; then
61 if [ -f /var/lock/subsys/%{name} ]; then
62 /etc/rc.d/init.d/%{name} stop >&2
63 fi
64 /sbin/chkconfig --del %{name}
65fi
66
67%files
68%defattr(644,root,root,755)
69%doc AUTHORS ChangeLog INSTALL README
70%attr(754,root,root) /etc/rc.d/init.d/%{name}
71%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/%{name}
72%attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/%{name}.conf
73%attr(755,root,root) %{_sbindir}/%{name}
74%{_mandir}/man?/*
This page took 0.07695 seconds and 4 git commands to generate.