]> git.pld-linux.org Git - packages/freetype.git/commitdiff
- added free patch: don't try to free ints - it caused SEGV on ghostscript-fonts...
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 18 Oct 2003 23:10:53 +0000 (23:10 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- release 2

Changed files:
    freetype-free.patch -> 1.1
    freetype.spec -> 1.92

freetype-free.patch [new file with mode: 0644]
freetype.spec

diff --git a/freetype-free.patch b/freetype-free.patch
new file mode 100644 (file)
index 0000000..1c5e4eb
--- /dev/null
@@ -0,0 +1,25 @@
+Don't try to free fields which are just ints (not pointers to ints) - it caused SEGV.
+--- freetype-2.1.5/src/type1/t1objs.c.orig     2003-07-26 00:09:53.000000000 +0200
++++ freetype-2.1.5/src/type1/t1objs.c  2003-10-19 00:52:48.000000000 +0200
+@@ -229,9 +229,6 @@
+       FT_FREE( type1->encoding.char_name );
+       FT_FREE( type1->font_name );
+-      FT_FREE( type1->paint_type );
+-      FT_FREE( type1->stroke_width );
+-
+ #ifndef T1_CONFIG_OPTION_NO_AFM
+       /* release afm data if present */
+       if ( face->afm_data )
+--- freetype-2.1.5/src/type42/t42objs.c.orig   2003-07-26 00:09:53.000000000 +0200
++++ freetype-2.1.5/src/type42/t42objs.c        2003-10-19 00:55:21.000000000 +0200
+@@ -398,9 +398,6 @@
+       FT_FREE( type1->encoding.char_name );
+       FT_FREE( type1->font_name );
+-      FT_FREE( type1->paint_type );
+-      FT_FREE( type1->stroke_width );
+-
+       FT_FREE( face->ttf_data );
+ #if 0
index 1fa00068b32d137a80847e6eee23c6912495138b..24ea6321e50e74807571b1abaad9c1cdfb40a3d1 100644 (file)
@@ -13,7 +13,7 @@ Summary(ru):  
 Summary(uk):   òÁÓÔÅÒÉÚÁÔÏÒ ÛÒÉÆԦנTrueType
 Name:          freetype
 Version:       2.1.5
-Release:       1
+Release:       2
 License:       GPL or FTL
 Group:         Libraries
 Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
@@ -22,6 +22,7 @@ Source1:      http://dl.sourceforge.net/%{name}/ftdocs-%{_docver}.tar.bz2
 # Source1-md5: 367064e81998a302f3844f1dcdb8d77f
 Source2:       http://dl.sourceforge.net/%{name}/ft2demos-%{version}.tar.bz2
 # Source2-md5: 0484cfc7d881ccb49cafa85ec3198f3c
+Patch0:                %{name}-free.patch
 URL:           http://www.freetype.org/
 BuildRequires: SysVinit
 BuildRequires: XFree86-devel
@@ -166,6 +167,7 @@ Programy demonstracyjne do biblioteki FreeType.
 
 %prep
 %setup -q -a1 -a2
+%patch -p1
 
 mv -f freetype-%{_docver}/docs/reference/* docs/reference
 
This page took 0.235228 seconds and 4 git commands to generate.