]> git.pld-linux.org Git - packages/freetds.git/blob - freetds.spec
- updated to 1.2.21
[packages/freetds.git] / freetds.spec
1 #
2 # Conditional build:
3 %bcond_with     msdblib         # use MS-style dblib instead of SYB-style
4 %bcond_without  kerberos5       # Kerberos5 support (via Heimdal)
5 #
6 # %%define tdsver - default protocol version; valid versions:
7 # auto (default)
8 # 4.2 (used by Sybase SQLServer <= 10 and MS SQL Server 6.5)
9 # 4.6
10 # 5.0 (used by Sybase SQLServer >= 11)
11 # 7.0 (used by MS SQL Server 7.0)
12 # 7.1 (used by MS SQL Server 2000)
13 # 7.2 (used by MS SQL Server 2005)
14 # 7.3 (used by MS SQL Server 2008)
15 # 7.4 (used by MS SQL Server 2012/2014)
16
17 Summary:        Free implementation of Sybase's db-lib
18 Summary(pl.UTF-8):      Wolnodostępna implementacja db-lib firmy Sybase
19 Name:           freetds
20 Version:        1.00.47
21 Release:        1
22 License:        LGPL v2+
23 Group:          Libraries
24 Source0:        ftp://ftp.freetds.org/pub/freetds/stable/%{name}-%{version}.tar.bz2
25 # Source0-md5:  c8c126d3d6c1981a0b5169cb5df2803e
26 Patch0:         %{name}-reserved.patch
27 Patch1:         %{name}-no-Llibdir.patch
28 URL:            http://www.freetds.org/
29 BuildRequires:  autoconf >= 2.53
30 BuildRequires:  automake
31 BuildRequires:  doxygen
32 BuildRequires:  gettext-tools
33 %{?with_kerberos5:BuildRequires:        heimdal-devel}
34 BuildRequires:  libltdl-devel >= 2:2
35 BuildRequires:  libtool >= 2:2
36 BuildRequires:  openssl-devel
37 BuildRequires:  readline-devel
38 BuildRequires:  unixODBC-devel
39 Requires(post): /sbin/ldconfig
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _sysconfdir     /etc/tds
43
44 %description
45 FreeTDS is a free (open source) implementation of Sybase's db-lib,
46 ct-lib, and ODBC libraries (which can be used also to work with MS SQL
47 databases). Currently, dblib and ctlib are most mature. Both of these
48 libraries have several programs known to compile and run against them.
49 ODBC is not quite as mature, but may work depending on your needs.
50
51 %description -l pl.UTF-8
52 FreeTDS to wolnodostępna (z otwartymi źródłami) implementacja
53 bibliotek db-lib, ct-lib i ODBC firmy Sybase (których można używać
54 także do pracy z bazami MS SQL). Aktualnie najlepiej działają dblib i
55 ctlib - istnieje trochę programów, o których wiadomo, że kompilują się
56 i działają z tymi bibliotekami. ODBC nie jest jeszcze na tyle
57 skończony, ale może działać w zależności od potrzeb.
58
59 %package devel
60 Summary:        FreeTDS header files
61 Summary(pl.UTF-8):      Pliki nagłówkowe FreeTDS
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 %{?with_kerberos5:Requires:     heimdal-devel}
65 Requires:       openssl-devel
66
67 %description devel
68 FreeTDS header files.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe FreeTDS.
72
73 %package static
74 Summary:        FreeTDS static libraries
75 Summary(pl.UTF-8):      Statyczne biblioteki FreeTDS
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 FreeTDS static libraries.
81
82 %description static -l pl.UTF-8
83 Statyczne biblioteki FreeTDS.
84
85 %package odbc
86 Summary:        FreeTDS ODBC driver for unixODBC
87 Summary(pl.UTF-8):      Sterownik ODBC FreeTDS dla unixODBC
88 Group:          Libraries
89 Requires(post): /sbin/ldconfig
90 Requires(post): /usr/bin/odbcinst
91 Requires:       %{name} = %{version}-%{release}
92 Requires:       unixODBC
93
94 %description odbc
95 FreeTDS ODBC driver for unixODBC.
96
97 %description odbc -l pl.UTF-8
98 Sterownik ODBC FreeTDS dla unixODBC.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103 %patch1 -p1
104
105 %build
106 %{__libtoolize}
107 %{__aclocal} -I m4
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         %{?with_kerberos5:--enable-krb5=gssapi} \
113         --disable-silent-rules \
114         %{?with_msdblib:--with-msdblib} \
115         --with-openssl \
116         %{?tdsver:--with-tdsver=%{tdsver}} \
117         --with-unixodbc=/usr
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT \
126         ETC=$RPM_BUILD_ROOT%{_sysconfdir}
127
128 cp -a src/pool/BUGS BUGS.pool
129 cp -a src/pool/README README.pool
130 cp -a src/pool/TODO TODO.pool
131
132 # ODBC driver, dlopen()ed
133 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libtdsodbc.{la,a}
134
135 # packaged as %doc
136 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post
142 /sbin/ldconfig
143 if [ -f /etc/freetds.conf ]; then
144         mv -f /etc/freetds.conf %{_sysconfdir}/freetds.conf
145 fi
146
147 %postun -p /sbin/ldconfig
148
149 %post odbc
150 /sbin/ldconfig
151 /usr/bin/odbcinst -i -d -r <<EOF
152 [FreeTDS]
153 Description = FreeTDS unixODBC Driver
154 Driver = %{_libdir}/libtdsodbc.so.0
155 Setup = %{_libdir}/libtdsodbc.so.0
156 EOF
157 /usr/bin/odbcinst -i -d -r <<EOF
158 [SQL Server]
159 Description = FreeTDS unixODBC Driver
160 Driver = %{_libdir}/libtdsodbc.so.0
161 Setup = %{_libdir}/libtdsodbc.so.0
162 EOF
163
164 %postun odbc -p /sbin/ldconfig
165
166 %files
167 %defattr(644,root,root,755)
168 %doc AUTHORS BUGS* ChangeLog NEWS README* TODO* doc/userguide
169 %attr(755,root,root) %{_bindir}/bsqldb
170 %attr(755,root,root) %{_bindir}/datacopy
171 %attr(755,root,root) %{_bindir}/defncopy
172 %attr(755,root,root) %{_bindir}/fisql
173 %attr(755,root,root) %{_bindir}/freebcp
174 %attr(755,root,root) %{_bindir}/tdspool
175 %attr(755,root,root) %{_bindir}/tsql
176 %attr(755,root,root) %{_libdir}/libct.so.*.*.*
177 %attr(755,root,root) %ghost %{_libdir}/libct.so.4
178 %attr(755,root,root) %{_libdir}/libsybdb.so.*.*.*
179 %attr(755,root,root) %ghost %{_libdir}/libsybdb.so.5
180 %dir %{_sysconfdir}
181 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/freetds.conf
182 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locales.conf
183 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pool.conf
184 %{_mandir}/man1/bsqldb.1*
185 %{_mandir}/man1/datacopy.1*
186 %{_mandir}/man1/defncopy.1*
187 %{_mandir}/man1/fisql.1*
188 %{_mandir}/man1/freebcp.1*
189 %{_mandir}/man1/tsql.1*
190 %{_mandir}/man5/freetds.conf.5*
191
192 %files devel
193 %defattr(644,root,root,755)
194 %doc doc/reference
195 %attr(755,root,root) %{_libdir}/libct.so
196 %attr(755,root,root) %{_libdir}/libsybdb.so
197 %{_libdir}/libct.la
198 %{_libdir}/libsybdb.la
199 %{_includedir}/bkpublic.h
200 %{_includedir}/cspublic.h
201 %{_includedir}/cstypes.h
202 %{_includedir}/ctpublic.h
203 %{_includedir}/odbcss.h
204 %{_includedir}/sqldb.h
205 %{_includedir}/sqlfront.h
206 %{_includedir}/sybdb.h
207 %{_includedir}/syberror*.h
208 %{_includedir}/sybfront.h
209 %{_includedir}/tds_sysdep_public.h
210
211 %files static
212 %defattr(644,root,root,755)
213 %{_libdir}/libct.a
214 %{_libdir}/libsybdb.a
215
216 %files odbc
217 %defattr(644,root,root,755)
218 %attr(755,root,root) %{_bindir}/bsqlodbc
219 %attr(755,root,root) %{_bindir}/osql
220 %attr(755,root,root) %{_libdir}/libtdsodbc.so.*.*.*
221 %attr(755,root,root) %ghost %{_libdir}/libtdsodbc.so.0
222 %attr(755,root,root) %{_libdir}/libtdsodbc.so
223 %{_mandir}/man1/bsqlodbc.1*
224 %{_mandir}/man1/osql.1*
This page took 0.136466 seconds and 3 git commands to generate.