]> git.pld-linux.org Git - packages/freetds.git/blob - freetds.spec
- updated to 1.2.21
[packages/freetds.git] / freetds.spec
1 #
2 # Conditional build:
3 %bcond_with     msdblib         # use MS-style dblib instead of SYB-style
4 %bcond_without  kerberos5       # Kerberos5 support (via Heimdal)
5 #
6 # %%define tdsver - default protocol version; valid versions:
7 # auto (default)
8 # 4.2 (used by Sybase SQLServer <= 10 and MS SQL Server 6.5)
9 # 4.6
10 # 5.0 (used by Sybase SQLServer >= 11)
11 # 7.0 (used by MS SQL Server 7.0)
12 # 7.1 (used by MS SQL Server 2000)
13 # 7.2 (used by MS SQL Server 2005)
14 # 7.3 (used by MS SQL Server 2008)
15 # 7.4 (used by MS SQL Server 2012/2014)
16
17 Summary:        Free implementation of Sybase's db-lib
18 Summary(pl.UTF-8):      Wolnodostępna implementacja db-lib firmy Sybase
19 Name:           freetds
20 Version:        1.00.91
21 Release:        1
22 License:        LGPL v2+
23 Group:          Libraries
24 Source0:        ftp://ftp.freetds.org/pub/freetds/stable/%{name}-%{version}.tar.bz2
25 # Source0-md5:  8d71f9f29be0fe0637e443dd3807b3fd
26 Patch0:         %{name}-no-Llibdir.patch
27 URL:            http://www.freetds.org/
28 BuildRequires:  autoconf >= 2.53
29 BuildRequires:  automake
30 BuildRequires:  doxygen
31 BuildRequires:  gettext-tools
32 %{?with_kerberos5:BuildRequires:        heimdal-devel}
33 BuildRequires:  libltdl-devel >= 2:2
34 BuildRequires:  libtool >= 2:2
35 BuildRequires:  openssl-devel
36 BuildRequires:  readline-devel
37 BuildRequires:  unixODBC-devel
38 Requires(post): /sbin/ldconfig
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %define         _sysconfdir     /etc/tds
42
43 %description
44 FreeTDS is a free (open source) implementation of Sybase's db-lib,
45 ct-lib, and ODBC libraries (which can be used also to work with MS SQL
46 databases). Currently, dblib and ctlib are most mature. Both of these
47 libraries have several programs known to compile and run against them.
48 ODBC is not quite as mature, but may work depending on your needs.
49
50 %description -l pl.UTF-8
51 FreeTDS to wolnodostępna (z otwartymi źródłami) implementacja
52 bibliotek db-lib, ct-lib i ODBC firmy Sybase (których można używać
53 także do pracy z bazami MS SQL). Aktualnie najlepiej działają dblib i
54 ctlib - istnieje trochę programów, o których wiadomo, że kompilują się
55 i działają z tymi bibliotekami. ODBC nie jest jeszcze na tyle
56 skończony, ale może działać w zależności od potrzeb.
57
58 %package devel
59 Summary:        FreeTDS header files
60 Summary(pl.UTF-8):      Pliki nagłówkowe FreeTDS
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 %{?with_kerberos5:Requires:     heimdal-devel}
64 Requires:       openssl-devel
65
66 %description devel
67 FreeTDS header files.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe FreeTDS.
71
72 %package static
73 Summary:        FreeTDS static libraries
74 Summary(pl.UTF-8):      Statyczne biblioteki FreeTDS
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 FreeTDS static libraries.
80
81 %description static -l pl.UTF-8
82 Statyczne biblioteki FreeTDS.
83
84 %package odbc
85 Summary:        FreeTDS ODBC driver for unixODBC
86 Summary(pl.UTF-8):      Sterownik ODBC FreeTDS dla unixODBC
87 Group:          Libraries
88 Requires(post): /sbin/ldconfig
89 Requires(post): /usr/bin/odbcinst
90 Requires:       %{name} = %{version}-%{release}
91 Requires:       unixODBC
92
93 %description odbc
94 FreeTDS ODBC driver for unixODBC.
95
96 %description odbc -l pl.UTF-8
97 Sterownik ODBC FreeTDS dla unixODBC.
98
99 %prep
100 %setup -q
101 %patch0 -p1
102
103 %build
104 %{__libtoolize}
105 %{__aclocal} -I m4
106 %{__autoconf}
107 %{__autoheader}
108 %{__automake}
109 %configure \
110         %{?with_kerberos5:--enable-krb5=gssapi} \
111         --disable-silent-rules \
112         %{?with_msdblib:--with-msdblib} \
113         --with-openssl \
114         %{?tdsver:--with-tdsver=%{tdsver}} \
115         --with-unixodbc=/usr
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT \
124         ETC=$RPM_BUILD_ROOT%{_sysconfdir}
125
126 cp -a src/pool/BUGS BUGS.pool
127 cp -a src/pool/README README.pool
128 cp -a src/pool/TODO TODO.pool
129
130 # ODBC driver, dlopen()ed
131 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libtdsodbc.{la,a}
132
133 # packaged as %doc
134 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post
140 /sbin/ldconfig
141 if [ -f /etc/freetds.conf ]; then
142         mv -f /etc/freetds.conf %{_sysconfdir}/freetds.conf
143 fi
144
145 %postun -p /sbin/ldconfig
146
147 %post odbc
148 /sbin/ldconfig
149 /usr/bin/odbcinst -i -d -r <<EOF
150 [FreeTDS]
151 Description = FreeTDS unixODBC Driver
152 Driver = %{_libdir}/libtdsodbc.so.0
153 Setup = %{_libdir}/libtdsodbc.so.0
154 EOF
155 /usr/bin/odbcinst -i -d -r <<EOF
156 [SQL Server]
157 Description = FreeTDS unixODBC Driver
158 Driver = %{_libdir}/libtdsodbc.so.0
159 Setup = %{_libdir}/libtdsodbc.so.0
160 EOF
161
162 %postun odbc -p /sbin/ldconfig
163
164 %files
165 %defattr(644,root,root,755)
166 %doc AUTHORS BUGS* ChangeLog NEWS README* TODO* doc/userguide
167 %attr(755,root,root) %{_bindir}/bsqldb
168 %attr(755,root,root) %{_bindir}/datacopy
169 %attr(755,root,root) %{_bindir}/defncopy
170 %attr(755,root,root) %{_bindir}/fisql
171 %attr(755,root,root) %{_bindir}/freebcp
172 %attr(755,root,root) %{_bindir}/tdspool
173 %attr(755,root,root) %{_bindir}/tsql
174 %attr(755,root,root) %{_libdir}/libct.so.*.*.*
175 %attr(755,root,root) %ghost %{_libdir}/libct.so.4
176 %attr(755,root,root) %{_libdir}/libsybdb.so.*.*.*
177 %attr(755,root,root) %ghost %{_libdir}/libsybdb.so.5
178 %dir %{_sysconfdir}
179 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/freetds.conf
180 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/locales.conf
181 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pool.conf
182 %{_mandir}/man1/bsqldb.1*
183 %{_mandir}/man1/datacopy.1*
184 %{_mandir}/man1/defncopy.1*
185 %{_mandir}/man1/fisql.1*
186 %{_mandir}/man1/freebcp.1*
187 %{_mandir}/man1/tsql.1*
188 %{_mandir}/man5/freetds.conf.5*
189
190 %files devel
191 %defattr(644,root,root,755)
192 %doc doc/reference
193 %attr(755,root,root) %{_libdir}/libct.so
194 %attr(755,root,root) %{_libdir}/libsybdb.so
195 %{_libdir}/libct.la
196 %{_libdir}/libsybdb.la
197 %{_includedir}/bkpublic.h
198 %{_includedir}/cspublic.h
199 %{_includedir}/cstypes.h
200 %{_includedir}/ctpublic.h
201 %{_includedir}/odbcss.h
202 %{_includedir}/sqldb.h
203 %{_includedir}/sqlfront.h
204 %{_includedir}/sybdb.h
205 %{_includedir}/syberror*.h
206 %{_includedir}/sybfront.h
207 %{_includedir}/tds_sysdep_public.h
208
209 %files static
210 %defattr(644,root,root,755)
211 %{_libdir}/libct.a
212 %{_libdir}/libsybdb.a
213
214 %files odbc
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_bindir}/bsqlodbc
217 %attr(755,root,root) %{_bindir}/osql
218 %attr(755,root,root) %{_libdir}/libtdsodbc.so.*.*.*
219 %attr(755,root,root) %ghost %{_libdir}/libtdsodbc.so.0
220 %attr(755,root,root) %{_libdir}/libtdsodbc.so
221 %{_mandir}/man1/bsqlodbc.1*
222 %{_mandir}/man1/osql.1*
This page took 0.08148 seconds and 3 git commands to generate.