]> git.pld-linux.org Git - packages/freeswan.git/commitdiff
-modify for new version 1.97freeswan-config.patch
authorpioklo <pioklo@linuxpl.com>
Wed, 1 May 2002 17:12:01 +0000 (17:12 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    freeswan-Makefile.patch -> 1.2
    freeswan-init.patch -> 1.6
    freeswan-keygen.patch -> 1.2
    freeswan-manlink.patch -> 1.2

freeswan-Makefile.patch
freeswan-init.patch
freeswan-keygen.patch
freeswan-manlink.patch

index 199dc1271971194c485809ad017039665745e884..c23ad43cd6e7d81e7f2339a1c9839beba7db2f56 100644 (file)
@@ -1,6 +1,5 @@
-diff -Naur freeswan-1.96.orig/Makefile.inc freeswan-1.96/Makefile.inc
---- freeswan-1.96.orig/Makefile.inc    Mon Mar 18 09:32:50 2002
-+++ freeswan-1.96/Makefile.inc Mon Mar 18 09:40:32 2002
+--- freeswan-1.97/Makefile.inc Fri Apr 12 04:37:17 2002
++++ freeswan-1.97/Makefile.inc.org     Wed May  1 18:28:17 2002
 @@ -45,7 +45,7 @@
  DESTDIR=
  
@@ -25,7 +24,7 @@ diff -Naur freeswan-1.96.orig/Makefile.inc freeswan-1.96/Makefile.inc
  CONFDIR=$(DESTDIR)$(FINALCONFDIR)
  
  # An attempt is made to automatically figure out where boot/shutdown scripts 
-@@ -74,17 +74,14 @@
+@@ -74,17 +74,18 @@
  # If none of those exists (or INC_RCDIRS is empty), INC_RCDEFAULT gets them.
  # With a non-null DESTDIR, INC_RCDEFAULT will be used unless one of the
  # INC_RCDIRS directories has been pre-created under DESTDIR.
@@ -42,11 +41,15 @@ diff -Naur freeswan-1.96.orig/Makefile.inc freeswan-1.96/Makefile.inc
 -              do if test -d $(DESTDIR)/$$d ; \
 -              then echo $$d ; exit 0 ; \
 -              fi ; done ; echo $(INC_RCDEFAULT) )
++#FINALRCDIR=$(shell for d in $(INC_RCDIRS) ; \
++#             do if test -d $(DESTDIR)/$$d ; \
++#             then echo $$d ; exit 0 ; \
++#             fi ; done ; echo $(INC_RCDEFAULT) )
 +FINALRCDIR=/etc/rc.d/init.d
  RCDIR=$(DESTDIR)$(FINALRCDIR)
  
  
-@@ -125,8 +122,8 @@
+@@ -126,8 +127,8 @@
  
  # extra compile flags, for userland and kernel stuff, e.g. -g for debug info
  # (caution, this stuff is still being sorted out, will change in future)
@@ -55,5 +58,5 @@ diff -Naur freeswan-1.96.orig/Makefile.inc freeswan-1.96/Makefile.inc
 +USERCOMPILE=$(OPT_FLAGS)
 +KLIPSCOMPILE=$(OPT_FLAGS)
  
- # extra options for use in kernel build
- KERNMAKEOPTS=
+ # command used to link/copy KLIPS into kernel source tree
+ # There are good reasons why this is "ln -s"; only people like distribution
index 3d42aff8a919a30f6101cd2a2d20fa68c0bc021d..f5151ad1d3905c07da5eddd4bceaf8386af2b3e4 100644 (file)
@@ -1,35 +1,36 @@
-diff -Naur freeswan-1.95.orig/utils/setup freeswan-1.95/utils/setup
---- freeswan-1.95.orig/utils/setup     Mon Feb 18 12:48:24 2002
-+++ freeswan-1.95/utils/setup  Mon Feb 18 20:58:50 2002
-@@ -30,9 +30,26 @@
+--- freeswan-1.97/utils/setup  Wed Jun 20 17:55:13 2001
++++ freeswan-1.97/utils/setup.org      Wed May  1 18:38:35 2002
+@@ -30,10 +30,28 @@
  # description: IPsec provides encrypted and authenticated communications; \
  # KLIPS is the kernel half of it, Pluto is the user-level management daemon.
  
 -me='ipsec setup'              # for messages
 +# Source function library
 +. /etc/rc.d/init.d/functions
++
 +# Get network config
 +. /etc/sysconfig/network
++
 +# Check that networking is up.
 +if is_yes "${NETWORKING}"; then
-+      if [ ! -f /var/lock/subsys/network ]; then
-+              # nls "ERROR: Networking is down. %s can't be run." ipsec
-+              msg_network_down ipsec
-+              exit 1
-+      fi
++       if [ ! -f /var/lock/subsys/network ]; then
++               # nls "ERROR: Networking is down. %s can't be run." ipsec
++               msg_network_down ipsec
++               exit 1
++       fi
 +else
-+      exit 0
++       exit 0
 +fi
++me='ipsec setup'               # for messages
 +
 +
-+
-+me='ipsec setup'              # for messages
  if test " $IPSEC_DIR" = " "   # if we were not called by the ipsec command
  then
-@@ -54,7 +71,7 @@
+       # we must establish a suitable PATH ourselves
+@@ -54,7 +72,7 @@
  if ! test "$found"
  then
        echo "cannot find ipsec command -- \`$1' aborted" |
@@ -38,7 +39,7 @@ diff -Naur freeswan-1.95.orig/utils/setup freeswan-1.95/utils/setup
        exit 1
  fi
  
-@@ -65,7 +82,7 @@
+@@ -65,7 +83,7 @@
  if test " $IPSEC_confreadstatus" != " "
  then
        echo "$IPSEC_confreadstatus -- \`$1' aborted" |
@@ -47,13 +48,7 @@ diff -Naur freeswan-1.95.orig/utils/setup freeswan-1.95/utils/setup
        exit 1
  fi
  IPSECsyslog=${IPSECsyslog-daemon.error}
-@@ -74,25 +91,77 @@
- # misc setup
- umask 022
--
-+#set -v
-+#set -x
+@@ -78,23 +96,73 @@
  
  # do it
  case "$1" in
@@ -63,35 +58,36 @@ diff -Naur freeswan-1.95.orig/utils/setup freeswan-1.95/utils/setup
 -              echo "permission denied (must be superuser)" |
 -                      logger -s -p $IPSECsyslog -t ipsec_setup 2>&1
 +  start|--start|_autostart)
-+      # Check if the service is already running?
-+      if [ ! -f /var/lock/subsys/ipsec ]; then
-+              # show "Starting %s service" ipsec
-+              msg_starting ipsec
-+              busy
-+              if test " `id -u`" != " 0"
-+              then
-+                  echo "permission denied (must be superuser)" |
-+                      logger -p $IPSECsyslog -t ipsec_setup 2>&1
-+                  fail
-+                  exit 1
-+              fi
-+              {
-+                  ipsec _realsetup $1 ;
-+                  RETVAL=$?;
-+              } 2>&1 | logger -p $IPSECsyslog -t ipsec_setup 2>&1
-+              
-+              if [ "$RETVAL" -eq 0 ];
-+              then
-+                  touch /var/lock/subsys/ipsec
-+                  ok
-+                  exit $RETVAL;
-+              fi
-+              fail
-+              exit $RETVAL
++       # Check if the service is already running?
++       if [ ! -f /var/lock/subsys/ipsec ]; then
++               # show "Starting %s service" ipsec
++               msg_starting ipsec
++               busy
++               if test " `id -u`" != " 0"
++               then
++                   echo "permission denied (must be superuser)" |
++                       logger -p $IPSECsyslog -t ipsec_setup 2>&1
++                   fail
++                   exit 1
++               fi
++               {
++                   ipsec _realsetup $1 ;
++                   RETVAL=$?;
++               } 2>&1 | logger -p $IPSECsyslog -t ipsec_setup 2>&1
++
++               if [ "$RETVAL" -eq 0 ];
++               then
++                   touch /var/lock/subsys/ipsec
++                   ok
++                   exit $RETVAL;
++               fi
++               fail
++               exit $RETVAL
++
++       else
++               # show "%s service is already running." ipsec
++               msg_already_running ipsec
 +              
-+      else
-+              # show "%s service is already running." ipsec
-+              msg_already_running ipsec
                exit 1
        fi
 -      tmp=/var/run/ipsec_setup.st
@@ -102,40 +98,41 @@ diff -Naur freeswan-1.95.orig/utils/setup freeswan-1.95/utils/setup
 -      st=`cat $tmp`
 -      rm -f $tmp
 -      exit $st
-+      ;;
-+
+-      ;;
++       ;;
 +  stop|--stop|_autostop)
 +        # Stop daemons.
 +        # show "Stopping %s service" ipsec
-+      if [ -f /var/lock/subsys/ipsec ]; then
-+              msg_stopping ipsec
-+              busy
-+              if test " `id -u`" != " 0"
-+              then
-+                  echo "permission denied (must be superuser)" |
-+                      logger -p $IPSECsyslog -t ipsec_setup 2>&1
-+                  fail
-+                  exit 1
-+              fi
-+              {
-+                  ipsec _realsetup $1 ;
-+                  RETVAL=$?;
-+              } 2>&1 | logger -p $IPSECsyslog -t ipsec_setup 2>&1
-+              
-+              rm -f /var/lock/subsys/ipsec
++       if [ -f /var/lock/subsys/ipsec ]; then
++               msg_stopping ipsec
++               busy
++               if test " `id -u`" != " 0"
++               then
++                   echo "permission denied (must be superuser)" |
++                       logger -p $IPSECsyslog -t ipsec_setup 2>&1
++                   fail
++                   exit 1
++               fi
++               {
++                   ipsec _realsetup $1 ;
++                   RETVAL=$?;
++               } 2>&1 | logger -p $IPSECsyslog -t ipsec_setup 2>&1
 +
-+              if [ "$RETVAL" -eq 0 ];
-+              then
-+                  ok
-+                  exit $RETVAL;
-+              fi
-+              fail
-+              exit $RETVAL
-+      else
-+              # show "%s service is not running." ipsec
-+              msg_not_running ipsec
-+              exit 1
-+      fi      
-       ;;
++               rm -f /var/lock/subsys/ipsec
++
++               if [ "$RETVAL" -eq 0 ];
++               then
++                   ok
++                   exit $RETVAL;
++               fi
++               fail
++               exit $RETVAL
++       else
++               # show "%s service is not running." ipsec
++               msg_not_running ipsec
++               exit 1
++       fi
    restart|--restart)
+       $0 stop
+       $0 start
index fb774f3a227fd69d503161b059b64a161c22a6b9..4c146b6a0c1e9fbd5722c9026af671a0163ed354 100644 (file)
@@ -1,14 +1,13 @@
-diff -Naur freeswan-1.95.orig/utils/Makefile freeswan-1.95/utils/Makefile
---- freeswan-1.95.orig/utils/Makefile  Wed Mar 13 15:36:51 2002
-+++ freeswan-1.95/utils/Makefile       Wed Mar 13 15:37:38 2002
-@@ -69,17 +69,19 @@
+--- freeswan-1.97/utils/Makefile       Mon Apr  1 22:05:27 2002
++++ freeswan-1.97/utils/Makefile.org   Wed May  1 18:41:09 2002
+@@ -71,17 +71,19 @@
  
  # generate RSA private key... if, and only if, /etc/ipsec.secrets does
  # not already exist
 -BLURB=-- not filled in because ipsec.secrets existed at build time --
 +# BLURB=-- not filled in because ipsec.secrets existed at build time --
-+# 
-+# This will be done in %post in spec file (radzio@pld.org.pl)
++#
++# This will be done in %post in spec file 
  secrets.eg:   secrets.proto ranbits rsasigkey
 -      rm -f $@
 -      umask 077 ; ( \
@@ -31,7 +30,7 @@ diff -Naur freeswan-1.95.orig/utils/Makefile freeswan-1.95/utils/Makefile
  
  # force full secrets-file build
  newsecrets:
-@@ -104,8 +106,8 @@
+@@ -106,8 +108,8 @@
                $(INSTMAN) $(PUB) $$f $(CMANDIR)/ipsec_$$f || exit 1 ; \
                ./manlink $(CMANDIR) ipsec_$$f ; \
        done
index 98d8a1aaabd4664c6a671dff1135ebc3ff81805f..add1480d3cc578a3eb7d921aa4c5251f5455afc3 100644 (file)
@@ -1,12 +1,11 @@
-diff -durN freeswan-1.3.orig1/utils/manlink freeswan-1.3/utils/manlink
---- freeswan-1.3.orig1/utils/manlink   Wed Jul  7 05:12:52 1999
-+++ freeswan-1.3/utils/manlink Tue Apr 25 11:38:27 2000
+--- freeswan-1.97/utils/manlink        Wed Jul  7 05:12:52 1999
++++ freeswan-1.97/utils/manlink.org    Wed May  1 18:41:59 2002
 @@ -49,7 +49,7 @@
                esac
                if test " $ff" != " $m"
                then
 -                      ln -f -s $m $ff
-+                      echo ".so $m" > $ff
++                  echo ".so $m" > $ff
                fi
        done
  done
This page took 0.125494 seconds and 4 git commands to generate.