]> git.pld-linux.org Git - packages/freenet6-client.git/blob - freenet6-client.spec
- BR: libstdc++-devel
[packages/freenet6-client.git] / freenet6-client.spec
1 Summary:        Hexago's TSP Client
2 Summary(pl.UTF-8):      Klient TSP Hexago
3 Name:           freenet6-client
4 Version:        5.1
5 Release:        1
6 License:        HPL 1.0
7 Group:          Applications/System
8 # Source0: http://www.go6.net/4105/file.asp?file_id=80
9 Source0:        gw6c-5_1-RELEASE-src.tar.gz
10 # Source0-md5:  5c5205dc58e82454a5d55a3efb4bf786
11 Source1:        %{name}.init
12 Source2:        %{name}.conf
13 Patch0:         %{name}-pld.patch
14 URL:            http://www.freenet6.net/
15 BuildRequires:  libstdc++-devel
16 Requires(post,preun):   /sbin/chkconfig
17 Requires:       glibc >= 2.2.1
18 Requires:       iproute2 >= 2.2.4
19 Requires:       net-tools >= 1.60
20 #Requires:      radvd >= 0.6.2
21 Requires:       rc-scripts
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 TSP is a new initiative launched by Hexago, a private company in
26 Canada involved in IPv6 since 1996, to facilitate a faster deployment
27 of an IPv6 Internet. The Internet is deployed worldwide over IPv4 so
28 this project's goal is large scale deployment of IPv6 by using
29 configured tunnels.
30
31 Configured tunneling is a transition method standardized by IETF to
32 use IPv6 in coexistence with IPv4 by encapsulating IPv6 packets over
33 IPv4. Any host already connected to Internet with IPv4 which has an
34 IPv6 stack can establish a link to the Internet IPv6.
35
36 Freenet6, developed by Viagenie in 1999/2000, was the first public
37 tunnel server service and one of the most used in the world to
38 automatically delegate one single IPv6 address to any host already
39 connected to an IPv4 network over configured tunnel simply by filling
40 a web form and running a script. TSP represents another very important
41 step to accelerate the large scale deployment of IPv6 to everyone on
42 the net.
43
44 Instead of a web interface to request configured tunnels and IPv6
45 addresses, TSP is a new model based on a client/server approach. A
46 protocol is used to request a single IPv6 address to a full IPv6
47 prefix from a client to a tunnel server according to the IPv6 broker
48 model. The protocol could be integrated directly into the operating
49 system to provide a service like DHCP but for requesting IPv6
50 addresses or prefixes over an IPv4 network (Internet).
51
52 %description -l pl.UTF-8
53 TSP to nowa inicjatywa zapoczątkowana przez Hexago - prywatną firmę z
54 Kanady zaangażowaną w IPv6 od 1996 roku - aby ułatwić szybszy rozwój
55 Internetu IPv6. Internet jest rozwinięty na całym świecie w oparciu o
56 IPv4, więc celem tego projektu jest rozwinięcie IPv6 na wielką skalę
57 poprzez użycie skonfigurowanych tuneli.
58
59 Skonfigurowane tunele to metoda przejściowa ustandaryzowana przez IETF
60 w celu używania IPv6 w koegzystencji z IPv4 poprzez pakowanie pakietów
61 IPv6 w IPv4. Dowolny host podłączony do Internetu po IPv4 mający stos
62 IPv6 może łączyć się z Internetem IPv6.
63
64 Freenet6 rozwijany przez Viagenie w latach 1999-2000 był pierwszym
65 publicznym serwerem tuneli i jednym z najbardziej używanych na świecie
66 do automatycznego delegowania pojedynczych adresów IPv6 do dowolnego
67 hosta już podłączonego do sieci IPv4 poprzez skonfigurowany tunel po
68 zwykłym wypełnieniu formularza WWW i uruchomieniu skryptu. TSP
69 reprezentuje kolejny bardzo ważny krok do przyspieszenia rozwoju IPv6
70 na szerszą skalę.
71
72 Zamiast interfejsu WWW do żądania skonfigurowanych tuneli i adresów
73 IPv6, TSP jest nowym modelem opartym na komunikacji klient/serwer.
74 Protokół jest używany do żądania od pojedynczego adresu IPv6 do
75 pełnego prefiksu IPv6 od klienta do serwera tuneli zgodnie z modelem
76 brokera IPv6. Protokół może być zintegrowany z systemem operacyjnym,
77 aby udostępnić usługę typu DHCP, ale do żądania adresów lub prefiksów
78 IPv6 po sieci IPv4 (Internecie).
79
80 %prep
81 %setup -q -n tspc-advanced
82 %patch0 -p1
83
84 %build
85 %{__make} all \
86         CC="%{__cc} %{rpmcflags} -I\$(INC) -Wall" \
87         target=linux \
88         installdir=%{_prefix}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/gw6c,/etc/rc.d/init.d}
93
94 %{__make} install \
95         target=linux \
96         installdir=$RPM_BUILD_ROOT%{_prefix} \
97         install_bin=$RPM_BUILD_ROOT%{_sbindir} \
98         install_man=$RPM_BUILD_ROOT%{_mandir} \
99         install_template=$RPM_BUILD_ROOT%{_datadir}/gw6c/template
100
101 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/freenet6
102 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/gw6c/gw6c.conf
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post
108 /sbin/chkconfig --add freenet6
109 if [ -f /var/lock/subsys/freenet6 ]; then
110         /etc/rc.d/init.d/freenet6 restart 1>&2
111 else
112         echo "Run \"/etc/rc.d/init.d/freenet6 start\" to start freenet6 connection"
113 fi
114
115 %preun
116 if [ "$1" = "0" ]; then
117         if [ -f /var/lock/subsys/freenet6 ]; then
118                 /etc/rc.d/init.d/freenet6 stop 1>&2
119         fi
120         /sbin/chkconfig --del freenet6
121 fi
122
123 %files
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_sbindir}/gw6c
126 %dir %{_sysconfdir}/gw6c
127 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gw6c/gw6c.conf
128 %attr(754,root,root) /etc/rc.d/init.d/*
129 %dir %{_datadir}/gw6c
130 %dir %{_datadir}/gw6c/template
131 %{_datadir}/gw6c/template/linux.sh
132 %{_mandir}/man5/*
133 %{_mandir}/man8/*
This page took 0.084109 seconds and 3 git commands to generate.