]> git.pld-linux.org Git - packages/freehdl.git/blob - freehdl.spec
- some raw description
[packages/freehdl.git] / freehdl.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4 %bcond_without  tests           # build without tests
5 #
6 Summary:        freehdl
7 Name:           freehdl
8 Version:        0.0.6
9 Release:        0.1
10 License:        GPL
11 # library is under lgpl but its not separated as package so all falls under GPL imo
12 Group:          Applications
13 Source0:        http://%{name}.seul.org/~enaroska/freehdl-%{version}.tar.gz
14 # Source0-md5:  bd168382c72f9fbd392f89ab2c5fddf8
15 URL:            http://freehdl.seul.org/
16 #BuildRequires: -
17 #BuildRequires: autoconf
18 #BuildRequires: automake
19 #BuildRequires: intltool
20 #BuildRequires: libtool
21 #Patch0: %{name}-DESTDIR.patch
22 #Requires(postun):      -
23 #Requires(pre,post):    -
24 #Requires(preun):       -
25 #Requires:      -
26 #Provides:      -
27 #Provides:      group(foo)
28 #Provides:      user(foo)
29 #Obsoletes:     -
30 #Conflicts:     -
31 #BuildArch:     noarch
32 #ExclusiveArch: %{ix86}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 FreeHDL is an project aiming to develop VHDL simulator with following capabilities:
37  * Has a graphical waveform viewer.
38  * Has a source level debugger.
39  * Is VHDL-93 compliant.
40  * Is of commercial quality. (on par with, say, V-System - it'll take us a while to get there, but that should be our aim)
41
42 %prep
43 %setup -q
44 #%setup -q -c -T
45 #%setup -q -n %{name}
46 #%setup -q -n %{name}-%{version}.orig -a 1
47 #%patch0 -p1
48
49 # undos the source
50 #find '(' -name '*.php' -o -name '*.inc' ')' -print0 | xargs -0 %{__sed} -i -e 's,\r$,,'
51
52 # remove CVS control files
53 #find -name CVS -print0 | xargs -0 rm -rf
54
55 # you'll need this if you cp -a complete dir in source
56 # cleanup backups after patching
57 #find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
58
59 %build
60 # if ac/am/* rebuilding is necessary, do it in this order and add
61 # appropriate BuildRequires
62 #%%{__intltoolize}
63 #%%{__gettextize}
64 #%%{__libtoolize}
65 #%%{__aclocal}
66 #%%{__autoconf}
67 #%%{__autoheader}
68 #%%{__automake}
69 # if not running libtool or automake, but config.sub is too old:
70 #cp -f /usr/share/automake/config.sub .
71 %configure
72 %{__make}
73
74 #%{__make} \
75 #       CFLAGS="%{rpmcflags}" \
76 #       LDFLAGS="%{rpmldflags}"
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 # create directories if necessary
81 #install -d $RPM_BUILD_ROOT
82 #install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86 #install -d $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/
87 #install AUTHORS COPYING COPYING.LIB README README.AIRE README.gen-nodes README.libraries README.v2cc README.vaul ChangeLog $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS COPYING COPYING.LIB README README.AIRE README.gen-nodes README.libraries README.v2cc README.vaul ChangeLog
98 %attr(755,root,root) %{_libdir}/*.so*
99 %{_libdir}/*.la
100 %{_libdir}/*.a
101 %dir %{_libdir}/freehdl
102 %attr(755,root,root) %{_libdir}/freehdl/*.so*
103 %{_libdir}/freehdl/*.la
104 %{_libdir}/freehdl/*.a
105 %{_datadir}/freehdl
106 %dir %{_includedir}/freehdl
107 %{_includedir}/freehdl/*h
108 %{_includedir}/freehdl/*t
109 %attr(755,root,root) %{_bindir}/*
110 %{_pkgconfigdir}/freehdl.pc
111 #%{_docdir}/%{name}-%{version}
112 %{_mandir}/man[15]/*
This page took 0.057131 seconds and 3 git commands to generate.