]> git.pld-linux.org Git - packages/freecivac.git/blob - freecivac.spec
- unix -> Unix
[packages/freecivac.git] / freecivac.spec
1 #
2 # TODO: 
3 #  - fix app name (files are freeciv.mo and so on, so conflicts with freeciv)
4 # Conditional build:
5 %define snapdate 20050502
6 Summary:        FREE CIVilization clone - AC version
7 Summary(pl.UTF-8):      Klon FREE CIVilization - wersja AC
8 Name:           freecivac
9 Version:        snap.%{snapdate}
10 Release:        0.1
11 License:        GPL
12 Group:          X11/Applications/Games/Strategy
13 Source0:        http://vorlon.icpnet.pl/~agaran/%{name}-snap-%{snapdate}.tgz
14 # Source0-md5:  5dc07e4f5cae347241b42341ea10d83f
15 Patch0:         %{name}-gtk2-m4.diff
16 Patch1:         %{name}-slang.diff
17 URL:            http://freecivac.sourceforge.net/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21 # needs to be resolved, mo and /usr/share/freeciv conflict
22 Conflicts:      freeciv
23
24 %define         _appdefsdir     /usr/X11R6/lib/X11/app-defaults
25
26 %description
27 Free clone of Sid Meier's Civilization. Free Civilization clone for
28 Unix and X. This is multiplayer strategic game and you can also play
29 against computer-AI players.
30
31 %description -l pl.UTF-8
32 Darmowy klon Civilization Sida Meiera, dziaĹ\82ajÄ\85cy pod Uniksem i X.
33 Jest to gra strategiczna dla wielu graczy, moĹźna graÄ\87 takĹźe przeciwko
34 komputerowej AI.
35
36 # yes, i know ugly way, but i wanted to commit what i done @home maybe
37 # somebody else could fix rest, 
38 %prep
39 %setup -q -n %{name}
40 %patch0 -p1
41 %patch1 -p1
42 rm configure.in
43 mv m4/x.252 m4/x.m4
44 perl -pi -e 's/-lslang-utf8/-lslang/' server/Makefile.am
45 perl -pi -e 's/-lslang-utf8/-lslang/' client/Makefile.am
46 chmod +x client/gui-gtk-2.0/rc2c
47
48 %build
49 #%%{__gettextize}
50 #autoupdate
51 %{__aclocal} -I m4
52 %{__autoconf}
53 %{__autoheader}
54 %{__automake}
55 %configure
56
57 %{__make} \
58         ARFLAGS=rcs
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 #install -d $RPM_BUILD_ROOT%{_appdefsdir},%{_desktopdir},%{_pixmapsdir}}
66
67 #rm $RPM_BUILD_ROOT%{_datadir}/freeciv/Freeciv
68
69 #install %{SOURCE1} %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
70 #install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
71 #install %{SOURCE5} $RPM_BUILD_ROOT%{_datadir}/freeciv/stdsounds.soundspec
72 #cp -ar stdsounds $RPM_BUILD_ROOT%{_datadir}/freeciv
73
74 %find_lang freeciv 
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files -f freeciv.lang
80 %defattr(644,root,root,755)
81 %doc AUTHORS README ChangeLog NEWS
82 %attr(755,root,root) %{_bindir}/*
83 %{_datadir}/freeciv
84 #%%{_desktopdir}/*
85 #%%{_pixmapsdir}/*
This page took 0.071839 seconds and 3 git commands to generate.