]> git.pld-linux.org Git - packages/fpm.git/commitdiff
new, version 0.4.36
authorElan Ruusamäe <glen@delfi.ee>
Thu, 20 Jun 2013 14:27:58 +0000 (17:27 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Thu, 20 Jun 2013 14:28:22 +0000 (17:28 +0300)
created with gem2rpm

ruby-fpm.spec [new file with mode: 0644]

diff --git a/ruby-fpm.spec b/ruby-fpm.spec
new file mode 100644 (file)
index 0000000..c4f29df
--- /dev/null
@@ -0,0 +1,62 @@
+#
+# Conditional build:
+%bcond_with    tests           # build without tests
+
+%define        pkgname fpm
+Summary:       fpm - package building and mangling
+Name:          ruby-%{pkgname}
+Version:       0.4.36
+Release:       1
+License:       GPL v2+ or Ruby
+Group:         Development/Languages
+Source0:       http://rubygems.org/downloads/%{pkgname}-%{version}.gem
+# Source0-md5: 722802ab7f9ab4c2befa26551314fcff
+URL:           https://github.com/jordansissel/fpm
+BuildRequires: rpm-rubyprov
+BuildRequires: rpmbuild(macros) >= 1.656
+BuildRequires: sed >= 4.0
+%if %{with tests}
+BuildRequires: ruby-insist < 0.1
+BuildRequires: ruby-insist >= 0.0.5
+BuildRequires: ruby-minitest
+BuildRequires: ruby-pry
+BuildRequires: ruby-rspec
+BuildRequires: ruby-rush
+%endif
+Requires:      ruby-arr-pm < 0.1
+Requires:      ruby-arr-pm >= 0.0.8
+Requires:      ruby-backports >= 2.6.2
+Requires:      ruby-cabin >= 0.6.0
+Requires:      ruby-childprocess
+Requires:      ruby-clamp = 0.6.0
+Requires:      ruby-ftw < 0.1
+Requires:      ruby-ftw >= 0.0.30
+Requires:      ruby-json < 1.8
+Requires:      ruby-json >= 1.7.7
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Convert directories, rpms, python eggs, rubygems, and more to rpms,
+debs, solaris packages and more. Win at package management without
+wasting pointless hours debugging bad rpm specs!
+
+
+%prep
+%setup -q -n %{pkgname}-%{version}
+%{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
+
+%install
+rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
+cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
+cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/fpm
+%{ruby_vendorlibdir}/%{pkgname}.rb
+%{ruby_vendorlibdir}/%{pkgname}
This page took 0.080987 seconds and 4 git commands to generate.