]> git.pld-linux.org Git - packages/fpm.git/commitdiff
install templates
authorElan Ruusamäe <glen@delfi.ee>
Mon, 10 Aug 2015 10:14:20 +0000 (13:14 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 10 Aug 2015 10:14:20 +0000 (13:14 +0300)
ruby-fpm.spec
templates.patch [new file with mode: 0644]

index 6f87ad4f233e88269a7b14dc4b53dc0d77164dad..f51828915a931b09053b5606d5ef52ef009eed4f 100644 (file)
@@ -11,6 +11,7 @@ License:      MIT-like
 Group:         Development/Languages
 Source0:       http://rubygems.org/downloads/%{pkgname}-%{version}.gem
 # Source0-md5: 4d82b0484db150928330b04bb44c92a2
+Patch0:                templates.patch
 URL:           https://github.com/jordansissel/fpm
 BuildRequires: rpm-rubyprov
 BuildRequires: rpmbuild(macros) >= 1.665
@@ -42,6 +43,7 @@ wasting pointless hours debugging bad rpm specs!
 
 %prep
 %setup -q -n %{pkgname}-%{version}
+%patch0 -p1
 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
 
 %build
@@ -53,6 +55,7 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir}}
 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
+cp -a templates $RPM_BUILD_ROOT%{ruby_vendorlibdir}/%{pkgname}
 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
 
 %clean
diff --git a/templates.patch b/templates.patch
new file mode 100644 (file)
index 0000000..1b6d558
--- /dev/null
@@ -0,0 +1,11 @@
+--- ./lib/fpm/package.rb~      2015-08-10 13:11:29.000000000 +0300
++++ ./lib/fpm/package.rb       2015-08-10 13:12:44.109522857 +0300
+@@ -319,7 +319,7 @@
+   end # def files
+   def template_dir
+-    File.expand_path(File.join(File.dirname(__FILE__), "..", "..", "templates"))
++    File.expand_path(File.join(File.dirname(__FILE__), "templates"))
+   end
+   def template(path)
This page took 0.092141 seconds and 4 git commands to generate.