]> git.pld-linux.org Git - packages/fpm-cookery.git/commitdiff
don't process depends for build dependencies
authorElan Ruusamäe <glen@delfi.ee>
Mon, 31 Aug 2015 10:50:21 +0000 (13:50 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Mon, 31 Aug 2015 10:50:21 +0000 (13:50 +0300)
in pld all -dev packages require appropriate runtime packages

https://github.com/bernd/fpm-cookery/issues/123
https://github.com/bernd/fpm-cookery/pull/116#issuecomment-136329952

fpm-cookery.spec
no-runtime-deps-during-build.patch [new file with mode: 0644]

index 77ce461a0a5b18b353a6cceaf980ca3fc425fe77..bd09dbd546fe116549b7e3eea3221082a72194c6 100644 (file)
@@ -5,13 +5,14 @@
 Summary:       A tool for building software packages with fpm
 Name:          fpm-cookery
 Version:       0.29.0
-Release:       0.5
+Release:       0.6
 License:       BSD
 Group:         Development/Languages
 Source0:       http://rubygems.org/downloads/%{name}-%{version}.gem
 # Source0-md5: bd210d6acb6a0519f8d940200917eefe
 Patch0:                svn-ignore-externals.patch
 Patch1:                rpm-attributes.patch
+Patch2:                no-runtime-deps-during-build.patch
 URL:           https://github.com/bernd/fpm-cookery
 BuildRequires: rpm-rubyprov
 BuildRequires: rpmbuild(macros) >= 1.656
@@ -42,6 +43,7 @@ A tool for building software packages with fpm.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
 
 %build
diff --git a/no-runtime-deps-during-build.patch b/no-runtime-deps-during-build.patch
new file mode 100644 (file)
index 0000000..726762d
--- /dev/null
@@ -0,0 +1,18 @@
+https://github.com/bernd/fpm-cookery/issues/123
+
+diff --git a/lib/fpm/cookery/dependency_inspector.rb b/lib/fpm/cookery/dependency_inspector.rb
+index bd311dd..875833b 100644
+--- a/lib/fpm/cookery/dependency_inspector.rb
++++ b/lib/fpm/cookery/dependency_inspector.rb
+@@ -20,9 +20,9 @@ module FPM
+           return
+         end
+-        Log.info "Verifying build_depends and depends with Puppet"
++        Log.info "Verifying build_depends with Puppet"
+-        missing = missing_packages(build_depends + depends)
++        missing = missing_packages(build_depends)
+         if missing.length == 0
+           Log.info "All build_depends and depends packages installed"
This page took 0.079079 seconds and 4 git commands to generate.