]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
- updated to version 1.1.31
[packages/fox.git] / fox.spec
1 Summary:        The FOX C++ GUI Toolkit
2 Summary(pl):    FOX - toolkit graficzny w C++
3 Name:           fox
4 Version:        1.1.31
5 Release:        1
6 License:        LGPL
7 Group:          X11/Libraries
8 #Source0ActiveFTP
9 Source0:        http://ftp.fox-toolkit.org/ftp/%{name}-%{version}.tar.gz
10 # Source0-md5:  bf6e440398f37bf485c40b2793888936
11 Patch0:         %{name}-opt.patch
12 URL:            http://www.fox-toolkit.org/fox.html
13 BuildRequires:  OpenGL-devel
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libjpeg-devel
17 BuildRequires:  libpng-devel
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtiff-devel
20 BuildRequires:  libtool
21 Requires:       OpenGL
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
25
26 %description
27 FOX is a C++-Based Library for Graphical User Interface Development
28 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
29 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
30 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
31 graphics. Subclassing of basic FOX widgets allows for easy extension
32 beyond the built-in widgets by application writers.
33
34 %description -l pl
35 FOX jest bibliotek± bazuj±c± na C++ do projektowania graficznych
36 interfejsów u¿ytkownika. Obs³uguje wiele w³a¶ciwo¶ci wspó³czesnych
37 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
38 liczniki, przetwarznie w tle, automatyczne uaktualnianie GUI, obs³ugê
39 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalaj± na ³atwe
40 rozszerzanie.
41
42 %package progs
43 Summary:        FOX example applications
44 Summary(pl):    Przyk³ady aplikacji w FOX
45 Group:          X11/Applications
46 Requires:       %{name} = %{version}
47 Obsoletes:      %{name}-example-apps
48
49 %description progs
50 Editor and file browser, written with FOX.
51
52 %description progs -l pl
53 Edytor i przegl±darka plików napisane z u¿yciem toolkitu FOX.
54
55 %package devel
56 Summary:        Header files and development documentation for the FOX library
57 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki FOX
58 Group:          X11/Development/Libraries
59 Requires:       %{name} = %{version}
60
61 %description devel
62 Header files and development documentation for the FOX library.
63
64 %description devel -l pl
65 Pliki nag³ówkowe i dokumentacja programisty do biblioteki FOX.
66
67 %package static
68 Summary:        FOX static libraries
69 Summary(pl):    Biblioteki statyczne FOX
70 Group:          X11/Development/Libraries
71 Requires:       %{name}-devel = %{version}
72
73 %description static
74 FOX static libraries.
75
76 %description static -l pl
77 Biblioteki statyczne FOX.
78
79 %prep
80 %setup -q
81 %patch -p1
82
83 %build
84 rm -f missing
85 %{__libtoolize}
86 %{__aclocal}
87 %{__autoconf}
88 %{__automake}
89 %configure LDFLAGS="-L/usr/X11R6/lib"\
90         --with-opengl \
91         %{?debug:--enable-debug}%{!?_debug:--enable-release}
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT%{_datadir}
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 cp -p pathfinder/.libs/PathFinder $RPM_BUILD_ROOT%{_bindir}
102
103 rm -f doc/Makefile* doc/*/Makefile*
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   -p /sbin/ldconfig
109 %postun -p /sbin/ldconfig
110
111 %files
112 %defattr(644,root,root,755)
113 %doc AUTHORS README
114 %attr(755,root,root) %{_libdir}/lib*.so.*.*
115
116 %files progs
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_bindir}/adie
119 %attr(755,root,root) %{_bindir}/calculator
120 %attr(755,root,root) %{_bindir}/PathFinder
121
122 %files devel
123 %defattr(644,root,root,755)
124 %doc ADDITIONS TRACING doc
125 %attr(755,root,root) %{_bindir}/reswrap
126 %attr(755,root,root) %{_libdir}/lib*.so
127 %{_libdir}/lib*.la
128 %{_mandir}/man1/*
129 %{_includedir}/fox
130
131 %files static
132 %defattr(644,root,root,755)
133 %{_libdir}/lib*.a
This page took 0.073084 seconds and 4 git commands to generate.