]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
- BR: pkgconfig
[packages/fox.git] / fox.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        The FOX C++ GUI Toolkit
6 Summary(pl.UTF-8):      FOX - toolkit graficzny w C++
7 Name:           fox
8 Version:        1.7.19
9 Release:        5
10 License:        LGPL
11 Group:          X11/Libraries
12 Source0:        ftp://ftp.fox-toolkit.com/pub/%{name}-%{version}.tar.gz
13 # Source0-md5:  fb4d0934be26c27c7e76fcbefe2b5d30
14 Patch0:         %{name}-opt.patch
15 Patch1:         %{name}-link.patch
16 Patch2:         %{name}-Makefile.patch
17 URL:            http://www.fox-toolkit.org/
18 BuildRequires:  OpenGL-GLU-devel
19 BuildRequires:  autoconf >= 2.59-9
20 BuildRequires:  automake
21 BuildRequires:  bzip2-devel >= 1.0.2
22 BuildRequires:  cups-devel
23 BuildRequires:  doxygen
24 BuildRequires:  graphviz
25 BuildRequires:  libjpeg-devel >= 6b
26 BuildRequires:  libpng-devel >= 1.2.5
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtiff-devel >= 3.5.7
29 BuildRequires:  libtool >= 2:1.5
30 BuildRequires:  pkgconfig
31 BuildRequires:  xorg-lib-libXcursor-devel
32 BuildRequires:  xorg-lib-libXext-devel
33 BuildRequires:  xorg-lib-libXft-devel
34 BuildRequires:  xorg-lib-libXrandr-devel
35 BuildRequires:  zlib-devel >= 1.1.4
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
39
40 %description
41 FOX is a C++-Based Library for Graphical User Interface Development
42 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
43 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
44 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
45 graphics. Subclassing of basic FOX widgets allows for easy extension
46 beyond the built-in widgets by application writers.
47
48 %description -l pl.UTF-8
49 FOX jest biblioteką bazującą na C++ do projektowania graficznych
50 interfejsów użytkownika. Obsługuje wiele właściwości współczesnych
51 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
52 liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obsługę
53 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalają na łatwe
54 rozszerzanie.
55
56 %package progs
57 Summary:        FOX example applications
58 Summary(pl.UTF-8):      Przykłady aplikacji w FOX
59 Group:          X11/Applications
60 Requires:       %{name} = %{version}-%{release}
61 Obsoletes:      fox-example-apps
62
63 %description progs
64 Editor and file browser, written with FOX.
65
66 %description progs -l pl.UTF-8
67 Edytor i przeglądarka plików napisane z użyciem toolkitu FOX.
68
69 %package devel
70 Summary:        Header files for FOX library
71 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FOX
72 Group:          X11/Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       OpenGL-GLU-devel
75 Requires:       bzip2-devel >= 1.0.2
76 Requires:       cups-devel
77 Requires:       libjpeg-devel >= 6b
78 Requires:       libpng-devel >= 1.2.5
79 Requires:       libstdc++-devel
80 Requires:       libtiff-devel >= 3.5.7
81 Requires:       xorg-lib-libXcursor-devel
82 Requires:       xorg-lib-libXext-devel
83 Requires:       xorg-lib-libXft-devel
84 Requires:       xorg-lib-libXrandr-devel
85 Requires:       zlib-devel >= 1.1.4
86
87 %description devel
88 Header files for FOX library.
89
90 %description devel -l pl.UTF-8
91 Pliki nagłówkowe biblioteki FOX.
92
93 %package static
94 Summary:        FOX static libraries
95 Summary(pl.UTF-8):      Biblioteki statyczne FOX
96 Group:          X11/Development/Libraries
97 Requires:       %{name}-devel = %{version}-%{release}
98
99 %description static
100 FOX static libraries.
101
102 %description static -l pl.UTF-8
103 Biblioteki statyczne FOX.
104
105 %package doc
106 Summary:        Development documentation for FOX library
107 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki FOX
108 Group:          X11/Development/Libraries
109
110 %description doc
111 Development documentation for FOX library.
112
113 %description doc -l pl.UTF-8
114 Dokumentacja programisty do biblioteki FOX.
115
116 %package examples
117 Summary:        FOX - example programs
118 Summary(pl.UTF-8):      FOX - programy przykładowe
119 Group:          X11/Development/Libraries
120 Requires:       %{name}-devel = %{version}-%{release}
121
122 %description examples
123 FOX - example programs.
124
125 %description examples -l pl.UTF-8
126 FOX - przykładowe programy.
127
128 %prep
129 %setup -q
130 %patch0 -p1
131 %patch1 -p1
132 %patch2 -p1
133
134 %build
135 %{__libtoolize}
136 %{__aclocal}
137 %{__autoconf}
138 %{__automake}
139 %configure \
140         --enable-cups \
141         %{?debug:--enable-debug}%{!?debug:--enable-release} \
142         --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no} \
143         --with-opengl \
144         --with-xft \
145         --with-shape \
146         --with-xshm \
147         --with-xcursor \
148         --with-xrandr \
149         --with-xim
150
151 %{__make}
152
153 %{__make} -C doc docs
154
155 %install
156 rm -rf $RPM_BUILD_ROOT
157 install -d $RPM_BUILD_ROOT{%{_datadir},%{_examplesdir}/%{name}-%{version}}
158
159 %{__make} install \
160         DESTDIR=$RPM_BUILD_ROOT
161
162 ln -sf libFOX-1.7.so $RPM_BUILD_ROOT%{_libdir}/libFOX.so
163
164 rm -f doc/Makefile* doc/*/Makefile*
165
166 %{__make} -C tests clean
167 cp -r tests/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
168
169 %clean
170 rm -rf $RPM_BUILD_ROOT
171
172 %post   -p /sbin/ldconfig
173 %postun -p /sbin/ldconfig
174
175 %files
176 %defattr(644,root,root,755)
177 %doc AUTHORS LICENSE_ADDENDUM README
178 %attr(755,root,root) %{_libdir}/libCHART-1.7.so.*.*.*
179 %attr(755,root,root) %ghost %{_libdir}/libCHART-1.7.so.0
180 %attr(755,root,root) %{_libdir}/libFOX-1.7.so.*.*.*
181 %attr(755,root,root) %ghost %{_libdir}/libFOX-1.7.so.0
182 %attr(755,root,root) %{_bindir}/ControlPanel
183
184 %files progs
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_bindir}/adie
187 %attr(755,root,root) %{_bindir}/calculator
188 %attr(755,root,root) %{_bindir}/PathFinder
189 %attr(755,root,root) %{_bindir}/shutterbug
190 %attr(755,root,root) %{_bindir}/Adie.stx
191 %{_mandir}/man1/*
192
193 %files devel
194 %defattr(644,root,root,755)
195 %doc ADDITIONS TRACING
196 %attr(755,root,root) %{_bindir}/fox-config
197 %attr(755,root,root) %{_bindir}/reswrap
198 %attr(755,root,root) %{_libdir}/libCHART-1.7.so
199 %attr(755,root,root) %{_libdir}/libFOX-1.7.so
200 %attr(755,root,root) %{_libdir}/libFOX.so
201 %{_libdir}/libCHART-1.7.la
202 %{_libdir}/libFOX-1.7.la
203 %{_includedir}/fox-1.7
204 %{_pkgconfigdir}/fox.pc
205
206 %if %{with static_libs}
207 %files static
208 %defattr(644,root,root,755)
209 %{_libdir}/libCHART-1.7.a
210 %{_libdir}/libFOX-1.7.a
211 %endif
212
213 %files doc
214 %defattr(644,root,root,755)
215 %doc doc/*
216
217 %files examples
218 %defattr(644,root,root,755)
219 %{_examplesdir}/%{name}-%{version}
This page took 0.073452 seconds and 4 git commands to generate.