]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
- fix LDFLAGS
[packages/fox.git] / fox.spec
1 Summary:        The FOX C++ GUI Toolkit
2 Summary(pl):    FOX - toolkit graficzny w C++
3 Name:           fox
4 Version:        1.1.44
5 Release:        1
6 License:        LGPL
7 Group:          X11/Libraries
8 #Source0ActiveFTP
9 Source0:        http://ftp.fox-toolkit.org/ftp/%{name}-%{version}.tar.gz
10 # Source0-md5:  17db2e2a53e2a090964c7059318c62f6
11 Patch0:         %{name}-opt.patch
12 Patch1:         %{name}-link.patch
13 URL:            http://www.fox-toolkit.org/fox.html
14 BuildRequires:  OpenGL-devel
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  libjpeg-devel
18 BuildRequires:  libpng-devel
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtiff-devel
21 BuildRequires:  libtool
22 Requires:       OpenGL
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
26
27 %description
28 FOX is a C++-Based Library for Graphical User Interface Development
29 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
30 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
31 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
32 graphics. Subclassing of basic FOX widgets allows for easy extension
33 beyond the built-in widgets by application writers.
34
35 %description -l pl
36 FOX jest bibliotek± bazuj±c± na C++ do projektowania graficznych
37 interfejsów u¿ytkownika. Obs³uguje wiele w³a¶ciwo¶ci wspó³czesnych
38 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
39 liczniki, przetwarznie w tle, automatyczne uaktualnianie GUI, obs³ugê
40 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalaj± na ³atwe
41 rozszerzanie.
42
43 %package progs
44 Summary:        FOX example applications
45 Summary(pl):    Przyk³ady aplikacji w FOX
46 Group:          X11/Applications
47 Requires:       %{name} = %{version}
48 Obsoletes:      %{name}-example-apps
49
50 %description progs
51 Editor and file browser, written with FOX.
52
53 %description progs -l pl
54 Edytor i przegl±darka plików napisane z u¿yciem toolkitu FOX.
55
56 %package devel
57 Summary:        Header files and development documentation for the FOX library
58 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki FOX
59 Group:          X11/Development/Libraries
60 Requires:       %{name} = %{version}
61
62 %description devel
63 Header files and development documentation for the FOX library.
64
65 %description devel -l pl
66 Pliki nag³ówkowe i dokumentacja programisty do biblioteki FOX.
67
68 %package static
69 Summary:        FOX static libraries
70 Summary(pl):    Biblioteki statyczne FOX
71 Group:          X11/Development/Libraries
72 Requires:       %{name}-devel = %{version}
73
74 %description static
75 FOX static libraries.
76
77 %description static -l pl
78 Biblioteki statyczne FOX.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %patch1 -p1
84
85 %build
86 %{__libtoolize}
87 %{__aclocal}
88 %{__autoconf}
89 %{__automake}
90 LDFLAGS="%{rpmldflags} -L/usr/X11R6/%{_lib}"
91 %configure \
92         --with-opengl \
93         %{?debug:--enable-debug}%{!?_debug:--enable-release}
94 %{__make}
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 install -d $RPM_BUILD_ROOT%{_datadir}
99
100 # new fox installs headers in include/fox-1.1, but apps expect them as <fox/*.h>
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT \
103         foxincludedir=%{_includedir}/fox \
104         chartincludedir=%{_includedir}/fox/chart
105
106 ln -sf libFOX-1.1.so $RPM_BUILD_ROOT%{_libdir}/libFOX.so
107
108 rm -f doc/Makefile* doc/*/Makefile*
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %files
117 %defattr(644,root,root,755)
118 %doc AUTHORS LICENSE_ADDENDUM README
119 %attr(755,root,root) %{_libdir}/lib*.so.*.*
120
121 %files progs
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_bindir}/adie
124 %attr(755,root,root) %{_bindir}/calculator
125 %attr(755,root,root) %{_bindir}/PathFinder
126 %attr(755,root,root) %{_bindir}/shutterbug
127
128 %files devel
129 %defattr(644,root,root,755)
130 %doc ADDITIONS TRACING doc
131 %attr(755,root,root) %{_bindir}/reswrap
132 %attr(755,root,root) %{_libdir}/lib*.so
133 %{_libdir}/lib*.la
134 %{_mandir}/man1/*
135 %{_includedir}/fox
136
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/lib*.a
This page took 0.11697 seconds and 4 git commands to generate.