]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
- up to 1.6.3
[packages/fox.git] / fox.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        The FOX C++ GUI Toolkit
6 Summary(pl):    FOX - toolkit graficzny w C++
7 Name:           fox
8 Version:        1.6.3
9 Release:        1
10 License:        LGPL
11 Group:          X11/Libraries
12 Source0:        ftp://ftp.fox-toolkit.com/pub/%{name}-%{version}.tar.gz
13 # Source0-md5:  67f7b3d4fdc4e4d466cee8ff9ea7b519
14 Patch0:         %{name}-opt.patch
15 Patch1:         %{name}-link.patch
16 Patch2:         %{name}-Makefile.patch
17 URL:            http://www.fox-toolkit.org/fox.html
18 BuildRequires:  OpenGL-GLU-devel
19 BuildRequires:  autoconf >= 2.59-9
20 BuildRequires:  automake
21 BuildRequires:  bzip2-devel >= 1.0.2
22 BuildRequires:  libjpeg-devel >= 6b
23 BuildRequires:  libpng-devel >= 1.2.5
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtiff-devel >= 3.5.7
26 BuildRequires:  libtool >= 2:1.5
27 BuildRequires:  xorg-lib-libXcursor-devel
28 BuildRequires:  xorg-lib-libXext-devel
29 BuildRequires:  xorg-lib-libXft-devel
30 BuildRequires:  xorg-lib-libXrandr-devel
31 BuildRequires:  zlib-devel >= 1.1.4
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
35
36 %description
37 FOX is a C++-Based Library for Graphical User Interface Development
38 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
39 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
40 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
41 graphics. Subclassing of basic FOX widgets allows for easy extension
42 beyond the built-in widgets by application writers.
43
44 %description -l pl
45 FOX jest bibliotek± bazuj±c± na C++ do projektowania graficznych
46 interfejsów u¿ytkownika. Obs³uguje wiele w³a¶ciwo¶ci wspó³czesnych
47 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
48 liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obs³ugê
49 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalaj± na ³atwe
50 rozszerzanie.
51
52 %package progs
53 Summary:        FOX example applications
54 Summary(pl):    Przyk³ady aplikacji w FOX
55 Group:          X11/Applications
56 Requires:       %{name} = %{version}-%{release}
57 Obsoletes:      fox-example-apps
58
59 %description progs
60 Editor and file browser, written with FOX.
61
62 %description progs -l pl
63 Edytor i przegl±darka plików napisane z u¿yciem toolkitu FOX.
64
65 %package devel
66 Summary:        Header files for FOX library
67 Summary(pl):    Pliki nag³ówkowe biblioteki FOX
68 Group:          X11/Development/Libraries
69 Requires:       %{name} = %{version}-%{release}
70 Requires:       OpenGL-GLU-devel
71 Requires:       bzip2-devel >= 1.0.2
72 Requires:       libjpeg-devel >= 6b
73 Requires:       libpng-devel >= 1.2.5
74 Requires:       libstdc++-devel
75 Requires:       libtiff-devel >= 3.5.7
76 Requires:       xorg-lib-libXcursor-devel
77 Requires:       xorg-lib-libXext-devel
78 Requires:       xorg-lib-libXft-devel
79 Requires:       xorg-lib-libXrandr-devel
80 Requires:       zlib-devel >= 1.1.4
81
82 %description devel
83 Header files for FOX library.
84
85 %description devel -l pl
86 Pliki nag³ówkowe biblioteki FOX.
87
88 %package static
89 Summary:        FOX static libraries
90 Summary(pl):    Biblioteki statyczne FOX
91 Group:          X11/Development/Libraries
92 Requires:       %{name}-devel = %{version}-%{release}
93
94 %description static
95 FOX static libraries.
96
97 %description static -l pl
98 Biblioteki statyczne FOX.
99
100 %package doc
101 Summary:        Development documentation for FOX library
102 Summary(pl):    Dokumentacja programisty do biblioteki FOX
103 Group:          X11/Development/Libraries
104
105 %description doc
106 Development documentation for FOX library.
107
108 %description doc -l pl
109 Dokumentacja programisty do biblioteki FOX.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114 %patch1 -p1
115 %patch2 -p1
116
117 %build
118 %{__libtoolize}
119 %{__aclocal}
120 %{__autoconf}
121 %{__automake}
122 %configure \
123         %{?debug:--enable-debug}%{!?debug:--enable-release} \
124         --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no} \
125         --with-opengl \
126         --with-xft
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 install -d $RPM_BUILD_ROOT%{_datadir}
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 ln -sf libFOX-1.6.so $RPM_BUILD_ROOT%{_libdir}/libFOX.so
137
138 rm -f doc/Makefile* doc/*/Makefile*
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -p /sbin/ldconfig
144 %postun -p /sbin/ldconfig
145
146 %files
147 %defattr(644,root,root,755)
148 %doc AUTHORS LICENSE_ADDENDUM README
149 %attr(755,root,root) %{_libdir}/lib*.so.*.*
150
151 %files progs
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_bindir}/adie
154 %attr(755,root,root) %{_bindir}/calculator
155 %attr(755,root,root) %{_bindir}/PathFinder
156 %attr(755,root,root) %{_bindir}/shutterbug
157 %attr(755,root,root) %{_bindir}/Adie.stx
158 %{_mandir}/man1/*
159
160 %files devel
161 %defattr(644,root,root,755)
162 %doc ADDITIONS TRACING
163 %attr(755,root,root) %{_bindir}/fox-config
164 %attr(755,root,root) %{_bindir}/reswrap
165 %attr(755,root,root) %{_libdir}/lib*.so
166 %{_libdir}/lib*.la
167 %{_includedir}/fox-1.6
168
169 %if %{with static_libs}
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/lib*.a
173 %endif
174
175 %files doc
176 %defattr(644,root,root,755)
177 %doc doc/*
This page took 0.040812 seconds and 4 git commands to generate.