]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
- typos / formatting / etc.
[packages/fox.git] / fox.spec
1 Summary:        The FOX C++ GUI Toolkit
2 Summary(pl):    FOX - toolkit graficzny w C++
3 Name:           fox
4 Version:        1.2.9
5 Release:        2
6 License:        LGPL
7 Group:          X11/Libraries
8 Source0:        http://www.fox-toolkit.org/ftp/%{name}-%{version}.tar.gz
9 # Source0-md5:  6cf5a0562ea2a097e6d1e0c4fd9d1bba
10 Patch0:         %{name}-opt.patch
11 Patch1:         %{name}-link.patch
12 URL:            http://www.fox-toolkit.org/fox.html
13 BuildRequires:  OpenGL-devel
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libjpeg-devel
17 BuildRequires:  libpng-devel
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtiff-devel
20 BuildRequires:  libtool
21 Requires:       OpenGL
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
25
26 %description
27 FOX is a C++-Based Library for Graphical User Interface Development
28 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
29 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
30 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
31 graphics. Subclassing of basic FOX widgets allows for easy extension
32 beyond the built-in widgets by application writers.
33
34 %description -l pl
35 FOX jest bibliotek± bazuj±c± na C++ do projektowania graficznych
36 interfejsów u¿ytkownika. Obs³uguje wiele w³a¶ciwo¶ci wspó³czesnych
37 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
38 liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obs³ugê
39 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalaj± na ³atwe
40 rozszerzanie.
41
42 %package progs
43 Summary:        FOX example applications
44 Summary(pl):    Przyk³ady aplikacji w FOX
45 Group:          X11/Applications
46 Requires:       %{name} = %{version}-%{release}
47 Obsoletes:      %{name}-example-apps
48
49 %description progs
50 Editor and file browser, written with FOX.
51
52 %description progs -l pl
53 Edytor i przegl±darka plików napisane z u¿yciem toolkitu FOX.
54
55 %package devel
56 Summary:        Header files for FOX library
57 Summary(pl):    Pliki nag³ówkowe biblioteki FOX
58 Group:          X11/Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60
61 %description devel
62 Header files for FOX library.
63
64 %description devel -l pl
65 Pliki nag³ówkowe biblioteki FOX.
66
67 %package static
68 Summary:        FOX static libraries
69 Summary(pl):    Biblioteki statyczne FOX
70 Group:          X11/Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 FOX static libraries.
75
76 %description static -l pl
77 Biblioteki statyczne FOX.
78
79 %package doc
80 Summary:        Development documentation for FOX library
81 Summary(pl):    Dokumentacja programisty do biblioteki FOX
82 Group:          X11/Development/Libraries
83
84 %description doc
85 Development documentation for FOX library.
86
87 %description doc -l pl
88 Dokumentacja programisty do biblioteki FOX.
89
90 %prep
91 %setup -q
92 %patch0 -p1
93 %patch1 -p1
94
95 %build
96 %{__libtoolize}
97 %{__aclocal}
98 %{__autoconf}
99 %{__automake}
100 LDFLAGS="%{rpmldflags} -L/usr/X11R6/%{_lib}"
101 %configure \
102         --with-opengl \
103         %{?debug:--enable-debug}%{!?_debug:--enable-release}
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT%{_datadir}
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 ln -sf libFOX-1.2.so $RPM_BUILD_ROOT%{_libdir}/libFOX.so
114
115 rm -f doc/Makefile* doc/*/Makefile*
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc AUTHORS LICENSE_ADDENDUM README
126 %attr(755,root,root) %{_libdir}/lib*.so.*.*
127
128 %files progs
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_bindir}/adie
131 %attr(755,root,root) %{_bindir}/calculator
132 %attr(755,root,root) %{_bindir}/PathFinder
133 %attr(755,root,root) %{_bindir}/shutterbug
134
135 %files devel
136 %defattr(644,root,root,755)
137 %doc ADDITIONS TRACING
138 %attr(755,root,root) %{_bindir}/reswrap
139 %attr(755,root,root) %{_libdir}/lib*.so
140 %{_libdir}/lib*.la
141 %{_mandir}/man1/*
142 %{_includedir}/fox-1.2
143
144 %files static
145 %defattr(644,root,root,755)
146 %{_libdir}/lib*.a
147
148 %files doc
149 %defattr(644,root,root,755)
150 %doc doc/*
This page took 0.088056 seconds and 4 git commands to generate.