]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
- up to 1.4.17, manpages moved to correct place (from -devel to -progs
[packages/fox.git] / fox.spec
1 Summary:        The FOX C++ GUI Toolkit
2 Summary(pl):    FOX - toolkit graficzny w C++
3 Name:           fox
4 Version:        1.4.17
5 Release:        1
6 License:        LGPL
7 Group:          X11/Libraries
8 Source0:        ftp://ftp.fox-toolkit.com/pub/%{name}-%{version}.tar.gz
9 # Source0-md5:  7fbff1ac84af3bd3f9d6bdb39ed3b5f2
10 Patch0:         %{name}-opt.patch
11 Patch1:         %{name}-link.patch
12 Patch2:         %{name}-Makefile.patch
13 URL:            http://www.fox-toolkit.org/fox.html
14 BuildRequires:  OpenGL-devel
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  bzip2-devel
18 BuildRequires:  libjpeg-devel
19 BuildRequires:  libpng-devel
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtiff-devel
22 BuildRequires:  libtool
23 BuildRequires:  xcursor-devel
24 Requires:       OpenGL
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
28
29 %description
30 FOX is a C++-Based Library for Graphical User Interface Development
31 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
32 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
33 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
34 graphics. Subclassing of basic FOX widgets allows for easy extension
35 beyond the built-in widgets by application writers.
36
37 %description -l pl
38 FOX jest bibliotek± bazuj±c± na C++ do projektowania graficznych
39 interfejsów u¿ytkownika. Obs³uguje wiele w³a¶ciwo¶ci wspó³czesnych
40 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
41 liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obs³ugê
42 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalaj± na ³atwe
43 rozszerzanie.
44
45 %package progs
46 Summary:        FOX example applications
47 Summary(pl):    Przyk³ady aplikacji w FOX
48 Group:          X11/Applications
49 Requires:       %{name} = %{version}-%{release}
50 Obsoletes:      %{name}-example-apps
51
52 %description progs
53 Editor and file browser, written with FOX.
54
55 %description progs -l pl
56 Edytor i przegl±darka plików napisane z u¿yciem toolkitu FOX.
57
58 %package devel
59 Summary:        Header files for FOX library
60 Summary(pl):    Pliki nag³ówkowe biblioteki FOX
61 Group:          X11/Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       OpenGL-devel
64 Requires:       bzip2-devel
65 Requires:       libjpeg-devel
66 Requires:       libpng-devel
67 Requires:       libstdc++-devel
68 Requires:       libtiff-devel
69 Requires:       xcursor-devel
70
71 %description devel
72 Header files for FOX library.
73
74 %description devel -l pl
75 Pliki nag³ówkowe biblioteki FOX.
76
77 %package static
78 Summary:        FOX static libraries
79 Summary(pl):    Biblioteki statyczne FOX
80 Group:          X11/Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 FOX static libraries.
85
86 %description static -l pl
87 Biblioteki statyczne FOX.
88
89 %package doc
90 Summary:        Development documentation for FOX library
91 Summary(pl):    Dokumentacja programisty do biblioteki FOX
92 Group:          X11/Development/Libraries
93
94 %description doc
95 Development documentation for FOX library.
96
97 %description doc -l pl
98 Dokumentacja programisty do biblioteki FOX.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103 %patch1 -p1
104 %patch2 -p1
105
106 %build
107 %{__libtoolize}
108 %{__aclocal}
109 %{__autoconf}
110 %{__automake}
111 LDFLAGS="%{rpmldflags} -L/usr/X11R6/%{_lib}"
112 %configure \
113         --with-opengl \
114         %{?debug:--enable-debug}%{!?_debug:--enable-release}
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT%{_datadir}
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 ln -sf libFOX-1.4.so $RPM_BUILD_ROOT%{_libdir}/libFOX.so
125
126 rm -f doc/Makefile* doc/*/Makefile*
127
128 %clean
129 rm -rf $RPM_BUILD_ROOT
130
131 %post   -p /sbin/ldconfig
132 %postun -p /sbin/ldconfig
133
134 %files
135 %defattr(644,root,root,755)
136 %doc AUTHORS LICENSE_ADDENDUM README
137 %attr(755,root,root) %{_libdir}/lib*.so.*.*
138
139 %files progs
140 %defattr(644,root,root,755)
141 %attr(755,root,root) %{_bindir}/adie
142 %attr(755,root,root) %{_bindir}/calculator
143 %attr(755,root,root) %{_bindir}/PathFinder
144 %attr(755,root,root) %{_bindir}/shutterbug
145 %attr(755,root,root) %{_bindir}/Adie.stx
146 %{_mandir}/man1/*
147
148 %files devel
149 %defattr(644,root,root,755)
150 %doc ADDITIONS TRACING
151 %attr(755,root,root) %{_bindir}/fox-config
152 %attr(755,root,root) %{_bindir}/reswrap
153 %attr(755,root,root) %{_libdir}/lib*.so
154 %{_libdir}/lib*.la
155 %{_includedir}/fox-1.4
156
157 %files static
158 %defattr(644,root,root,755)
159 %{_libdir}/lib*.a
160
161 %files doc
162 %defattr(644,root,root,755)
163 %doc doc/*
This page took 0.067126 seconds and 4 git commands to generate.