]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
updated to 1.0.28 - bug fix
[packages/fox.git] / fox.spec
1 Summary:        The FOX C++ GUI Toolkit
2 Summary(pl):    FOX - toolkit graficzny w C++
3 Name:           fox
4 Version:        1.0.28
5 Release:        1
6 License:        LGPL
7 Group:          X11/Libraries
8 Source0:        ftp://ftp.fox-toolkit.org/pub/%{name}-%{version}.tar.gz
9 URL:            http://www.cfdrc.com/FOX/fox.html
10 BuildRequires:  OpenGL-devel
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  libtool
14 BuildRequires:  libstdc++-devel
15 Requires:       OpenGL
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
19 %define         _prefix         /usr/X11R6
20 %define         _mandir         %{_prefix}/man
21
22 %description
23 FOX is a C++-Based Library for Graphical User Interface Development
24 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
25 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
26 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
27 graphics. Subclassing of basic FOX widgets allows for easy extension
28 beyond the built-in widgets by application writers.
29
30 %description -l pl
31 FOX jest bibliotek± bazuj±c± na C++ do projektowania graficznych
32 interfejsów u¿ytkownika. Obs³uguje wiele w³a¶ciwo¶ci wspó³czesnych
33 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
34 liczniki, przetwarznie w tle, automatyczne uaktualnianie GUI, obs³ugê
35 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalaj± na ³atwe
36 rozszerzanie.
37
38 %package progs
39 Summary:        FOX example applications
40 Summary(pl):    Przyk³ady aplikacji w FOX
41 Group:          X11/Applications
42 Requires:       %{name} = %{version}
43 Obsoletes:      %{name}-example-apps
44
45 %description progs
46 Editor and file browser, written with FOX.
47
48 %description progs -l pl
49 Edytor i przegl±darka plików napisane z u¿yciem toolkitu FOX.
50
51 %package devel
52 Summary:        Header files and development documentation for the FOX library
53 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki FOX
54 Group:          X11/Development/Libraries
55 Requires:       %{name} = %{version}
56
57 %description devel
58 Header files and development documentation for the FOX library.
59
60 %description devel -l pl
61 Pliki nag³ówkowe i dokumentacja programisty do biblioteki FOX.
62
63 %package static
64 Summary:        FOX static libraries
65 Summary(pl):    Biblioteki statyczne FOX
66 Group:          X11/Development/Libraries
67 Requires:       %{name}-devel = %{version}
68
69 %description static
70 FOX static libraries.
71
72 %description static -l pl
73 Biblioteki statyczne FOX.
74
75 %prep
76 %setup -q
77
78 %build
79 rm -f missing
80 libtoolize -c -f
81 %{__aclocal}
82 %{__autoconf}
83 %{__automake}
84 CPPFLAGS="%{rpmcflags} -frtti" \
85 #CFLAGS="%{rpmcflags} -frtti" \
86 %configure \
87         --with-opengl=mesa \
88         --enable-release
89 %{__make} GL_LIBS="-lGL -lGLU"
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT/%{_datadir}
94
95 %{__make} install DESTDIR=$RPM_BUILD_ROOT
96
97 cp -p pathfinder/.libs/PathFinder $RPM_BUILD_ROOT%{_bindir}
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %files
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/lib*.so.*.*
108
109 %files progs
110 %defattr(644,root,root,755)
111 %attr(755,root,root) /%{_bindir}/adie
112 %attr(755,root,root) /%{_bindir}/calculator
113 %attr(755,root,root) /%{_bindir}/PathFinder
114
115 %files devel
116 %defattr(644,root,root,755)
117 %doc ADDITIONS AUTHORS README TRACING doc
118 %attr(755,root,root) %{_bindir}/reswrap
119 %attr(755,root,root) %{_libdir}/lib*.so
120 %{_libdir}/lib*.la
121 %{_mandir}/man1/*
122 %{_includedir}/fox
123
124 %files static
125 %defattr(644,root,root,755)
126 %{_libdir}/lib*.a
This page took 0.081673 seconds and 4 git commands to generate.