]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
- updated to 1.1.41
[packages/fox.git] / fox.spec
1 Summary:        The FOX C++ GUI Toolkit
2 Summary(pl):    FOX - toolkit graficzny w C++
3 Name:           fox
4 Version:        1.1.41
5 Release:        1
6 License:        LGPL
7 Group:          X11/Libraries
8 #Source0ActiveFTP
9 Source0:        http://ftp.fox-toolkit.org/ftp/%{name}-%{version}.tar.gz
10 # Source0-md5:  fa8e1762201fc867451036462f43512b
11 Patch0:         %{name}-opt.patch
12 Patch1:         %{name}-amfix.patch
13 Patch2:         %{name}-link.patch
14 URL:            http://www.fox-toolkit.org/fox.html
15 BuildRequires:  OpenGL-devel
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  libjpeg-devel
19 BuildRequires:  libpng-devel
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtiff-devel
22 BuildRequires:  libtool
23 Requires:       OpenGL
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
27
28 %description
29 FOX is a C++-Based Library for Graphical User Interface Development
30 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
31 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
32 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
33 graphics. Subclassing of basic FOX widgets allows for easy extension
34 beyond the built-in widgets by application writers.
35
36 %description -l pl
37 FOX jest bibliotek± bazuj±c± na C++ do projektowania graficznych
38 interfejsów u¿ytkownika. Obs³uguje wiele w³a¶ciwo¶ci wspó³czesnych
39 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
40 liczniki, przetwarznie w tle, automatyczne uaktualnianie GUI, obs³ugê
41 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalaj± na ³atwe
42 rozszerzanie.
43
44 %package progs
45 Summary:        FOX example applications
46 Summary(pl):    Przyk³ady aplikacji w FOX
47 Group:          X11/Applications
48 Requires:       %{name} = %{version}
49 Obsoletes:      %{name}-example-apps
50
51 %description progs
52 Editor and file browser, written with FOX.
53
54 %description progs -l pl
55 Edytor i przegl±darka plików napisane z u¿yciem toolkitu FOX.
56
57 %package devel
58 Summary:        Header files and development documentation for the FOX library
59 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki FOX
60 Group:          X11/Development/Libraries
61 Requires:       %{name} = %{version}
62
63 %description devel
64 Header files and development documentation for the FOX library.
65
66 %description devel -l pl
67 Pliki nag³ówkowe i dokumentacja programisty do biblioteki FOX.
68
69 %package static
70 Summary:        FOX static libraries
71 Summary(pl):    Biblioteki statyczne FOX
72 Group:          X11/Development/Libraries
73 Requires:       %{name}-devel = %{version}
74
75 %description static
76 FOX static libraries.
77
78 %description static -l pl
79 Biblioteki statyczne FOX.
80
81 %prep
82 %setup -q
83 %patch0 -p1
84 %patch1 -p1
85 %patch2 -p1
86
87 %build
88 %{__libtoolize}
89 %{__aclocal}
90 %{__autoconf}
91 %{__automake}
92 LDFLAGS="%{rpmldflags} -L/usr/X11R6/lib"
93 %configure \
94         --with-opengl \
95         %{?debug:--enable-debug}%{!?_debug:--enable-release}
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 install -d $RPM_BUILD_ROOT%{_datadir}
101
102 # new fox installs headers in include/fox-1.1, but apps expect them as <fox/*.h>
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT \
105         foxincludedir=%{_includedir}/fox \
106         chartincludedir=%{_includedir}/fox/chart
107
108 ln -sf libFOX-1.1.so $RPM_BUILD_ROOT%{_libdir}/libFOX.so
109
110 rm -f doc/Makefile* doc/*/Makefile*
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post   -p /sbin/ldconfig
116 %postun -p /sbin/ldconfig
117
118 %files
119 %defattr(644,root,root,755)
120 %doc AUTHORS LICENSE_ADDENDUM README
121 %attr(755,root,root) %{_libdir}/lib*.so.*.*
122
123 %files progs
124 %defattr(644,root,root,755)
125 %attr(755,root,root) %{_bindir}/adie
126 %attr(755,root,root) %{_bindir}/calculator
127 %attr(755,root,root) %{_bindir}/PathFinder
128 %attr(755,root,root) %{_bindir}/shutterbug
129
130 %files devel
131 %defattr(644,root,root,755)
132 %doc ADDITIONS TRACING doc
133 %attr(755,root,root) %{_bindir}/reswrap
134 %attr(755,root,root) %{_libdir}/lib*.so
135 %{_libdir}/lib*.la
136 %{_mandir}/man1/*
137 %{_includedir}/fox
138
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/lib*.a
This page took 0.133389 seconds and 4 git commands to generate.