]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
- release 3
[packages/fox.git] / fox.spec
1 #
2 # Conditional build:
3 %bcond_without  cups            # CUPS support
4 %bcond_without  static_libs     # don't build static libraries
5 #
6 Summary:        The FOX C++ GUI Toolkit
7 Summary(pl.UTF-8):      FOX - toolkit graficzny w C++
8 Name:           fox
9 Version:        1.7.26
10 Release:        3
11 License:        LGPL v2.1+
12 Group:          X11/Libraries
13 Source0:        http://fox-toolkit.org/ftp/%{name}-%{version}.tar.gz
14 # Source0-md5:  acaf8a1f33d02265b26a2b0c3fd06625
15 Patch0:         %{name}-opt.patch
16 Patch1:         %{name}-link.patch
17 Patch2:         %{name}-Makefile.patch
18 Patch3:         %{name}-Xlib.patch
19 URL:            http://www.fox-toolkit.org/
20 BuildRequires:  OpenGL-GLU-devel
21 BuildRequires:  autoconf >= 2.59-9
22 BuildRequires:  automake
23 BuildRequires:  bzip2-devel >= 1.0.2
24 %{?with_cups:BuildRequires:     cups-devel}
25 BuildRequires:  doxygen
26 BuildRequires:  libjpeg-devel >= 6b
27 BuildRequires:  libpng-devel >= 1.2.5
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libtiff-devel >= 3.5.7
30 BuildRequires:  libtool >= 2:1.5
31 BuildRequires:  pkgconfig
32 BuildRequires:  xorg-lib-libXcursor-devel
33 BuildRequires:  xorg-lib-libXext-devel
34 BuildRequires:  xorg-lib-libXft-devel
35 BuildRequires:  xorg-lib-libXi-devel
36 BuildRequires:  xorg-lib-libXrandr-devel
37 BuildRequires:  zlib-devel >= 1.1.4
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
41
42 %description
43 FOX is a C++-Based Library for Graphical User Interface Development
44 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
45 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
46 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
47 graphics. Subclassing of basic FOX widgets allows for easy extension
48 beyond the built-in widgets by application writers.
49
50 %description -l pl.UTF-8
51 FOX jest biblioteką bazującą na C++ do projektowania graficznych
52 interfejsów użytkownika. Obsługuje wiele właściwości współczesnych
53 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
54 liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obsługę
55 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalają na łatwe
56 rozszerzanie.
57
58 %package progs
59 Summary:        FOX example applications
60 Summary(pl.UTF-8):      Przykłady aplikacji w FOX
61 Group:          X11/Applications
62 Requires:       %{name} = %{version}-%{release}
63 Obsoletes:      fox-example-apps
64
65 %description progs
66 Editor and file browser, written with FOX.
67
68 %description progs -l pl.UTF-8
69 Edytor i przeglądarka plików napisane z użyciem toolkitu FOX.
70
71 %package devel
72 Summary:        Header files for FOX library
73 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FOX
74 Group:          X11/Development/Libraries
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       OpenGL-GLU-devel
77 Requires:       bzip2-devel >= 1.0.2
78 Requires:       cups-devel
79 Requires:       libjpeg-devel >= 6b
80 Requires:       libpng-devel >= 1.2.5
81 Requires:       libstdc++-devel
82 Requires:       libtiff-devel >= 3.5.7
83 Requires:       xorg-lib-libXcursor-devel
84 Requires:       xorg-lib-libXext-devel
85 Requires:       xorg-lib-libXft-devel
86 Requires:       xorg-lib-libXi-devel
87 Requires:       xorg-lib-libXrandr-devel
88 Requires:       zlib-devel >= 1.1.4
89
90 %description devel
91 Header files for FOX library.
92
93 %description devel -l pl.UTF-8
94 Pliki nagłówkowe biblioteki FOX.
95
96 %package static
97 Summary:        FOX static libraries
98 Summary(pl.UTF-8):      Biblioteki statyczne FOX
99 Group:          X11/Development/Libraries
100 Requires:       %{name}-devel = %{version}-%{release}
101
102 %description static
103 FOX static libraries.
104
105 %description static -l pl.UTF-8
106 Biblioteki statyczne FOX.
107
108 %package doc
109 Summary:        Development documentation for FOX library
110 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki FOX
111 Group:          X11/Development/Libraries
112
113 %description doc
114 Development documentation for FOX library.
115
116 %description doc -l pl.UTF-8
117 Dokumentacja programisty do biblioteki FOX.
118
119 %package examples
120 Summary:        FOX - example programs
121 Summary(pl.UTF-8):      FOX - programy przykładowe
122 Group:          X11/Development/Libraries
123 Requires:       %{name}-devel = %{version}-%{release}
124
125 %description examples
126 FOX - example programs.
127
128 %description examples -l pl.UTF-8
129 FOX - przykładowe programy.
130
131 %prep
132 %setup -q
133 %patch0 -p1
134 %patch1 -p1
135 %patch2 -p1
136 %patch3 -p1
137
138 %build
139 %{__libtoolize}
140 %{__aclocal}
141 %{__autoconf}
142 %{__automake}
143 %configure \
144         %{?with_cups:--enable-cups} \
145         %{?debug:--enable-debug}%{!?debug:--enable-release} \
146         --enable-static%{!?with_static_libs:=no} \
147         --with-opengl \
148         --with-xft \
149         --with-shape \
150         --with-xshm \
151         --with-xcursor \
152         --with-xrandr \
153         --with-xim
154
155 %{__make}
156
157 %install
158 rm -rf $RPM_BUILD_ROOT
159 install -d $RPM_BUILD_ROOT{%{_datadir},%{_examplesdir}/%{name}-%{version}}
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 ln -sf libFOX-1.7.so $RPM_BUILD_ROOT%{_libdir}/libFOX.so
165
166 %{__make} -C tests clean
167 cp -r tests/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
168
169 %{__rm} doc/Makefile* doc/*/Makefile*
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post   -p /sbin/ldconfig
175 %postun -p /sbin/ldconfig
176
177 %files
178 %defattr(644,root,root,755)
179 %doc AUTHORS LICENSE_ADDENDUM README
180 %attr(755,root,root) %{_bindir}/ControlPanel
181 %attr(755,root,root) %{_libdir}/libCHART-1.7.so.*.*.*
182 %attr(755,root,root) %ghost %{_libdir}/libCHART-1.7.so.0
183 %attr(755,root,root) %{_libdir}/libFOX-1.7.so.*.*.*
184 %attr(755,root,root) %ghost %{_libdir}/libFOX-1.7.so.0
185 %{_mandir}/man1/ControlPanel.1*
186
187 %files progs
188 %defattr(644,root,root,755)
189 %attr(755,root,root) %{_bindir}/Adie.stx
190 %attr(755,root,root) %{_bindir}/PathFinder
191 %attr(755,root,root) %{_bindir}/adie
192 %attr(755,root,root) %{_bindir}/calculator
193 %attr(755,root,root) %{_bindir}/shutterbug
194 %{_mandir}/man1/PathFinder.1*
195 %{_mandir}/man1/adie.1*
196 %{_mandir}/man1/calculator.1*
197 %{_mandir}/man1/shutterbug.1*
198
199 %files devel
200 %defattr(644,root,root,755)
201 %doc ADDITIONS TRACING
202 %attr(755,root,root) %{_bindir}/reswrap
203 %attr(755,root,root) %{_libdir}/libCHART-1.7.so
204 %attr(755,root,root) %{_libdir}/libFOX-1.7.so
205 %attr(755,root,root) %{_libdir}/libFOX.so
206 %{_libdir}/libCHART-1.7.la
207 %{_libdir}/libFOX-1.7.la
208 %{_includedir}/fox-1.7
209 %{_pkgconfigdir}/fox17.pc
210 %{_mandir}/man1/reswrap.1*
211
212 %if %{with static_libs}
213 %files static
214 %defattr(644,root,root,755)
215 %{_libdir}/libCHART-1.7.a
216 %{_libdir}/libFOX-1.7.a
217 %endif
218
219 %files doc
220 %defattr(644,root,root,755)
221 %doc doc/*
222
223 %files examples
224 %defattr(644,root,root,755)
225 %{_examplesdir}/%{name}-%{version}
This page took 0.048594 seconds and 4 git commands to generate.