]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
- bcond header, dropped non-versioned OpenGL dep
[packages/fox.git] / fox.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        The FOX C++ GUI Toolkit
6 Summary(pl):    FOX - toolkit graficzny w C++
7 Name:           fox
8 Version:        1.6.0
9 Release:        1
10 License:        LGPL
11 Group:          X11/Libraries
12 Source0:        ftp://ftp.fox-toolkit.com/pub/%{name}-%{version}.tar.gz
13 # Source0-md5:  cc700a729aecfad9b67e9300cf05b961
14 Patch0:         %{name}-opt.patch
15 Patch1:         %{name}-link.patch
16 Patch2:         %{name}-Makefile.patch
17 URL:            http://www.fox-toolkit.org/fox.html
18 BuildRequires:  OpenGL-devel
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  bzip2-devel
22 BuildRequires:  libjpeg-devel
23 BuildRequires:  libpng-devel
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtiff-devel
26 BuildRequires:  libtool
27 BuildRequires:  xcursor-devel
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
31
32 %description
33 FOX is a C++-Based Library for Graphical User Interface Development
34 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
35 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
36 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
37 graphics. Subclassing of basic FOX widgets allows for easy extension
38 beyond the built-in widgets by application writers.
39
40 %description -l pl
41 FOX jest bibliotek± bazuj±c± na C++ do projektowania graficznych
42 interfejsów u¿ytkownika. Obs³uguje wiele w³a¶ciwo¶ci wspó³czesnych
43 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
44 liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obs³ugê
45 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalaj± na ³atwe
46 rozszerzanie.
47
48 %package progs
49 Summary:        FOX example applications
50 Summary(pl):    Przyk³ady aplikacji w FOX
51 Group:          X11/Applications
52 Requires:       %{name} = %{version}-%{release}
53 Obsoletes:      %{name}-example-apps
54
55 %description progs
56 Editor and file browser, written with FOX.
57
58 %description progs -l pl
59 Edytor i przegl±darka plików napisane z u¿yciem toolkitu FOX.
60
61 %package devel
62 Summary:        Header files for FOX library
63 Summary(pl):    Pliki nag³ówkowe biblioteki FOX
64 Group:          X11/Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66 Requires:       OpenGL-devel
67 Requires:       bzip2-devel
68 Requires:       libjpeg-devel
69 Requires:       libpng-devel
70 Requires:       libstdc++-devel
71 Requires:       libtiff-devel
72 Requires:       xcursor-devel
73
74 %description devel
75 Header files for FOX library.
76
77 %description devel -l pl
78 Pliki nag³ówkowe biblioteki FOX.
79
80 %package static
81 Summary:        FOX static libraries
82 Summary(pl):    Biblioteki statyczne FOX
83 Group:          X11/Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 FOX static libraries.
88
89 %description static -l pl
90 Biblioteki statyczne FOX.
91
92 %package doc
93 Summary:        Development documentation for FOX library
94 Summary(pl):    Dokumentacja programisty do biblioteki FOX
95 Group:          X11/Development/Libraries
96
97 %description doc
98 Development documentation for FOX library.
99
100 %description doc -l pl
101 Dokumentacja programisty do biblioteki FOX.
102
103 %prep
104 %setup -q
105 %patch0 -p1
106 %patch1 -p1
107 %patch2 -p1
108
109 %build
110 %{__libtoolize}
111 %{__aclocal}
112 %{__autoconf}
113 %{__automake}
114 LDFLAGS="%{rpmldflags} -L/usr/X11R6/%{_lib}"
115 %configure \
116         --with-opengl \
117         %{?debug:--enable-debug}%{!?debug:--enable-release} \
118         --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no}
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT%{_datadir}
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 ln -sf libFOX-1.6.so $RPM_BUILD_ROOT%{_libdir}/libFOX.so
129
130 rm -f doc/Makefile* doc/*/Makefile*
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %files
139 %defattr(644,root,root,755)
140 %doc AUTHORS LICENSE_ADDENDUM README
141 %attr(755,root,root) %{_libdir}/lib*.so.*.*
142
143 %files progs
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_bindir}/adie
146 %attr(755,root,root) %{_bindir}/calculator
147 %attr(755,root,root) %{_bindir}/PathFinder
148 %attr(755,root,root) %{_bindir}/shutterbug
149 %attr(755,root,root) %{_bindir}/Adie.stx
150 %{_mandir}/man1/*
151
152 %files devel
153 %defattr(644,root,root,755)
154 %doc ADDITIONS TRACING
155 %attr(755,root,root) %{_bindir}/fox-config
156 %attr(755,root,root) %{_bindir}/reswrap
157 %attr(755,root,root) %{_libdir}/lib*.so
158 %{_libdir}/lib*.la
159 %{_includedir}/fox-1.6
160
161 %if %{with static_libs}
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/lib*.a
165 %endif
166
167 %files doc
168 %defattr(644,root,root,755)
169 %doc doc/*
This page took 0.043204 seconds and 4 git commands to generate.