]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
- release 5
[packages/fox.git] / fox.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        The FOX C++ GUI Toolkit
6 Summary(pl.UTF-8):      FOX - toolkit graficzny w C++
7 Name:           fox
8 Version:        1.7.19
9 Release:        5
10 License:        LGPL
11 Group:          X11/Libraries
12 Source0:        ftp://ftp.fox-toolkit.com/pub/%{name}-%{version}.tar.gz
13 # Source0-md5:  fb4d0934be26c27c7e76fcbefe2b5d30
14 Patch0:         %{name}-opt.patch
15 Patch1:         %{name}-link.patch
16 Patch2:         %{name}-Makefile.patch
17 URL:            http://www.fox-toolkit.org/
18 BuildRequires:  OpenGL-GLU-devel
19 BuildRequires:  autoconf >= 2.59-9
20 BuildRequires:  automake
21 BuildRequires:  bzip2-devel >= 1.0.2
22 BuildRequires:  cups-devel
23 BuildRequires:  doxygen
24 BuildRequires:  graphviz
25 BuildRequires:  libjpeg-devel >= 6b
26 BuildRequires:  libpng-devel >= 1.2.5
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtiff-devel >= 3.5.7
29 BuildRequires:  libtool >= 2:1.5
30 BuildRequires:  xorg-lib-libXcursor-devel
31 BuildRequires:  xorg-lib-libXext-devel
32 BuildRequires:  xorg-lib-libXft-devel
33 BuildRequires:  xorg-lib-libXrandr-devel
34 BuildRequires:  zlib-devel >= 1.1.4
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
38
39 %description
40 FOX is a C++-Based Library for Graphical User Interface Development
41 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
42 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
43 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
44 graphics. Subclassing of basic FOX widgets allows for easy extension
45 beyond the built-in widgets by application writers.
46
47 %description -l pl.UTF-8
48 FOX jest biblioteką bazującą na C++ do projektowania graficznych
49 interfejsów użytkownika. Obsługuje wiele właściwości współczesnych
50 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
51 liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obsługę
52 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalają na łatwe
53 rozszerzanie.
54
55 %package progs
56 Summary:        FOX example applications
57 Summary(pl.UTF-8):      Przykłady aplikacji w FOX
58 Group:          X11/Applications
59 Requires:       %{name} = %{version}-%{release}
60 Obsoletes:      fox-example-apps
61
62 %description progs
63 Editor and file browser, written with FOX.
64
65 %description progs -l pl.UTF-8
66 Edytor i przeglądarka plików napisane z użyciem toolkitu FOX.
67
68 %package devel
69 Summary:        Header files for FOX library
70 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FOX
71 Group:          X11/Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       OpenGL-GLU-devel
74 Requires:       bzip2-devel >= 1.0.2
75 Requires:       cups-devel
76 Requires:       libjpeg-devel >= 6b
77 Requires:       libpng-devel >= 1.2.5
78 Requires:       libstdc++-devel
79 Requires:       libtiff-devel >= 3.5.7
80 Requires:       xorg-lib-libXcursor-devel
81 Requires:       xorg-lib-libXext-devel
82 Requires:       xorg-lib-libXft-devel
83 Requires:       xorg-lib-libXrandr-devel
84 Requires:       zlib-devel >= 1.1.4
85
86 %description devel
87 Header files for FOX library.
88
89 %description devel -l pl.UTF-8
90 Pliki nagłówkowe biblioteki FOX.
91
92 %package static
93 Summary:        FOX static libraries
94 Summary(pl.UTF-8):      Biblioteki statyczne FOX
95 Group:          X11/Development/Libraries
96 Requires:       %{name}-devel = %{version}-%{release}
97
98 %description static
99 FOX static libraries.
100
101 %description static -l pl.UTF-8
102 Biblioteki statyczne FOX.
103
104 %package doc
105 Summary:        Development documentation for FOX library
106 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki FOX
107 Group:          X11/Development/Libraries
108
109 %description doc
110 Development documentation for FOX library.
111
112 %description doc -l pl.UTF-8
113 Dokumentacja programisty do biblioteki FOX.
114
115 %package examples
116 Summary:        FOX - example programs
117 Summary(pl.UTF-8):      FOX - programy przykładowe
118 Group:          X11/Development/Libraries
119 Requires:       %{name}-devel = %{version}-%{release}
120
121 %description examples
122 FOX - example programs.
123
124 %description examples -l pl.UTF-8
125 FOX - przykładowe programy.
126
127 %prep
128 %setup -q
129 %patch0 -p1
130 %patch1 -p1
131 %patch2 -p1
132
133 %build
134 %{__libtoolize}
135 %{__aclocal}
136 %{__autoconf}
137 %{__automake}
138 %configure \
139         --enable-cups \
140         %{?debug:--enable-debug}%{!?debug:--enable-release} \
141         --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no} \
142         --with-opengl \
143         --with-xft \
144         --with-shape \
145         --with-xshm \
146         --with-xcursor \
147         --with-xrandr \
148         --with-xim
149
150 %{__make}
151
152 %{__make} -C doc docs
153
154 %install
155 rm -rf $RPM_BUILD_ROOT
156 install -d $RPM_BUILD_ROOT{%{_datadir},%{_examplesdir}/%{name}-%{version}}
157
158 %{__make} install \
159         DESTDIR=$RPM_BUILD_ROOT
160
161 ln -sf libFOX-1.7.so $RPM_BUILD_ROOT%{_libdir}/libFOX.so
162
163 rm -f doc/Makefile* doc/*/Makefile*
164
165 %{__make} -C tests clean
166 cp -r tests/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %post   -p /sbin/ldconfig
172 %postun -p /sbin/ldconfig
173
174 %files
175 %defattr(644,root,root,755)
176 %doc AUTHORS LICENSE_ADDENDUM README
177 %attr(755,root,root) %{_libdir}/libCHART-1.7.so.*.*.*
178 %attr(755,root,root) %ghost %{_libdir}/libCHART-1.7.so.0
179 %attr(755,root,root) %{_libdir}/libFOX-1.7.so.*.*.*
180 %attr(755,root,root) %ghost %{_libdir}/libFOX-1.7.so.0
181 %attr(755,root,root) %{_bindir}/ControlPanel
182
183 %files progs
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_bindir}/adie
186 %attr(755,root,root) %{_bindir}/calculator
187 %attr(755,root,root) %{_bindir}/PathFinder
188 %attr(755,root,root) %{_bindir}/shutterbug
189 %attr(755,root,root) %{_bindir}/Adie.stx
190 %{_mandir}/man1/*
191
192 %files devel
193 %defattr(644,root,root,755)
194 %doc ADDITIONS TRACING
195 %attr(755,root,root) %{_bindir}/fox-config
196 %attr(755,root,root) %{_bindir}/reswrap
197 %attr(755,root,root) %{_libdir}/libCHART-1.7.so
198 %attr(755,root,root) %{_libdir}/libFOX-1.7.so
199 %attr(755,root,root) %{_libdir}/libFOX.so
200 %{_libdir}/libCHART-1.7.la
201 %{_libdir}/libFOX-1.7.la
202 %{_includedir}/fox-1.7
203 %{_pkgconfigdir}/fox.pc
204
205 %if %{with static_libs}
206 %files static
207 %defattr(644,root,root,755)
208 %{_libdir}/libCHART-1.7.a
209 %{_libdir}/libFOX-1.7.a
210 %endif
211
212 %files doc
213 %defattr(644,root,root,755)
214 %doc doc/*
215
216 %files examples
217 %defattr(644,root,root,755)
218 %{_examplesdir}/%{name}-%{version}
This page took 0.07075 seconds and 4 git commands to generate.