]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
73df80e71250d3ca14f57df0c95a75b2f0493e36
[packages/fox.git] / fox.spec
1 Summary:        The FOX C++ GUI Toolkit
2 Summary(pl):    FOX - toolkit graficzny w C++
3 Name:           fox
4 Version:        1.1.45
5 Release:        1
6 License:        LGPL
7 Group:          X11/Libraries
8 Source0:        http://ftp.fox-toolkit.org/ftp/%{name}-%{version}.tar.gz
9 # Source0-md5:  730d817501a6a2589ca7312503f623dd
10 Patch0:         %{name}-opt.patch
11 Patch1:         %{name}-link.patch
12 URL:            http://www.fox-toolkit.org/fox.html
13 BuildRequires:  OpenGL-devel
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libjpeg-devel
17 BuildRequires:  libpng-devel
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtiff-devel
20 BuildRequires:  libtool
21 Requires:       OpenGL
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
25
26 %description
27 FOX is a C++-Based Library for Graphical User Interface Development
28 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
29 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
30 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
31 graphics. Subclassing of basic FOX widgets allows for easy extension
32 beyond the built-in widgets by application writers.
33
34 %description -l pl
35 FOX jest bibliotek± bazuj±c± na C++ do projektowania graficznych
36 interfejsów u¿ytkownika. Obs³uguje wiele w³a¶ciwo¶ci wspó³czesnych
37 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
38 liczniki, przetwarznie w tle, automatyczne uaktualnianie GUI, obs³ugê
39 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalaj± na ³atwe
40 rozszerzanie.
41
42 %package progs
43 Summary:        FOX example applications
44 Summary(pl):    Przyk³ady aplikacji w FOX
45 Group:          X11/Applications
46 Requires:       %{name} = %{version}
47 Obsoletes:      %{name}-example-apps
48
49 %description progs
50 Editor and file browser, written with FOX.
51
52 %description progs -l pl
53 Edytor i przegl±darka plików napisane z u¿yciem toolkitu FOX.
54
55 %package devel
56 Summary:        Header files and development documentation for the FOX library
57 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki FOX
58 Group:          X11/Development/Libraries
59 Requires:       %{name} = %{version}
60
61 %description devel
62 Header files and development documentation for the FOX library.
63
64 %description devel -l pl
65 Pliki nag³ówkowe i dokumentacja programisty do biblioteki FOX.
66
67 %package static
68 Summary:        FOX static libraries
69 Summary(pl):    Biblioteki statyczne FOX
70 Group:          X11/Development/Libraries
71 Requires:       %{name}-devel = %{version}
72
73 %description static
74 FOX static libraries.
75
76 %description static -l pl
77 Biblioteki statyczne FOX.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82 %patch1 -p1
83
84 %build
85 %{__libtoolize}
86 %{__aclocal}
87 %{__autoconf}
88 %{__automake}
89 LDFLAGS="%{rpmldflags} -L/usr/X11R6/%{_lib}"
90 %configure \
91         --with-opengl \
92         %{?debug:--enable-debug}%{!?_debug:--enable-release}
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT%{_datadir}
98
99 # new fox installs headers in include/fox-1.1, but apps expect them as <fox/*.h>
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT \
102         foxincludedir=%{_includedir}/fox \
103         chartincludedir=%{_includedir}/fox/chart
104
105 ln -sf libFOX-1.1.so $RPM_BUILD_ROOT%{_libdir}/libFOX.so
106
107 rm -f doc/Makefile* doc/*/Makefile*
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post   -p /sbin/ldconfig
113 %postun -p /sbin/ldconfig
114
115 %files
116 %defattr(644,root,root,755)
117 %doc AUTHORS LICENSE_ADDENDUM README
118 %attr(755,root,root) %{_libdir}/lib*.so.*.*
119
120 %files progs
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_bindir}/adie
123 %attr(755,root,root) %{_bindir}/calculator
124 %attr(755,root,root) %{_bindir}/PathFinder
125 %attr(755,root,root) %{_bindir}/shutterbug
126
127 %files devel
128 %defattr(644,root,root,755)
129 %doc ADDITIONS TRACING doc
130 %attr(755,root,root) %{_bindir}/reswrap
131 %attr(755,root,root) %{_libdir}/lib*.so
132 %{_libdir}/lib*.la
133 %{_mandir}/man1/*
134 %{_includedir}/fox
135
136 %files static
137 %defattr(644,root,root,755)
138 %{_libdir}/lib*.a
This page took 0.029595 seconds and 3 git commands to generate.