]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
- html docs generated by doxygen
[packages/fox.git] / fox.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        The FOX C++ GUI Toolkit
6 Summary(pl):    FOX - toolkit graficzny w C++
7 Name:           fox
8 Version:        1.6.4
9 Release:        2
10 License:        LGPL
11 Group:          X11/Libraries
12 Source0:        ftp://ftp.fox-toolkit.com/pub/%{name}-%{version}.tar.gz
13 # Source0-md5:  6801922b6874db4761f098a3fa3a819b
14 Patch0:         %{name}-opt.patch
15 Patch1:         %{name}-link.patch
16 Patch2:         %{name}-Makefile.patch
17 URL:            http://www.fox-toolkit.org/fox.html
18 BuildRequires:  OpenGL-GLU-devel
19 BuildRequires:  autoconf >= 2.59-9
20 BuildRequires:  automake
21 BuildRequires:  bzip2-devel >= 1.0.2
22 BuildRequires:  doxygen
23 BuildRequires:  graphviz
24 BuildRequires:  libjpeg-devel >= 6b
25 BuildRequires:  libpng-devel >= 1.2.5
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtiff-devel >= 3.5.7
28 BuildRequires:  libtool >= 2:1.5
29 BuildRequires:  xorg-lib-libXcursor-devel
30 BuildRequires:  xorg-lib-libXext-devel
31 BuildRequires:  xorg-lib-libXft-devel
32 BuildRequires:  xorg-lib-libXrandr-devel
33 BuildRequires:  zlib-devel >= 1.1.4
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
37
38 %description
39 FOX is a C++-Based Library for Graphical User Interface Development
40 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
41 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
42 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
43 graphics. Subclassing of basic FOX widgets allows for easy extension
44 beyond the built-in widgets by application writers.
45
46 %description -l pl
47 FOX jest bibliotek± bazuj±c± na C++ do projektowania graficznych
48 interfejsów u¿ytkownika. Obs³uguje wiele w³a¶ciwo¶ci wspó³czesnych
49 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
50 liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obs³ugê
51 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalaj± na ³atwe
52 rozszerzanie.
53
54 %package progs
55 Summary:        FOX example applications
56 Summary(pl):    Przyk³ady aplikacji w FOX
57 Group:          X11/Applications
58 Requires:       %{name} = %{version}-%{release}
59 Obsoletes:      fox-example-apps
60
61 %description progs
62 Editor and file browser, written with FOX.
63
64 %description progs -l pl
65 Edytor i przegl±darka plików napisane z u¿yciem toolkitu FOX.
66
67 %package devel
68 Summary:        Header files for FOX library
69 Summary(pl):    Pliki nag³ówkowe biblioteki FOX
70 Group:          X11/Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       OpenGL-GLU-devel
73 Requires:       bzip2-devel >= 1.0.2
74 Requires:       libjpeg-devel >= 6b
75 Requires:       libpng-devel >= 1.2.5
76 Requires:       libstdc++-devel
77 Requires:       libtiff-devel >= 3.5.7
78 Requires:       xorg-lib-libXcursor-devel
79 Requires:       xorg-lib-libXext-devel
80 Requires:       xorg-lib-libXft-devel
81 Requires:       xorg-lib-libXrandr-devel
82 Requires:       zlib-devel >= 1.1.4
83
84 %description devel
85 Header files for FOX library.
86
87 %description devel -l pl
88 Pliki nag³ówkowe biblioteki FOX.
89
90 %package static
91 Summary:        FOX static libraries
92 Summary(pl):    Biblioteki statyczne FOX
93 Group:          X11/Development/Libraries
94 Requires:       %{name}-devel = %{version}-%{release}
95
96 %description static
97 FOX static libraries.
98
99 %description static -l pl
100 Biblioteki statyczne FOX.
101
102 %package doc
103 Summary:        Development documentation for FOX library
104 Summary(pl):    Dokumentacja programisty do biblioteki FOX
105 Group:          X11/Development/Libraries
106
107 %description doc
108 Development documentation for FOX library.
109
110 %description doc -l pl
111 Dokumentacja programisty do biblioteki FOX.
112
113 %prep
114 %setup -q
115 %patch0 -p1
116 %patch1 -p1
117 %patch2 -p1
118
119 %build
120 %{__libtoolize}
121 %{__aclocal}
122 %{__autoconf}
123 %{__automake}
124 %configure \
125         %{?debug:--enable-debug}%{!?debug:--enable-release} \
126         --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no} \
127         --with-opengl \
128         --with-xft
129 %{__make}
130
131 %{__make} -C doc docs
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 install -d $RPM_BUILD_ROOT%{_datadir}
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT
139
140 ln -sf libFOX-1.6.so $RPM_BUILD_ROOT%{_libdir}/libFOX.so
141
142 rm -f doc/Makefile* doc/*/Makefile*
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post   -p /sbin/ldconfig
148 %postun -p /sbin/ldconfig
149
150 %files
151 %defattr(644,root,root,755)
152 %doc AUTHORS LICENSE_ADDENDUM README
153 %attr(755,root,root) %{_libdir}/lib*.so.*.*
154
155 %files progs
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_bindir}/adie
158 %attr(755,root,root) %{_bindir}/calculator
159 %attr(755,root,root) %{_bindir}/PathFinder
160 %attr(755,root,root) %{_bindir}/shutterbug
161 %attr(755,root,root) %{_bindir}/Adie.stx
162 %{_mandir}/man1/*
163
164 %files devel
165 %defattr(644,root,root,755)
166 %doc ADDITIONS TRACING
167 %attr(755,root,root) %{_bindir}/fox-config
168 %attr(755,root,root) %{_bindir}/reswrap
169 %attr(755,root,root) %{_libdir}/lib*.so
170 %{_libdir}/lib*.la
171 %{_includedir}/fox-1.6
172
173 %if %{with static_libs}
174 %files static
175 %defattr(644,root,root,755)
176 %{_libdir}/lib*.a
177 %endif
178
179 %files doc
180 %defattr(644,root,root,755)
181 %doc doc/*
This page took 0.044181 seconds and 3 git commands to generate.