]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
32737d95fa8952f7e73571deebcacd742d0e0240
[packages/fox.git] / fox.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        The FOX C++ GUI Toolkit
6 Summary(pl.UTF-8):      FOX - toolkit graficzny w C++
7 Name:           fox
8 Version:        1.7.19
9 Release:        6
10 License:        LGPL
11 Group:          X11/Libraries
12 Source0:        ftp://ftp.fox-toolkit.com/pub/%{name}-%{version}.tar.gz
13 # Source0-md5:  fb4d0934be26c27c7e76fcbefe2b5d30
14 Patch0:         %{name}-opt.patch
15 Patch1:         %{name}-link.patch
16 Patch2:         %{name}-Makefile.patch
17 Patch3:         pkgconfig.patch
18 URL:            http://www.fox-toolkit.org/
19 BuildRequires:  OpenGL-GLU-devel
20 BuildRequires:  autoconf >= 2.59-9
21 BuildRequires:  automake
22 BuildRequires:  bzip2-devel >= 1.0.2
23 BuildRequires:  cups-devel
24 BuildRequires:  doxygen
25 BuildRequires:  graphviz
26 BuildRequires:  libjpeg-devel >= 6b
27 BuildRequires:  libpng-devel >= 1.2.5
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  libtiff-devel >= 3.5.7
30 BuildRequires:  libtool >= 2:1.5
31 BuildRequires:  pkgconfig
32 BuildRequires:  xorg-lib-libXcursor-devel
33 BuildRequires:  xorg-lib-libXext-devel
34 BuildRequires:  xorg-lib-libXft-devel
35 BuildRequires:  xorg-lib-libXrandr-devel
36 BuildRequires:  zlib-devel >= 1.1.4
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
40
41 %description
42 FOX is a C++-Based Library for Graphical User Interface Development
43 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
44 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
45 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
46 graphics. Subclassing of basic FOX widgets allows for easy extension
47 beyond the built-in widgets by application writers.
48
49 %description -l pl.UTF-8
50 FOX jest biblioteką bazującą na C++ do projektowania graficznych
51 interfejsów użytkownika. Obsługuje wiele właściwości współczesnych
52 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
53 liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obsługę
54 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalają na łatwe
55 rozszerzanie.
56
57 %package progs
58 Summary:        FOX example applications
59 Summary(pl.UTF-8):      Przykłady aplikacji w FOX
60 Group:          X11/Applications
61 Requires:       %{name} = %{version}-%{release}
62 Obsoletes:      fox-example-apps
63
64 %description progs
65 Editor and file browser, written with FOX.
66
67 %description progs -l pl.UTF-8
68 Edytor i przeglądarka plików napisane z użyciem toolkitu FOX.
69
70 %package devel
71 Summary:        Header files for FOX library
72 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FOX
73 Group:          X11/Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       OpenGL-GLU-devel
76 Requires:       bzip2-devel >= 1.0.2
77 Requires:       cups-devel
78 Requires:       libjpeg-devel >= 6b
79 Requires:       libpng-devel >= 1.2.5
80 Requires:       libstdc++-devel
81 Requires:       libtiff-devel >= 3.5.7
82 Requires:       xorg-lib-libXcursor-devel
83 Requires:       xorg-lib-libXext-devel
84 Requires:       xorg-lib-libXft-devel
85 Requires:       xorg-lib-libXrandr-devel
86 Requires:       zlib-devel >= 1.1.4
87
88 %description devel
89 Header files for FOX library.
90
91 %description devel -l pl.UTF-8
92 Pliki nagłówkowe biblioteki FOX.
93
94 %package static
95 Summary:        FOX static libraries
96 Summary(pl.UTF-8):      Biblioteki statyczne FOX
97 Group:          X11/Development/Libraries
98 Requires:       %{name}-devel = %{version}-%{release}
99
100 %description static
101 FOX static libraries.
102
103 %description static -l pl.UTF-8
104 Biblioteki statyczne FOX.
105
106 %package doc
107 Summary:        Development documentation for FOX library
108 Summary(pl.UTF-8):      Dokumentacja programisty do biblioteki FOX
109 Group:          X11/Development/Libraries
110
111 %description doc
112 Development documentation for FOX library.
113
114 %description doc -l pl.UTF-8
115 Dokumentacja programisty do biblioteki FOX.
116
117 %package examples
118 Summary:        FOX - example programs
119 Summary(pl.UTF-8):      FOX - programy przykładowe
120 Group:          X11/Development/Libraries
121 Requires:       %{name}-devel = %{version}-%{release}
122
123 %description examples
124 FOX - example programs.
125
126 %description examples -l pl.UTF-8
127 FOX - przykładowe programy.
128
129 %prep
130 %setup -q
131 %patch0 -p1
132 %patch1 -p1
133 %patch2 -p1
134 %patch3 -p1
135
136 %build
137 %{__libtoolize}
138 %{__aclocal}
139 %{__autoconf}
140 %{__automake}
141 %configure \
142         --enable-cups \
143         %{?debug:--enable-debug}%{!?debug:--enable-release} \
144         --enable-static=%{?with_static_libs:yes}%{!?with_static_libs:no} \
145         --with-opengl \
146         --with-xft \
147         --with-shape \
148         --with-xshm \
149         --with-xcursor \
150         --with-xrandr \
151         --with-xim
152
153 %{__make}
154
155 %{__make} -C doc docs
156
157 %install
158 rm -rf $RPM_BUILD_ROOT
159 install -d $RPM_BUILD_ROOT{%{_datadir},%{_examplesdir}/%{name}-%{version}}
160
161 %{__make} install \
162         DESTDIR=$RPM_BUILD_ROOT
163
164 ln -sf libFOX-1.7.so $RPM_BUILD_ROOT%{_libdir}/libFOX.so
165
166 rm -f doc/Makefile* doc/*/Makefile*
167
168 %{__make} -C tests clean
169 cp -r tests/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post   -p /sbin/ldconfig
175 %postun -p /sbin/ldconfig
176
177 %files
178 %defattr(644,root,root,755)
179 %doc AUTHORS LICENSE_ADDENDUM README
180 %attr(755,root,root) %{_libdir}/libCHART-1.7.so.*.*.*
181 %attr(755,root,root) %ghost %{_libdir}/libCHART-1.7.so.0
182 %attr(755,root,root) %{_libdir}/libFOX-1.7.so.*.*.*
183 %attr(755,root,root) %ghost %{_libdir}/libFOX-1.7.so.0
184 %attr(755,root,root) %{_bindir}/ControlPanel
185
186 %files progs
187 %defattr(644,root,root,755)
188 %attr(755,root,root) %{_bindir}/adie
189 %attr(755,root,root) %{_bindir}/calculator
190 %attr(755,root,root) %{_bindir}/PathFinder
191 %attr(755,root,root) %{_bindir}/shutterbug
192 %attr(755,root,root) %{_bindir}/Adie.stx
193 %{_mandir}/man1/*
194
195 %files devel
196 %defattr(644,root,root,755)
197 %doc ADDITIONS TRACING
198 %attr(755,root,root) %{_bindir}/fox-config
199 %attr(755,root,root) %{_bindir}/reswrap
200 %attr(755,root,root) %{_libdir}/libCHART-1.7.so
201 %attr(755,root,root) %{_libdir}/libFOX-1.7.so
202 %attr(755,root,root) %{_libdir}/libFOX.so
203 %{_libdir}/libCHART-1.7.la
204 %{_libdir}/libFOX-1.7.la
205 %{_includedir}/fox-1.7
206 %{_pkgconfigdir}/fox.pc
207
208 %if %{with static_libs}
209 %files static
210 %defattr(644,root,root,755)
211 %{_libdir}/libCHART-1.7.a
212 %{_libdir}/libFOX-1.7.a
213 %endif
214
215 %files doc
216 %defattr(644,root,root,755)
217 %doc doc/*
218
219 %files examples
220 %defattr(644,root,root,755)
221 %{_examplesdir}/%{name}-%{version}
This page took 0.033018 seconds and 2 git commands to generate.