]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
- BR: bzip2-devel, apropriate R: in devel subpackage
[packages/fox.git] / fox.spec
1 Summary:        The FOX C++ GUI Toolkit
2 Summary(pl):    FOX - toolkit graficzny w C++
3 Name:           fox
4 Version:        1.2.11
5 Release:        1
6 License:        LGPL
7 Group:          X11/Libraries
8 Source0:        http://www.fox-toolkit.org/ftp/%{name}-%{version}.tar.gz
9 # Source0-md5:  cbe15ef87f6ad815689b3ca7322eb8c5
10 Patch0:         %{name}-opt.patch
11 Patch1:         %{name}-link.patch
12 URL:            http://www.fox-toolkit.org/fox.html
13 BuildRequires:  OpenGL-devel
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  bzip2-devel
17 BuildRequires:  libjpeg-devel
18 BuildRequires:  libpng-devel
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtiff-devel
21 BuildRequires:  libtool
22 Requires:       OpenGL
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
26
27 %description
28 FOX is a C++-Based Library for Graphical User Interface Development
29 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
30 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
31 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
32 graphics. Subclassing of basic FOX widgets allows for easy extension
33 beyond the built-in widgets by application writers.
34
35 %description -l pl
36 FOX jest bibliotek± bazuj±c± na C++ do projektowania graficznych
37 interfejsów u¿ytkownika. Obs³uguje wiele w³a¶ciwo¶ci wspó³czesnych
38 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
39 liczniki, przetwarzanie w tle, automatyczne uaktualnianie GUI, obs³ugê
40 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalaj± na ³atwe
41 rozszerzanie.
42
43 %package progs
44 Summary:        FOX example applications
45 Summary(pl):    Przyk³ady aplikacji w FOX
46 Group:          X11/Applications
47 Requires:       %{name} = %{version}-%{release}
48 Obsoletes:      %{name}-example-apps
49
50 %description progs
51 Editor and file browser, written with FOX.
52
53 %description progs -l pl
54 Edytor i przegl±darka plików napisane z u¿yciem toolkitu FOX.
55
56 %package devel
57 Summary:        Header files for FOX library
58 Summary(pl):    Pliki nag³ówkowe biblioteki FOX
59 Group:          X11/Development/Libraries
60 Requires:       OpenGL-devel
61 Requires:       bzip2-devel
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       libjpeg-devel
64 Requires:       libpng-devel
65 Requires:       libstdc++-devel
66 Requires:       libtiff-devel
67
68 %description devel
69 Header files for FOX library.
70
71 %description devel -l pl
72 Pliki nag³ówkowe biblioteki FOX.
73
74 %package static
75 Summary:        FOX static libraries
76 Summary(pl):    Biblioteki statyczne FOX
77 Group:          X11/Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 FOX static libraries.
82
83 %description static -l pl
84 Biblioteki statyczne FOX.
85
86 %package doc
87 Summary:        Development documentation for FOX library
88 Summary(pl):    Dokumentacja programisty do biblioteki FOX
89 Group:          X11/Development/Libraries
90
91 %description doc
92 Development documentation for FOX library.
93
94 %description doc -l pl
95 Dokumentacja programisty do biblioteki FOX.
96
97 %prep
98 %setup -q
99 %patch0 -p1
100 %patch1 -p1
101
102 %build
103 %{__libtoolize}
104 %{__aclocal}
105 %{__autoconf}
106 %{__automake}
107 LDFLAGS="%{rpmldflags} -L/usr/X11R6/%{_lib}"
108 %configure \
109         --with-opengl \
110         %{?debug:--enable-debug}%{!?_debug:--enable-release}
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT%{_datadir}
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 ln -sf libFOX-1.2.so $RPM_BUILD_ROOT%{_libdir}/libFOX.so
121
122 rm -f doc/Makefile* doc/*/Makefile*
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS LICENSE_ADDENDUM README
133 %attr(755,root,root) %{_libdir}/lib*.so.*.*
134
135 %files progs
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_bindir}/adie
138 %attr(755,root,root) %{_bindir}/calculator
139 %attr(755,root,root) %{_bindir}/PathFinder
140 %attr(755,root,root) %{_bindir}/shutterbug
141
142 %files devel
143 %defattr(644,root,root,755)
144 %doc ADDITIONS TRACING
145 %attr(755,root,root) %{_bindir}/reswrap
146 %attr(755,root,root) %{_libdir}/lib*.so
147 %{_libdir}/lib*.la
148 %{_mandir}/man1/*
149 %{_includedir}/fox-1.2
150
151 %files static
152 %defattr(644,root,root,755)
153 %{_libdir}/lib*.a
154
155 %files doc
156 %defattr(644,root,root,755)
157 %doc doc/*
This page took 0.034139 seconds and 3 git commands to generate.