]> git.pld-linux.org Git - packages/fox.git/blob - fox.spec
0393d7a8a3668e212ec78f1ac73c6099b160d974
[packages/fox.git] / fox.spec
1 Summary:        The FOX C++ GUI Toolkit
2 Summary(pl):    FOX - toolkit graficzny w C++
3 Name:           fox
4 Version:        1.0.30
5 Release:        1
6 License:        LGPL
7 Group:          X11/Libraries
8 #Source0ActiveFTP
9 Source0:        ftp://ftp.fox-toolkit.org/pub/%{name}-%{version}.tar.gz
10 Patch0:         %{name}-opt.patch
11 URL:            http://www.fox-toolkit.org/fox.html
12 BuildRequires:  OpenGL-devel
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  libjpeg-devel
16 BuildRequires:  libpng-devel
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libtiff-devel
19 BuildRequires:  libtool
20 Requires:       OpenGL
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
24
25 %description
26 FOX is a C++-Based Library for Graphical User Interface Development
27 FOX supports modern GUI features, such as Drag-and-Drop, Tooltips, Tab
28 Books, Tree Lists, Icons, Multiple-Document Interfaces (MDI), timers,
29 idle processing, automatic GUI updating, as well as OpenGL/Mesa for 3D
30 graphics. Subclassing of basic FOX widgets allows for easy extension
31 beyond the built-in widgets by application writers.
32
33 %description -l pl
34 FOX jest bibliotek± bazuj±c± na C++ do projektowania graficznych
35 interfejsów u¿ytkownika. Obs³uguje wiele w³a¶ciwo¶ci wspó³czesnych
36 GUI: Drag-and-Drop, listy, ikony, interfejsy wielodokumentowe (MDI),
37 liczniki, przetwarznie w tle, automatyczne uaktualnianie GUI, obs³ugê
38 grafiki OpenGL. Bazowe klasy widgetów FOX pozwalaj± na ³atwe
39 rozszerzanie.
40
41 %package progs
42 Summary:        FOX example applications
43 Summary(pl):    Przyk³ady aplikacji w FOX
44 Group:          X11/Applications
45 Requires:       %{name} = %{version}
46 Obsoletes:      %{name}-example-apps
47
48 %description progs
49 Editor and file browser, written with FOX.
50
51 %description progs -l pl
52 Edytor i przegl±darka plików napisane z u¿yciem toolkitu FOX.
53
54 %package devel
55 Summary:        Header files and development documentation for the FOX library
56 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki FOX
57 Group:          X11/Development/Libraries
58 Requires:       %{name} = %{version}
59
60 %description devel
61 Header files and development documentation for the FOX library.
62
63 %description devel -l pl
64 Pliki nag³ówkowe i dokumentacja programisty do biblioteki FOX.
65
66 %package static
67 Summary:        FOX static libraries
68 Summary(pl):    Biblioteki statyczne FOX
69 Group:          X11/Development/Libraries
70 Requires:       %{name}-devel = %{version}
71
72 %description static
73 FOX static libraries.
74
75 %description static -l pl
76 Biblioteki statyczne FOX.
77
78 %prep
79 %setup -q
80 %patch -p1
81
82 %build
83 rm -f missing
84 %{__libtoolize}
85 %{__aclocal}
86 %{__autoconf}
87 %{__automake}
88 %configure \
89         --with-opengl=mesa \
90         %{?debug:--enable-debug}%{!?_debug:--enable-release}
91 %{__make} GL_LIBS="-lGL -lGLU"
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT%{_datadir}
96
97 %{__make} install DESTDIR=$RPM_BUILD_ROOT
98
99 cp -p pathfinder/.libs/PathFinder $RPM_BUILD_ROOT%{_bindir}
100
101 rm -f doc/Makefile* doc/*/Makefile*
102
103 %clean
104 rm -rf $RPM_BUILD_ROOT
105
106 %post   -p /sbin/ldconfig
107 %postun -p /sbin/ldconfig
108
109 %files
110 %defattr(644,root,root,755)
111 %doc AUTHORS README
112 %attr(755,root,root) %{_libdir}/lib*.so.*.*
113
114 %files progs
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_bindir}/adie
117 %attr(755,root,root) %{_bindir}/calculator
118 %attr(755,root,root) %{_bindir}/PathFinder
119
120 %files devel
121 %defattr(644,root,root,755)
122 %doc ADDITIONS TRACING doc
123 %attr(755,root,root) %{_bindir}/reswrap
124 %attr(755,root,root) %{_libdir}/lib*.so
125 %{_libdir}/lib*.la
126 %{_mandir}/man1/*
127 %{_includedir}/fox
128
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/lib*.a
This page took 0.062162 seconds and 3 git commands to generate.