]> git.pld-linux.org Git - packages/forcefield.git/blob - forcefield.spec
- Requires(post,postun): gtk-update-icon-cache
[packages/forcefield.git] / forcefield.spec
1 #
2 # TODO:
3 # - real descriptions
4 # - check BR-s and R-s
5 #
6 %define     _snap   20070924
7 Summary:        A GNOME GUI for TrueCrypt
8 Summary(pl.UTF-8):      Graficzny interfejs GNOME do TrueCrypta
9 Name:           forcefield
10 Version:        0.92
11 Release:        0.%{_snap}
12 License:        GPL
13 Group:          Applications/System
14 # Download current version with: svn checkout
15 # http://bockcay.de/svn/forcefield/trunk
16 Source0:        %{name}-%{_snap}.tar.bz2
17 # Source0-md5:  6e403a32487c24eeb0fea2ec30500276
18 Source1:        %{name}.desktop
19 Patch0:         %{name}-install.patch
20 Patch1:         %{name}-cracklib.patch
21 URL:            http://www.bockcay.de/forcefield
22 BuildRequires:  autoconf >= 2.53
23 BuildRequires:  automake >= 1:1.9
24 BuildRequires:  python >= 1:2.5
25 BuildRequires:  python-gnome-devel
26 BuildRequires:  python-pygtk-devel >= 2:2.0
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.311
29 BuildRequires:  sed >= 4.0
30 Requires(post,postun):  gtk-update-icon-cache
31 Requires(post,postun):  hicolor-icon-theme
32 Requires(post,postun):  shared-mime-info
33 Requires(post,preun):   GConf2 >= 2.4.0
34 %pyrequires_eq  python
35 Requires:       cracklib
36 Requires:       python-cracklib
37 Requires:       python-gnome
38 Requires:       python-gnome-extras
39 Requires:       python-gnome-gconf
40 Requires:       python-pexpect
41 Requires:       python-pygtk-glade >= 2:2.0
42 Requires:       python-pygtk-gtk >= 2:2.0
43 Requires:       python-pynotify
44 Requires:       truecrypt
45 BuildArch:      noarch
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 A GNOME GUI for TrueCrypt.
50
51 %description -l pl.UTF-8
52 Graficzny interfejs GNOME do TrueCrypta.
53
54 %prep
55 %setup -q -n %{name}-%{_snap}
56 %patch0 -p1
57 %patch1 -p1
58
59 sed -i -e 's|include/python2.4|include/python%{py_ver} $(CFLAGS) -fPIC|g' src/lib/Makefile.am
60 # kill precompiled x86 module
61 rm data/misc/crack.so
62
63 %build
64 %{__aclocal}
65 %{__autoconf}
66 %{__automake}
67 %configure \
68         --disable-schemas-install
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
78
79 %py_postclean
80 %find_lang %{name}
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post
86 %gconf_schema_install %{name}.schemas
87 %update_icon_cache hicolor
88 %update_mime_database
89
90 %preun
91 %gconf_schema_uninstall %{name}.schemas
92
93 %postun
94 %update_icon_cache hicolor
95 %update_mime_database
96
97 %files -f %{name}.lang
98 %defattr(644,root,root,755)
99 %doc README AUTHORS ChangeLog
100 %attr(755,root,root) %{_bindir}/%{name}
101 %{_sysconfdir}/gconf/schemas/%{name}.schemas
102 %dir %{py_sitedir}/%{name}
103 %{py_sitedir}/%{name}/*.py[co]
104 %attr(755,root,root) %{py_sitedir}/%{name}/zero_out.so
105 %{_datadir}/%{name}
106 %{_iconsdir}/hicolor/24x24/apps/%{name}.png
107 %{_desktopdir}/%{name}.desktop
108 %{_datadir}/mime/packages/%{name}.xml
This page took 0.093861 seconds and 3 git commands to generate.