]> git.pld-linux.org Git - packages/fonts-TTF-microsoft.git/blob - fonts-TTF-microsoft.spec
- removed ftp url, which is 1) pointing to src.rpm in RPMS dir, 2) the -installer...
[packages/fonts-TTF-microsoft.git] / fonts-TTF-microsoft.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package
4 #
5 Summary:        Microsoft True Type fonts
6 Summary(pl):    Fonty True Type firmy Microsoft
7 %define         base_name       fonts-TTF-microsoft
8 %if %{with license_agreement}
9 Name:           %{base_name}
10 %else
11 Name:           %{base_name}-installer
12 %endif
13 Version:        20020525
14 Release:        5%{?with_license_agreement:wla}
15 License:        Microsoft EULA (for non-commercial use)
16 Group:          Fonts
17 %if %{with license_agreement}
18 Source0:        http://dl.sourceforge.net/corefonts/andale32.exe
19 # NoSource0-md5:        cbdc2fdd7d2ed0832795e86a8b9ee19a
20 Source1:        http://dl.sourceforge.net/corefonts/arial32.exe
21 # NoSource1-md5:        9637df0e91703179f0723ec095a36cb5
22 Source2:        http://dl.sourceforge.net/corefonts/arialb32.exe
23 # NoSource2-md5:        c9089ae0c3b3d0d8c4b0a95979bb9ff0
24 Source3:        http://dl.sourceforge.net/corefonts/comic32.exe
25 # NoSource3-md5:        2b30de40bb5e803a0452c7715fc835d1
26 Source4:        http://dl.sourceforge.net/corefonts/courie32.exe
27 # NoSource4-md5:        4e412c772294403ab62fb2d247d85c60
28 Source5:        http://dl.sourceforge.net/corefonts/georgi32.exe
29 # NoSource5-md5:        4d90016026e2da447593b41a8d8fa8bd
30 Source6:        http://dl.sourceforge.net/corefonts/impact32.exe
31 # NoSource6-md5:        7907c7dd6684e9bade91cff82683d9d7
32 Source7:        http://dl.sourceforge.net/corefonts/times32.exe
33 # NoSource7-md5:        ed39c8ef91b9fb80f76f702568291bd5
34 Source8:        http://dl.sourceforge.net/corefonts/trebuc32.exe
35 # NoSource8-md5:        0d7ea16cac6261f8513a061fbfcdb2b5
36 Source9:        http://dl.sourceforge.net/corefonts/verdan32.exe
37 # NoSource9-md5:        12d2a75f8156e10607be1eaa8e8ef120
38 Source10:       http://dl.sourceforge.net/corefonts/webdin32.exe
39 # NoSource10-md5:       230a1d13a365b22815f502eb24d9149b
40 %else
41 # extracted from one of the above
42 Source20:       Microsoft-EULA.txt
43 %endif
44 URL:            http://corefonts.sourceforge.net/
45 %if %{with license_agreement}
46 BuildRequires:  cabextract
47 Requires:       %{_fontsdir}/TTF
48 Requires(post,postun):  fontpostinst
49 %else
50 Requires:       cabextract
51 Requires:       rpm-build-tools
52 Requires:       wget
53 %endif
54 BuildArch:      noarch
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %define         ttffontsdir     %{_fontsdir}/TTF
58
59 %description
60 Microsoft free True Type fonts collection.
61 %if %{without license_agreement}
62 License issues made us not to include inherent files into this package
63 by default. If you want to create full working package please build it
64 with one of the following command:
65
66 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
67 %endif
68
69 %description -l pl
70 Kolekcja darmowych fontów True Type firmy Microsoft.
71 %if %{without license_agreement}
72 Kwestie licencji zmusi³y nas do niedo³±czania do tego pakietu istotnych
73 plików. Je¶li chcesz stworzyæ w pe³ni funkcjonalny pakiet, zbuduj go za
74 pomoc± polecenia:
75
76 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
77 %endif
78
79 %prep
80 %if %{with license_agreement}
81 %setup -q -c -T
82 /usr/bin/cabextract -L %{SOURCE0} %{SOURCE1} %{SOURCE2} %{SOURCE3} \
83 %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} %{SOURCE9} \
84 %{SOURCE10}
85 %endif
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %if %{without license_agreement}
91 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
92
93 cat <<EOF >$RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
94 #!/bin/sh
95 if [ "\$1" = "--with" -a "\$2" = "license_agreement" ]
96 then
97         TMPDIR=\`rpm --eval "%%{tmpdir}"\`; export TMPDIR
98         SPECDIR=\`rpm --eval "%%{_specdir}"\`; export SPECDIR
99         SRPMDIR=\`rpm --eval "%%{_srcrpmdir}"\`; export SRPMDIR
100         SOURCEDIR=\`rpm --eval "%%{_sourcedir}"\`; export SOURCEDIR
101         BUILDDIR=\`rpm --eval "%%{_builddir}"\`; export BUILDDIR
102         RPMDIR=\`rpm --eval "%%{_rpmdir}"\`; export RPMDIR
103         BACKUP_SPEC=0
104         mkdir -p \$TMPDIR \$SPECDIR \$SRPMDIR \$RPMDIR \$SRPMDIR \$SOURCEDIR \$BUILDDIR
105         if [ -f \$SPECDIR/%{base_name}.spec ]; then
106                 BACKUP_SPEC=1
107                 mv -f \$SPECDIR/%{base_name}.spec \$SPECDIR/%{base_name}.spec.prev
108         fi
109         if echo "\$3" | grep '\.src\.rpm$' >/dev/null; then
110                 ( cd \$SRPMDIR
111                 if echo "\$3" | grep '://' >/dev/null; then
112                         wget --passive-ftp -t0 "\$3"
113                 else
114                         cp -f "\$3" .
115                 fi
116                 rpm2cpio \`basename "\$3"\` | ( cd \$TMPDIR; cpio -i %{base_name}.spec ) )
117                 if ! cp -i \$TMPDIR/%{base_name}.spec \$SPECDIR/%{base_name}.spec; then
118                         exit 1
119                 fi
120         else
121                 if ! cp -i "\$3" \$SPECDIR; then
122                         exit 1
123                 fi
124         fi
125         ( cd \$SPECDIR
126         %{_bindir}/builder -nc -ncs --with license_agreement --opts --target=%{_target_cpu} %{base_name}.spec
127         if [ "\$?" -ne 0 ]; then
128                 exit 2
129         fi
130         RPMNAME=%{base_name}-%{version}-%{release}wla.noarch.rpm
131         rpm -U \$RPMDIR/\$RPMNAME || \
132                 echo -e Install manually the file:\\\n   \$RPMDIR/\$RPMNAME )
133         if [ "\$BACKUP_SPEC" -eq 1 ]; then
134                 mv -f \$SPECDIR/%{base_name}.spec.prev \$SPECDIR/%{base_name}.spec
135         fi
136 else
137         cat %{_datadir}/%{base_name}/Microsot-EULA.txt
138         echo "
139 If you accept the above license rebuild the package using:
140
141 \$0 --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
142 "
143 fi
144 EOF
145
146 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
147 install %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
148
149 %else
150 install -d $RPM_BUILD_ROOT%{ttffontsdir}
151 install *.ttf $RPM_BUILD_ROOT%{ttffontsdir}
152 %endif
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %if %{with license_agreement}
158 %post
159 fontpostinst TTF
160
161 %postun
162 fontpostinst TTF
163
164 %else
165 %pre
166 echo "
167 If you accept the license enclosed in the file
168 %{_datadir}/%{base_name}/Microsoft-EULA.txt
169 and want to install real fonts, then rebuild the package with the
170 following command:
171
172 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
173 "
174 %endif
175
176 %files
177 %defattr(644,root,root,755)
178 %if %{with license_agreement}
179 %doc licen.txt
180 %{ttffontsdir}/*
181 %else
182 %attr(755,root,root) %{_bindir}/%{base_name}.install
183 %{_datadir}/%{base_name}
184 %endif
This page took 0.122397 seconds and 4 git commands to generate.