]> git.pld-linux.org Git - packages/fonts-TTF-microsoft.git/blob - fonts-TTF-microsoft.spec
- use rpmbuild(macros) virtual, not direct package name
[packages/fonts-TTF-microsoft.git] / fonts-TTF-microsoft.spec
1 # NOTE
2 # according to EULA we *can* store the .exe's in distfiles in
3 # unaltered form (that is those .exe files), while can't distribute
4 # resulting rpm.
5 #
6 # Conditional build:
7 %bcond_with     license_agreement       # generates package
8
9 %define         base_name       fonts-TTF-microsoft
10 %define         rel     11
11 Summary:        Microsoft TrueType fonts
12 Summary(pl.UTF-8):      Fonty TrueType firmy Microsoft
13 %if %{with license_agreement}
14 Name:           %{base_name}
15 %else
16 Name:           %{base_name}-installer
17 %endif
18 Version:        20020525
19 Release:        %{rel}%{?with_license_agreement:wla}
20 License:        Microsoft EULA (for non-commercial use)
21 Group:          Fonts
22 %if %{with license_agreement}
23 Source0:        http://downloads.sourceforge.net/corefonts/andale32.exe
24 # Source0-md5:  cbdc2fdd7d2ed0832795e86a8b9ee19a
25 Source1:        http://downloads.sourceforge.net/corefonts/arial32.exe
26 # Source1-md5:  9637df0e91703179f0723ec095a36cb5
27 Source2:        http://downloads.sourceforge.net/corefonts/arialb32.exe
28 # Source2-md5:  c9089ae0c3b3d0d8c4b0a95979bb9ff0
29 Source3:        http://downloads.sourceforge.net/corefonts/comic32.exe
30 # Source3-md5:  2b30de40bb5e803a0452c7715fc835d1
31 Source4:        http://downloads.sourceforge.net/corefonts/courie32.exe
32 # Source4-md5:  4e412c772294403ab62fb2d247d85c60
33 Source5:        http://downloads.sourceforge.net/corefonts/georgi32.exe
34 # Source5-md5:  4d90016026e2da447593b41a8d8fa8bd
35 Source6:        http://downloads.sourceforge.net/corefonts/impact32.exe
36 # Source6-md5:  7907c7dd6684e9bade91cff82683d9d7
37 Source7:        http://downloads.sourceforge.net/corefonts/times32.exe
38 # Source7-md5:  ed39c8ef91b9fb80f76f702568291bd5
39 Source8:        http://downloads.sourceforge.net/corefonts/trebuc32.exe
40 # Source8-md5:  0d7ea16cac6261f8513a061fbfcdb2b5
41 Source9:        http://downloads.sourceforge.net/corefonts/verdan32.exe
42 # Source9-md5:  12d2a75f8156e10607be1eaa8e8ef120
43 Source10:       http://downloads.sourceforge.net/corefonts/webdin32.exe
44 # Source10-md5: 230a1d13a365b22815f502eb24d9149b
45 %else
46 Source21:       http://svn.pld-linux.org/svn/license-installer/license-installer.sh
47 # Source21-md5: 329c25f457fea66ec502b7ef70cb9ede
48 # extracted from one of the above
49 Source20:       Microsoft-EULA.txt
50 %endif
51 URL:            http://corefonts.sourceforge.net/
52 %if %{with license_agreement}
53 BuildRequires:  cabextract
54 Requires(post,postun):  fontpostinst
55 Requires:       %{_fontsdir}/TTF
56 Requires:       %{name}-ariblk
57 Requires:       fontpostinst
58 %else
59 Requires:       cabextract
60 Requires:       mktemp > 1.5-18
61 Requires:       rpm-build-tools >= 4.4.37
62 Requires:       rpmbuild(macros) >= 1.544
63 %endif
64 BuildArch:      noarch
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %define         ttffontsdir     %{_fontsdir}/TTF
68
69 %description
70 Microsoft free TrueType fonts collection.
71
72 %description -l pl.UTF-8
73 Kolekcja darmowych fontów TrueType firmy Microsoft.
74
75 %package ariblk
76 Summary:        Microsoft TrueType fonts - Arial Black
77 Group:          Fonts
78 Requires(post,postun):  fontpostinst
79 Requires:       %{_fontsdir}/TTF
80 Requires:       fontpostinst
81
82 %description ariblk
83 Microsoft TrueType fonts - Arial Black.
84
85 %prep
86 %if %{with license_agreement}
87 %setup -q -c -T
88 %{_bindir}/cabextract -L %{SOURCE0} %{SOURCE1} %{SOURCE2} %{SOURCE3} \
89 %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} %{SOURCE9} \
90 %{SOURCE10}
91 mv licen.txt Microsoft-EULA.txt
92 %endif
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 %if %{without license_agreement}
97 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
98
99 sed -e '
100         s/@BASE_NAME@/%{base_name}/g
101         s/@TARGET_CPU@/%{_target_cpu}/g
102         s-@VERSION@-%{version}-g
103         s-@RELEASE@-%{release}-g
104         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
105         s,@DATADIR@,%{_datadir}/%{base_name},g
106         s,@LICENSE@,%{_datadir}/%{base_name}/Microsoft-EULA.txt,
107 ' %{SOURCE21} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
108
109 cp -a %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
110 install -p %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
111
112 %else
113 install -d $RPM_BUILD_ROOT%{ttffontsdir}
114 cp -a *.ttf $RPM_BUILD_ROOT%{ttffontsdir}
115 %endif
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %if %{with license_agreement}
121 %post
122 fontpostinst TTF
123
124 %postun
125 fontpostinst TTF
126
127 %post ariblk
128 fontpostinst TTF
129
130 %postun ariblk
131 fontpostinst TTF
132
133 %else
134 %post
135 echo "
136 If you accept the license enclosed in the file
137 %{_datadir}/%{base_name}/Microsoft-EULA.txt
138 and want to install real fonts, then rebuild the package with the
139 following command:
140
141 %{_bindir}/%{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
142 "
143 %endif
144
145 %files
146 %defattr(644,root,root,755)
147 %if %{with license_agreement}
148 %doc Microsoft-EULA.txt
149 %{ttffontsdir}/andalemo.ttf
150 %{ttffontsdir}/arial.ttf
151 %{ttffontsdir}/arialbd.ttf
152 %{ttffontsdir}/arialbi.ttf
153 %{ttffontsdir}/ariali.ttf
154 %{ttffontsdir}/comic*.ttf
155 %{ttffontsdir}/cour*.ttf
156 %{ttffontsdir}/georgia*.ttf
157 %{ttffontsdir}/impact.ttf
158 %{ttffontsdir}/times*.ttf
159 %{ttffontsdir}/trebuc*.ttf
160 %{ttffontsdir}/verdana*.ttf
161 %{ttffontsdir}/webdings.ttf
162 %else
163 %attr(755,root,root) %{_bindir}/%{base_name}.install
164 %{_datadir}/%{base_name}
165 %endif
166
167 %if %{with license_agreement}
168 %files ariblk
169 %defattr(644,root,root,755)
170 %{ttffontsdir}/ariblk.ttf
171 %endif
This page took 0.064206 seconds and 3 git commands to generate.