]> git.pld-linux.org Git - packages/fonts-TTF-microsoft.git/blame_incremental - fonts-TTF-microsoft.spec
- converted to UTF-8
[packages/fonts-TTF-microsoft.git] / fonts-TTF-microsoft.spec
... / ...
CommitLineData
1# NOTE
2# according to EULA we *can* store the .exe's in distfiles in
3# unaltered form (that is those .exe files), while can't distribute
4# resulting rpm.
5#
6# Conditional build:
7%bcond_with license_agreement # generates package
8#
9%define base_name fonts-TTF-microsoft
10Summary: Microsoft True Type fonts
11Summary(pl.UTF-8): Fonty True Type firmy Microsoft
12%if %{with license_agreement}
13Name: %{base_name}
14%else
15Name: %{base_name}-installer
16%endif
17%define _rel 8
18Version: 20020525
19Release: %{_rel}%{?with_license_agreement:wla}
20License: Microsoft EULA (for non-commercial use)
21Group: Fonts
22%if %{with license_agreement}
23Source0: http://dl.sourceforge.net/corefonts/andale32.exe
24# Source0-md5: cbdc2fdd7d2ed0832795e86a8b9ee19a
25Source1: http://dl.sourceforge.net/corefonts/arial32.exe
26# Source1-md5: 9637df0e91703179f0723ec095a36cb5
27Source2: http://dl.sourceforge.net/corefonts/arialb32.exe
28# Source2-md5: c9089ae0c3b3d0d8c4b0a95979bb9ff0
29Source3: http://dl.sourceforge.net/corefonts/comic32.exe
30# Source3-md5: 2b30de40bb5e803a0452c7715fc835d1
31Source4: http://dl.sourceforge.net/corefonts/courie32.exe
32# Source4-md5: 4e412c772294403ab62fb2d247d85c60
33Source5: http://dl.sourceforge.net/corefonts/georgi32.exe
34# Source5-md5: 4d90016026e2da447593b41a8d8fa8bd
35Source6: http://dl.sourceforge.net/corefonts/impact32.exe
36# Source6-md5: 7907c7dd6684e9bade91cff82683d9d7
37Source7: http://dl.sourceforge.net/corefonts/times32.exe
38# Source7-md5: ed39c8ef91b9fb80f76f702568291bd5
39Source8: http://dl.sourceforge.net/corefonts/trebuc32.exe
40# Source8-md5: 0d7ea16cac6261f8513a061fbfcdb2b5
41Source9: http://dl.sourceforge.net/corefonts/verdan32.exe
42# Source9-md5: 12d2a75f8156e10607be1eaa8e8ef120
43Source10: http://dl.sourceforge.net/corefonts/webdin32.exe
44# Source10-md5: 230a1d13a365b22815f502eb24d9149b
45%else
46Source21: license-installer.sh
47# extracted from one of the above
48Source20: Microsoft-EULA.txt
49%endif
50URL: http://corefonts.sourceforge.net/
51%if %{with license_agreement}
52BuildRequires: cabextract
53Requires(post,postun): fontpostinst
54Requires: %{_fontsdir}/TTF
55Requires: fontpostinst
56%else
57Requires: cabextract
58Requires: mktemp > 1.5-18
59Requires: rpm-build-tools
60%endif
61BuildArch: noarch
62BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64%define ttffontsdir %{_fontsdir}/TTF
65
66%description
67Microsoft free True Type fonts collection.
68
69%description -l pl.UTF-8
70Kolekcja darmowych fontów True Type firmy Microsoft.
71
72%prep
73%if %{with license_agreement}
74%setup -q -c -T
75%{_bindir}/cabextract -L %{SOURCE0} %{SOURCE1} %{SOURCE2} %{SOURCE3} \
76%{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} %{SOURCE9} \
77%{SOURCE10}
78%endif
79
80%install
81rm -rf $RPM_BUILD_ROOT
82
83%if !%{with license_agreement}
84install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
85
86sed -e '
87 s/@BASE_NAME@/%{base_name}/g
88 s/@TARGET_CPU@/%{_target_cpu}/g
89 s-@VERSION@-%{version}-g
90 s-@RELEASE@-%{release}-g
91 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
92 s,@LICENSE@,%{_datadir}/%{base_name}/Microsoft-EULA.txt,
93' %{SOURCE21} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
94
95install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
96install %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
97
98%else
99install -d $RPM_BUILD_ROOT%{ttffontsdir}
100install *.ttf $RPM_BUILD_ROOT%{ttffontsdir}
101%endif
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%if %{with license_agreement}
107%post
108fontpostinst TTF
109
110%postun
111fontpostinst TTF
112
113%else
114%post
115echo "
116If you accept the license enclosed in the file
117%{_datadir}/%{base_name}/Microsoft-EULA.txt
118and want to install real fonts, then rebuild the package with the
119following command:
120
121%{_bindir}/%{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
122"
123%endif
124
125%files
126%defattr(644,root,root,755)
127%if %{with license_agreement}
128%doc licen.txt
129%{ttffontsdir}/*
130%else
131%attr(755,root,root) %{_bindir}/%{base_name}.install
132%{_datadir}/%{base_name}
133%endif
This page took 0.028005 seconds and 4 git commands to generate.