]> git.pld-linux.org Git - packages/fonts-TTF-microsoft.git/blame - fonts-TTF-microsoft.spec
- converted to UTF-8
[packages/fonts-TTF-microsoft.git] / fonts-TTF-microsoft.spec
CommitLineData
427e4904
ER
1# NOTE
2# according to EULA we *can* store the .exe's in distfiles in
3# unaltered form (that is those .exe files), while can't distribute
4# resulting rpm.
ad7883a7 5#
6# Conditional build:
e9cdd5ee 7%bcond_with license_agreement # generates package
ad7883a7 8#
427e4904 9%define base_name fonts-TTF-microsoft
c9e67209 10Summary: Microsoft True Type fonts
7fed25b6 11Summary(pl.UTF-8): Fonty True Type firmy Microsoft
7152a5cf 12%if %{with license_agreement}
13Name: %{base_name}
14%else
15Name: %{base_name}-installer
16%endif
f515789a 17%define _rel 8
5e6fde32 18Version: 20020525
427e4904 19Release: %{_rel}%{?with_license_agreement:wla}
ad7883a7 20License: Microsoft EULA (for non-commercial use)
0dd2af23 21Group: Fonts
7152a5cf 22%if %{with license_agreement}
46c3747c 23Source0: http://dl.sourceforge.net/corefonts/andale32.exe
427e4904 24# Source0-md5: cbdc2fdd7d2ed0832795e86a8b9ee19a
46c3747c 25Source1: http://dl.sourceforge.net/corefonts/arial32.exe
427e4904 26# Source1-md5: 9637df0e91703179f0723ec095a36cb5
46c3747c 27Source2: http://dl.sourceforge.net/corefonts/arialb32.exe
427e4904 28# Source2-md5: c9089ae0c3b3d0d8c4b0a95979bb9ff0
46c3747c 29Source3: http://dl.sourceforge.net/corefonts/comic32.exe
427e4904 30# Source3-md5: 2b30de40bb5e803a0452c7715fc835d1
46c3747c 31Source4: http://dl.sourceforge.net/corefonts/courie32.exe
427e4904 32# Source4-md5: 4e412c772294403ab62fb2d247d85c60
46c3747c 33Source5: http://dl.sourceforge.net/corefonts/georgi32.exe
427e4904 34# Source5-md5: 4d90016026e2da447593b41a8d8fa8bd
46c3747c 35Source6: http://dl.sourceforge.net/corefonts/impact32.exe
427e4904 36# Source6-md5: 7907c7dd6684e9bade91cff82683d9d7
46c3747c 37Source7: http://dl.sourceforge.net/corefonts/times32.exe
427e4904 38# Source7-md5: ed39c8ef91b9fb80f76f702568291bd5
46c3747c 39Source8: http://dl.sourceforge.net/corefonts/trebuc32.exe
427e4904 40# Source8-md5: 0d7ea16cac6261f8513a061fbfcdb2b5
46c3747c 41Source9: http://dl.sourceforge.net/corefonts/verdan32.exe
427e4904 42# Source9-md5: 12d2a75f8156e10607be1eaa8e8ef120
46c3747c 43Source10: http://dl.sourceforge.net/corefonts/webdin32.exe
427e4904 44# Source10-md5: 230a1d13a365b22815f502eb24d9149b
7152a5cf 45%else
066d48b7 46Source21: license-installer.sh
7152a5cf 47# extracted from one of the above
48Source20: Microsoft-EULA.txt
ad7883a7 49%endif
d9d5f319 50URL: http://corefonts.sourceforge.net/
7152a5cf 51%if %{with license_agreement}
5e6fde32 52BuildRequires: cabextract
7152a5cf 53Requires(post,postun): fontpostinst
427e4904 54Requires: %{_fontsdir}/TTF
f515789a 55Requires: fontpostinst
7152a5cf 56%else
4b0c12c9 57Requires: cabextract
0410e77e 58Requires: mktemp > 1.5-18
7152a5cf 59Requires: rpm-build-tools
7152a5cf 60%endif
fb613dbd 61BuildArch: noarch
5e6fde32 62BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64%define ttffontsdir %{_fontsdir}/TTF
65
5e6fde32 66%description
c9e67209 67Microsoft free True Type fonts collection.
1ed1a3e7 68
7fed25b6
JR
69%description -l pl.UTF-8
70Kolekcja darmowych fontów True Type firmy Microsoft.
5e6fde32 71
72%prep
7152a5cf 73%if %{with license_agreement}
5e6fde32 74%setup -q -c -T
427e4904 75%{_bindir}/cabextract -L %{SOURCE0} %{SOURCE1} %{SOURCE2} %{SOURCE3} \
5e6fde32 76%{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} %{SOURCE9} \
77%{SOURCE10}
7152a5cf 78%endif
5e6fde32 79
7152a5cf 80%install
81rm -rf $RPM_BUILD_ROOT
5e6fde32 82
3d45beeb 83%if !%{with license_agreement}
7152a5cf 84install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
ad7883a7 85
11e9721d
ER
86sed -e '
87 s/@BASE_NAME@/%{base_name}/g
88 s/@TARGET_CPU@/%{_target_cpu}/g
89 s-@VERSION@-%{version}-g
90 s-@RELEASE@-%{release}-g
91 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
92 s,@LICENSE@,%{_datadir}/%{base_name}/Microsoft-EULA.txt,
066d48b7 93' %{SOURCE21} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
5e6fde32 94
7152a5cf 95install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
96install %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
97
98%else
5e6fde32 99install -d $RPM_BUILD_ROOT%{ttffontsdir}
46c3747c 100install *.ttf $RPM_BUILD_ROOT%{ttffontsdir}
7152a5cf 101%endif
1ed1a3e7 102
5e6fde32 103%clean
104rm -rf $RPM_BUILD_ROOT
105
7152a5cf 106%if %{with license_agreement}
5e6fde32 107%post
c9e67209 108fontpostinst TTF
5e6fde32 109
110%postun
c9e67209 111fontpostinst TTF
5e6fde32 112
7152a5cf 113%else
2d6092d3 114%post
7152a5cf 115echo "
116If you accept the license enclosed in the file
117%{_datadir}/%{base_name}/Microsoft-EULA.txt
118and want to install real fonts, then rebuild the package with the
119following command:
120
427e4904 121%{_bindir}/%{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
7152a5cf 122"
123%endif
124
5e6fde32 125%files
126%defattr(644,root,root,755)
7152a5cf 127%if %{with license_agreement}
5a547390 128%doc licen.txt
5e6fde32 129%{ttffontsdir}/*
7152a5cf 130%else
131%attr(755,root,root) %{_bindir}/%{base_name}.install
132%{_datadir}/%{base_name}
133%endif
This page took 0.055758 seconds and 4 git commands to generate.