]> git.pld-linux.org Git - packages/fonts-TTF-microsoft.git/blame - fonts-TTF-microsoft.spec
- license-installer.sh updated to r11289
[packages/fonts-TTF-microsoft.git] / fonts-TTF-microsoft.spec
CommitLineData
427e4904
ER
1# NOTE
2# according to EULA we *can* store the .exe's in distfiles in
3# unaltered form (that is those .exe files), while can't distribute
4# resulting rpm.
ad7883a7 5#
6# Conditional build:
e9cdd5ee 7%bcond_with license_agreement # generates package
737a0423 8
427e4904 9%define base_name fonts-TTF-microsoft
102f1eae 10%define rel 11
96a3b669
JB
11Summary: Microsoft TrueType fonts
12Summary(pl.UTF-8): Fonty TrueType firmy Microsoft
7152a5cf 13%if %{with license_agreement}
14Name: %{base_name}
15%else
16Name: %{base_name}-installer
17%endif
5e6fde32 18Version: 20020525
737a0423 19Release: %{rel}%{?with_license_agreement:wla}
ad7883a7 20License: Microsoft EULA (for non-commercial use)
0dd2af23 21Group: Fonts
7152a5cf 22%if %{with license_agreement}
b2a452b6 23Source0: http://downloads.sourceforge.net/corefonts/andale32.exe
427e4904 24# Source0-md5: cbdc2fdd7d2ed0832795e86a8b9ee19a
b2a452b6 25Source1: http://downloads.sourceforge.net/corefonts/arial32.exe
427e4904 26# Source1-md5: 9637df0e91703179f0723ec095a36cb5
b2a452b6 27Source2: http://downloads.sourceforge.net/corefonts/arialb32.exe
427e4904 28# Source2-md5: c9089ae0c3b3d0d8c4b0a95979bb9ff0
b2a452b6 29Source3: http://downloads.sourceforge.net/corefonts/comic32.exe
427e4904 30# Source3-md5: 2b30de40bb5e803a0452c7715fc835d1
b2a452b6 31Source4: http://downloads.sourceforge.net/corefonts/courie32.exe
427e4904 32# Source4-md5: 4e412c772294403ab62fb2d247d85c60
b2a452b6 33Source5: http://downloads.sourceforge.net/corefonts/georgi32.exe
427e4904 34# Source5-md5: 4d90016026e2da447593b41a8d8fa8bd
b2a452b6 35Source6: http://downloads.sourceforge.net/corefonts/impact32.exe
427e4904 36# Source6-md5: 7907c7dd6684e9bade91cff82683d9d7
b2a452b6 37Source7: http://downloads.sourceforge.net/corefonts/times32.exe
427e4904 38# Source7-md5: ed39c8ef91b9fb80f76f702568291bd5
b2a452b6 39Source8: http://downloads.sourceforge.net/corefonts/trebuc32.exe
427e4904 40# Source8-md5: 0d7ea16cac6261f8513a061fbfcdb2b5
b2a452b6 41Source9: http://downloads.sourceforge.net/corefonts/verdan32.exe
427e4904 42# Source9-md5: 12d2a75f8156e10607be1eaa8e8ef120
b2a452b6 43Source10: http://downloads.sourceforge.net/corefonts/webdin32.exe
427e4904 44# Source10-md5: 230a1d13a365b22815f502eb24d9149b
7152a5cf 45%else
209acadd 46Source21: http://svn.pld-linux.org/svn/license-installer/license-installer.sh
102f1eae 47# Source21-md5: 329c25f457fea66ec502b7ef70cb9ede
7152a5cf 48# extracted from one of the above
49Source20: Microsoft-EULA.txt
ad7883a7 50%endif
d9d5f319 51URL: http://corefonts.sourceforge.net/
7152a5cf 52%if %{with license_agreement}
5e6fde32 53BuildRequires: cabextract
7152a5cf 54Requires(post,postun): fontpostinst
427e4904 55Requires: %{_fontsdir}/TTF
b2a452b6 56Requires: %{name}-ariblk
f515789a 57Requires: fontpostinst
7152a5cf 58%else
4b0c12c9 59Requires: cabextract
0410e77e 60Requires: mktemp > 1.5-18
102f1eae 61Requires: rpm-build-macros >= 1.544
62Requires: rpm-build-tools >= 4.4.37
7152a5cf 63%endif
fb613dbd 64BuildArch: noarch
5e6fde32 65BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67%define ttffontsdir %{_fontsdir}/TTF
68
5e6fde32 69%description
96a3b669 70Microsoft free TrueType fonts collection.
1ed1a3e7 71
7fed25b6 72%description -l pl.UTF-8
96a3b669 73Kolekcja darmowych fontów TrueType firmy Microsoft.
5e6fde32 74
b2a452b6
ER
75%package ariblk
76Summary: Microsoft TrueType fonts - Arial Black
77Group: Fonts
78Requires(post,postun): fontpostinst
79Requires: %{_fontsdir}/TTF
80Requires: fontpostinst
81
82%description ariblk
83Microsoft TrueType fonts - Arial Black.
84
5e6fde32 85%prep
7152a5cf 86%if %{with license_agreement}
5e6fde32 87%setup -q -c -T
427e4904 88%{_bindir}/cabextract -L %{SOURCE0} %{SOURCE1} %{SOURCE2} %{SOURCE3} \
5e6fde32 89%{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7} %{SOURCE8} %{SOURCE9} \
90%{SOURCE10}
b2a452b6 91mv licen.txt Microsoft-EULA.txt
7152a5cf 92%endif
5e6fde32 93
7152a5cf 94%install
95rm -rf $RPM_BUILD_ROOT
b2a452b6 96%if %{without license_agreement}
7152a5cf 97install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
ad7883a7 98
11e9721d
ER
99sed -e '
100 s/@BASE_NAME@/%{base_name}/g
101 s/@TARGET_CPU@/%{_target_cpu}/g
102 s-@VERSION@-%{version}-g
103 s-@RELEASE@-%{release}-g
104 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
a78c593b 105 s,@DATADIR@,%{_datadir}/%{base_name},g
11e9721d 106 s,@LICENSE@,%{_datadir}/%{base_name}/Microsoft-EULA.txt,
066d48b7 107' %{SOURCE21} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
5e6fde32 108
b2a452b6
ER
109cp -a %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
110install -p %{SOURCE20} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
7152a5cf 111
112%else
5e6fde32 113install -d $RPM_BUILD_ROOT%{ttffontsdir}
b2a452b6 114cp -a *.ttf $RPM_BUILD_ROOT%{ttffontsdir}
7152a5cf 115%endif
1ed1a3e7 116
5e6fde32 117%clean
118rm -rf $RPM_BUILD_ROOT
119
7152a5cf 120%if %{with license_agreement}
5e6fde32 121%post
c9e67209 122fontpostinst TTF
5e6fde32 123
124%postun
c9e67209 125fontpostinst TTF
5e6fde32 126
b2a452b6
ER
127%post ariblk
128fontpostinst TTF
129
130%postun ariblk
131fontpostinst TTF
132
7152a5cf 133%else
2d6092d3 134%post
7152a5cf 135echo "
136If you accept the license enclosed in the file
137%{_datadir}/%{base_name}/Microsoft-EULA.txt
138and want to install real fonts, then rebuild the package with the
139following command:
140
427e4904 141%{_bindir}/%{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
7152a5cf 142"
143%endif
144
5e6fde32 145%files
146%defattr(644,root,root,755)
7152a5cf 147%if %{with license_agreement}
b2a452b6
ER
148%doc Microsoft-EULA.txt
149%{ttffontsdir}/andalemo.ttf
150%{ttffontsdir}/arial.ttf
151%{ttffontsdir}/arialbd.ttf
152%{ttffontsdir}/arialbi.ttf
153%{ttffontsdir}/ariali.ttf
154%{ttffontsdir}/comic*.ttf
155%{ttffontsdir}/cour*.ttf
156%{ttffontsdir}/georgia*.ttf
157%{ttffontsdir}/impact.ttf
158%{ttffontsdir}/times*.ttf
159%{ttffontsdir}/trebuc*.ttf
160%{ttffontsdir}/verdana*.ttf
161%{ttffontsdir}/webdings.ttf
7152a5cf 162%else
163%attr(755,root,root) %{_bindir}/%{base_name}.install
164%{_datadir}/%{base_name}
165%endif
b2a452b6
ER
166
167%if %{with license_agreement}
168%files ariblk
169%defattr(644,root,root,755)
170%{ttffontsdir}/ariblk.ttf
171%endif
This page took 0.062561 seconds and 4 git commands to generate.