]> git.pld-linux.org Git - packages/fonts-TTF-microsoft-tahoma.git/commitdiff
- updated to new CVS layout auto/ac/fonts-TTF-microsoft-tahoma-installer-20020525-4
authorpawelz <pawelz@pld-linux.org>
Sat, 26 Dec 2009 13:00:18 +0000 (13:00 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- switch to license-installer.sh from SVN/DistFiles
- R: rpm-build-tools >= 4.4.35 (due to new CVS layout)
- parse @DATADIR@ macro from from new license-installer.sh
- rel 4

Changed files:
    fonts-TTF-microsoft-tahoma.spec -> 1.15
    license-installer.sh -> 1.12

fonts-TTF-microsoft-tahoma.spec
license-installer.sh [deleted file]

index b591868bb3271d198d5a9e8aac615bc016f2b19c..c57f67946518be05be2897625700933009a9d56b 100644 (file)
@@ -11,7 +11,7 @@ Name:         %{base_name}
 Name:          %{base_name}-installer
 %endif
 Version:       20020525
-%define                _rel    3
+%define                _rel    4
 Release:       %{_rel}%{?with_license_agreement:wla}
 # part of IE update - requires Windows license to use
 License:       Windows EULA
@@ -24,9 +24,10 @@ BuildRequires:       cabextract
 Requires(post,postun): fontpostinst
 Requires:      %{_fontsdir}/TTF
 %else
-Source1:       license-installer.sh
+Source1:       http://svn.pld-linux.org/svn/license-installer/license-installer.sh
+# Source1-md5:  4fb1600353dd57fe088e0b12fb0ecac2
 Requires:      cabextract
-Requires:      rpm-build-tools
+Requires:      rpm-build-tools >= 4.4.35
 %endif
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -57,6 +58,7 @@ sed -e '
        s-@RELEASE@-%{release}-g
        s,@USE_DISTFILES@,no,g
        s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
+       s,@DATADIR@,%{_datadir}/%{base_name},g
 ' %{SOURCE1} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
 
 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
diff --git a/license-installer.sh b/license-installer.sh
deleted file mode 100644 (file)
index 07b3cb1..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-#!/bin/sh
-if [ "$1" = "--with" -a "$2" = "license_agreement" ]; then
-       tmp=$(mktemp -d)
-       SPECDIR=`rpm --define "_topdir $tmp" --eval "%{_specdir}"`
-       SRPMDIR=`rpm --define "_topdir $tmp" --eval "%{_srcrpmdir}"`
-       SOURCEDIR=`rpm --define "_topdir $tmp" --eval "%{_sourcedir}"`
-       BUILDDIR=`rpm --define "_topdir $tmp" --eval "%{_builddir}"`
-       RPMDIR=`rpm --define "_topdir $tmp" --eval "%{_rpmdir}"`
-       mkdir -p $SPECDIR $SRPMDIR $RPMDIR $SRPMDIR $SOURCEDIR $BUILDDIR
-
-       if echo "$3" | grep '\.src\.rpm$' >/dev/null; then
-               (
-               if echo "$3" | grep '://' >/dev/null; then
-                       cd $SRPMDIR
-                       wget --passive-ftp -t0 "$3"
-               else
-                       cp -f "$3" $SRPMDIR
-               fi
-               rpm2cpio `basename "$3"` | ( cd $SPECDIR; cpio -i @BASE_NAME@.spec )
-               if [ '@COPYSOURCES@' != '@'COPYSOURCES'@' ]; then
-                       rpm2cpio `basename "$3"` | ( cd $SOURCEDIR; cpio -i @COPYSOURCES@ )
-               fi
-               )
-       else
-               cp -i "$3" $SPECDIR || exit 1
-               if [ '@COPYSOURCES@' != '@'COPYSOURCES'@' ]; then
-                       for i in @COPYSOURCES@; do
-                               cp -i @DATADIR@/$i $SOURCEDIR/$i || exit 1
-                       done
-               fi
-       fi
-       ( cd $SPECDIR
-       nd=
-       if [ '@USE_DISTFILES@' = 'no' ]; then
-               nd=-nd
-       fi
-       /usr/bin/builder --define _topdir $tmp $nd -nm -nc -ncs --with license_agreement --target @TARGET_CPU@ @BASE_NAME@.spec
-       if [ "$?" -ne 0 ]; then
-               exit 2
-       fi
-       RPMNAMES="$RPMDIR/@BASE_NAME@-@VERSION@-@RELEASE@wla.@TARGET_CPU@.rpm"
-       rpm -Uhv $RPMNAMES || echo -e "Install manually the file(s):\n   $RPMNAMES" )
-else
-       if [ "@LICENSE@" != '@'LICENSE'@' ]; then
-               cat @LICENSE@
-               echo "
-If you accept the above license rebuild the package using:
-"
-       else
-               echo "
-License issues made us not to include inherent files into
-this package by default. If you want to create full working
-package please build it with the following command:
-"
-       fi
-       echo "$0 --with license_agreement @SPECFILE@"
-fi
This page took 0.07726 seconds and 4 git commands to generate.