]> git.pld-linux.org Git - packages/fonts-TTF-microsoft-tahoma.git/blobdiff - fonts-TTF-microsoft-tahoma.spec
- release 6 (by relup.sh)
[packages/fonts-TTF-microsoft-tahoma.git] / fonts-TTF-microsoft-tahoma.spec
index 526af6d0c6fab222c6c0b7d6b0757f3ec97e32c9..4c1d91e7fd11a078401cc5fcc7ffaeb84779b80e 100644 (file)
@@ -1,31 +1,34 @@
 #
 # Conditional build:
-%bcond_with    license_agreement
-# _with_license_agreement       - generates package (may require Windows license?)
+%bcond_with    license_agreement       # generates package (requires Windows license)
 #
-Summary:       Microsoft Tahoma True Type font
-Summary(pl):   Font True Type Tahoma firmy Microsoft
 %define                base_name               fonts-TTF-microsoft-tahoma
+%define                _rel                    6
+Summary:       Microsoft Tahoma TrueType font
+Summary(pl.UTF-8):     Font TrueType Tahoma firmy Microsoft
 %if %{with license_agreement}
 Name:          %{base_name}
 %else
 Name:          %{base_name}-installer
 %endif
 Version:       20020525
-Release:       1%{?with_license_agreement:wla}
-# part of IE update - may require Windows license to use
-License:       ?
+Release:       %{_rel}%{?with_license_agreement:wla}
+# part of IE update - requires Windows license to use
+License:       Windows EULA
 Group:         Fonts
 %if %{with license_agreement}
-# also at http://dl.sourceforge.net/corefonts/
 Source0:       http://download.microsoft.com/download/ie6sp1/finrel/6_sp1/W98NT42KMeXP/EN-US/IELPKTH.CAB
 # NoSource0-md5: 358584cddb75ac90472c25f01b308ebe
+NoSource:      0
 BuildRequires: cabextract
-Requires:      %{_fontsdir}/TTF
 Requires(post,postun): fontpostinst
+Requires:      %{_fontsdir}/TTF
 %else
-Requires:      rpm-build-tools
-Requires:      wget
+Source1:       http://svn.pld-linux.org/svn/license-installer/license-installer.sh
+# Source1-md5:  329c25f457fea66ec502b7ef70cb9ede
+Requires:      cabextract
+Requires:      rpm-build-tools >= 4.4.37
+Requires:      rpmbuild(macros) >= 1.544
 %endif
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -33,93 +36,31 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                ttffontsdir     %{_fontsdir}/TTF
 
 %description
-Microsoft Tahoma True Type font.
-%if ! %{with license_agreement}
-License issues made us not to include inherent files into this package
-by default (it probably requires Windows license). If you want to
-create full working package please build it with one of the following
-command:
+Microsoft Tahoma TrueType font.
 
-%{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
-%{base_name}.install --with license_agreement ftp://ftp.pld-linux.org/dists/ac/PLD/<your_arch>/PLD/RPMS/%{base_name}-{version}-{release}.src.rpm
-%endif
-
-%description -l pl
-Font True Type Tahoma firmy Microsoft.
-%if ! %{with license_agreement}
-Kwestie licencji zmusi³y nas do niedo³±czania do tego pakietu istotnych
-plików (prawdopodobnie wymaga licencji na Windows). Je¶li chcesz stworzyæ
-w pe³ni funkcjonalny pakiet, zbuduj go za pomoc± polecenia:
-
-%{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
-%{base_name}.install --with license_agreement ftp://ftp.pld-linux.org/dists/ac/PLD/<your_arch>/PLD/RPMS/%{base_name}-{version}-{release}.src.rpm
-%endif
+%description -l pl.UTF-8
+Font TrueType Tahoma firmy Microsoft.
 
 %prep
 %if %{with license_agreement}
 %setup -q -c -T
-/usr/bin/cabextract -L %{SOURCE0}
+%{_bindir}/cabextract -L %{SOURCE0}
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%if ! %{with license_agreement}
+%if !%{with license_agreement}
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
 
-cat <<EOF >$RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
-#!/bin/sh
-if [ "\$1" = "--with" -a "\$2" = "license_agreement" ]
-then
-       TMPDIR=\`rpm --eval "%%{tmpdir}"\`; export TMPDIR
-       SPECDIR=\`rpm --eval "%%{_specdir}"\`; export SPECDIR
-       SRPMDIR=\`rpm --eval "%%{_srcrpmdir}"\`; export SRPMDIR
-       SOURCEDIR=\`rpm --eval "%%{_sourcedir}"\`; export SOURCEDIR
-       BUILDDIR=\`rpm --eval "%%{_builddir}"\`; export BUILDDIR
-       RPMDIR=\`rpm --eval "%%{_rpmdir}"\`; export RPMDIR
-       BACKUP_SPEC=0
-       mkdir -p \$TMPDIR \$SPECDIR \$SRPMDIR \$RPMDIR \$SRPMDIR \$SOURCEDIR \$BUILDDIR
-       if [ -f \$SPECDIR/%{base_name}.spec ]; then
-               BACKUP_SPEC=1
-               mv -f \$SPECDIR/%{base_name}.spec \$SPECDIR/%{base_name}.spec.prev
-       fi
-       if echo "\$3" | grep '\.src\.rpm$' >/dev/null; then
-               ( cd \$SRPMDIR
-               if echo "\$3" | grep '://' >/dev/null; then
-                       wget --passive-ftp -t0 "\$3"
-               else
-                       cp -f "\$3" .
-               fi
-               rpm2cpio \`basename "\$3"\` | ( cd \$TMPDIR; cpio -i %{base_name}.spec ) )
-               if ! cp -i \$TMPDIR/%{base_name}.spec \$SPECDIR/%{base_name}.spec; then
-                       exit 1
-               fi
-       else
-               if ! cp -i "\$3" \$SPECDIR; then
-                       exit 1
-               fi
-       fi
-       ( cd \$SPECDIR
-       %{_bindir}/builder -nc -ncs --with license_agreement --opts --target=%{_target_cpu} %{base_name}.spec
-       if [ "\$?" -ne 0 ]; then
-               exit 2
-       fi
-       RPMNAME=%{base_name}-%{version}-%{release}wla.noarch.rpm
-       rpm -U \$RPMDIR/\$RPMNAME || \
-               echo -e Install manually the file:\\\n   \$RPMDIR/\$RPMNAME )
-       if [ "\$BACKUP_SPEC" -eq 1 ]; then
-               mv -f \$SPECDIR/%{base_name}.spec.prev \$SPECDIR/%{base_name}.spec
-       fi
-else
-       cat %{_datadir}/%{base_name}/Microsot-EULA.txt
-       echo "
-License issues made us not to include inherent files into this package
-by default (it probably requires Windows license). If you want to
-create full working package please build it with the following command:
-
-\$0 --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
-"
-fi
-EOF
+sed -e '
+       s/@BASE_NAME@/%{base_name}/g
+       s/@TARGET_CPU@/%{_target_cpu}/g
+       s-@VERSION@-%{version}-g
+       s-@RELEASE@-%{release}-g
+       s,@USE_DISTFILES@,no,g
+       s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
+       s,@DATADIR@,%{_datadir}/%{base_name},g
+' %{SOURCE1} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
 
 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
 
@@ -139,13 +80,13 @@ fontpostinst TTF
 fontpostinst TTF
 
 %else
-%pre
+%post
 echo "
 License issues made us not to include inherent files into this package
-by default (it probably requires Windows license). If you want to
-create full working package please build it with the following command:
+by default (You need Windows license). If you want to create full
+working package please build it with the following command:
 
-%{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
+%{_bindir}/%{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
 "
 %endif
 
This page took 0.065113 seconds and 4 git commands to generate.