]> git.pld-linux.org Git - packages/fonts-TTF-microsoft-arialunicode.git/commitdiff
- fix for installing from local src.rpm
authorElan Ruusamäe <glen@pld-linux.org>
Sun, 28 Aug 2005 20:24:17 +0000 (20:24 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    license-installer.sh -> 1.6

license-installer.sh

index 0d3933c3f6bc65b102af083357ea833a1890ac76..4a0378b24fb26823d03b88478055250dcb91a74e 100644 (file)
@@ -21,16 +21,18 @@ if [ "$1" = "--with" -a "$2" = "license_agreement" ]; then
                done
        fi
        if echo "$3" | grep '\.src\.rpm$' >/dev/null; then
-               ( cd $SRPMDIR
+               (
                if echo "$3" | grep '://' >/dev/null; then
+                       cd $SRPMDIR
                        wget --passive-ftp -t0 "$3"
                else
-                       cp -f "$3" .
+                       cp -f "$3" $SRPMDIR
+                       cd $SRPMDIR
                fi
                rpm2cpio `basename "$3"` | ( cd $TMPDIR; cpio -i @BASE_NAME@.spec )
                if [ '@COPYSOURCES@' != '@'COPYSOURCES'@' ]; then
                        for i in @COPYSOURCES@; do
-                               rpm2cpio $i | ( cd $TMPDIR; cpio -i $i )
+                               rpm2cpio `basename "$3"` | ( cd $TMPDIR; cpio -i $i )
                        done
                fi
                )
This page took 0.067778 seconds and 4 git commands to generate.