]> git.pld-linux.org Git - packages/fonts-TTF-Code2000.git/blame - fonts-TTF-Code2000.spec
- extracted from CODE2000.ZIP
[packages/fonts-TTF-Code2000.git] / fonts-TTF-Code2000.spec
CommitLineData
743673e2 1# NOTE
2# according to license we *can* store the .ZIP in distfiles in
3# unaltered form, while can't distribute resulting rpm.
4#
5# Conditional build:
6%bcond_with license_agreement # generates package
7#
8%define base_name fonts-TTF-Code2000
9Summary: Code2000 Unicode TrueType font
10Summary(pl.UTF-8): Unikodowy font TrueType Code2000
11%if %{with license_agreement}
12Name: %{base_name}
13%else
14Name: %{base_name}-installer
15%endif
16%define _rel 1
17Version: 1.171
18Release: %{_rel}%{?with_license_agreement:wla}
19License: Shareware, fee required
20Group: Fonts
21%if %{with license_agreement}
22Source0: http://code2000.net/CODE2000.ZIP
23# Source0-md5: 1fa4e4b61d7ac0980b038e9260667a77
24%else
25# Source10 extracted from Source0
26Source10: CODE2000.HTM
27Source11: http://svn.pld-linux.org/svn/license-installer/license-installer.sh
28# Source11-md5: 4fb1600353dd57fe088e0b12fb0ecac2
29%endif
30URL: http://code2000.net/code2000_page.htm
31%if %{with license_agreement}
32BuildRequires: unzip
33Requires(post,postun): fontpostinst
34Requires: %{_fontsdir}/TTF
35Requires: fontpostinst
36%else
37Requires: unzip
38Requires: mktemp > 1.5-18
39Requires: rpm-build-tools
40%endif
41BuildArch: noarch
42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44%define ttffontsdir %{_fontsdir}/TTF
45
46%description
47Code2000 is a shareware font. It is a Unicode-based font, as are many
48modern computer fonts. Code2000 is one of the larger fonts available
49and the latest build has over 60000 glyphs.
50
51It relies on font-smoothing (anti-aliasing) for screen display, it
52does not contain hinting instructions.
53
54%prep
55%if %{with license_agreement}
56%setup -q -c
57%endif
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62%if !%{with license_agreement}
63install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
64
65sed -e '
66 s/@BASE_NAME@/%{base_name}/g
67 s/@TARGET_CPU@/%{_target_cpu}/g
68 s-@VERSION@-%{version}-g
69 s-@RELEASE@-%{release}-g
70 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
71' %{SOURCE11} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
72
73install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
74install %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
75
76%else
77install -d $RPM_BUILD_ROOT%{ttffontsdir}
78install *.TTF $RPM_BUILD_ROOT%{ttffontsdir}
79%endif
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%if %{with license_agreement}
85%post
86fontpostinst TTF
87
88%postun
89fontpostinst TTF
90
91%else
92%post
93%{_bindir}/%{base_name}.install
94
95echo "
96License issues made us not to include inherent files into
97this package by default. If you accept the conditions specified
98by the font Author in:
99%{_datadir}/%{base_name}/CODE2000.HTM
100and want to install a real font, then rebuild the package with the
101following command:
102
103%{_bindir}/%{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
104"
105%endif
106
107%files
108%defattr(644,root,root,755)
109%if %{with license_agreement}
110%doc *.HTM
111%{ttffontsdir}/*
112%else
113%attr(755,root,root) %{_bindir}/%{base_name}.install
114%{_datadir}/%{base_name}
115%endif
This page took 0.077593 seconds and 4 git commands to generate.