]> git.pld-linux.org Git - packages/fonts-TTF-Bitstream-Cyberfonts.git/blobdiff - fonts-TTF-Bitstream-Cyberfonts.spec
- use rpmbuild(macros) virtual, not direct package name
[packages/fonts-TTF-Bitstream-Cyberfonts.git] / fonts-TTF-Bitstream-Cyberfonts.spec
index 80fcfce2c7d24a1bb8786e34f989c9fd7cde2bcf..8f0a1f0e521822d865b6b8b19aedb88e23fbe1ac 100644 (file)
@@ -2,16 +2,17 @@
 # Conditional build:
 %bcond_with    license_agreement       # generates package
 #
-Summary:       Bitstream Cyberfonts True Type font
-Summary(pl):   Font True Type Cyberfonts firmy Bitstream
 %define                base_name               fonts-TTF-Bitstream-Cyberfonts
+%define                rel                     3
+Summary:       Bitstream Cyberfonts TrueType font
+Summary(pl.UTF-8):     Font TrueType Cyberfonts firmy Bitstream
 %if %{with license_agreement}
 Name:          %{base_name}
 %else
 Name:          %{base_name}-installer
 %endif
 Version:       1.0
-Release:       1%{?with_license_agreement:wla}
+Release:       %{rel}%{?with_license_agreement:wla}
 License:       Nondistributable but free (See Bitstream-Cyberfonts-licence.txt)
 Group:         Fonts
 %if %{with license_agreement}
@@ -22,14 +23,19 @@ Source1:    ftp://ftp.netscape.com/pub/communicator/extras/fonts/windows/Cyberbase.
 # NoSource1-md5: 63a6f607ac5a78d34b67247b893faf5b
 Source2:       ftp://ftp.netscape.com/pub/communicator/extras/fonts/windows/CyberCJK.ZIP
 # NoSource2-md5: 63a6f607ac5a78d34b67247b893faf5b
-Source3:       %{base_name}-licence.txt
 BuildRequires: unzip
-Requires:      %{_fontsdir}/TTF
+# we need the -installer package as otherwise can't make end-user
+# package to work. see also comments in %%prep section.
+BuildRequires: %{base_name}-installer
 Requires(post,postun): fontpostinst
+Requires:      %{_fontsdir}/TTF
 %else
+Source0:       http://svn.pld-linux.org/svn/license-installer/license-installer.sh
+# NoSource0-md5:       329c25f457fea66ec502b7ef70cb9ede
+Source1:       %{base_name}-licence.txt
+Requires:      rpm-build-tools >= 4.4.37
+Requires:      rpmbuild(macros) >= 1.544
 Requires:      unzip
-Requires:      rpm-build-tools
-Requires:      wget
 %endif
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -37,26 +43,24 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                ttffontsdir     %{_fontsdir}/TTF
 
 %description
-Bitstream Cyberfonts True Type font.
-%if ! %{with license_agreement}
+Bitstream Cyberfonts TrueType font.
+%if !%{with license_agreement}
 License issues made us not to include inherent files into this package
 by default. If you want to
 create full working package please build it with one of the following
 command:
 
 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
-%{base_name}.install --with license_agreement ftp://ftp.pld-linux.org/dists/ac/PLD/<your_arch>/PLD/RPMS/%{base_name}-{version}-{release}.src.rpm
 %endif
 
-%description -l pl
-Font True Type Cyberfonts firmy Bitstream.
-%if ! %{with license_agreement}
-Kwestie licencji zmusi³y nas do niedo³±czania do tego pakietu istotnych
-plików. Je¶li chcesz stworzyæ
-w pe³ni funkcjonalny pakiet, zbuduj go za pomoc± polecenia:
+%description -l pl.UTF-8
+Font TrueType Cyberfonts firmy Bitstream.
+%if !%{with license_agreement}
+Kwestie licencji zmusiły nas do niedołączania do tego pakietu istotnych
+plików. Jeśli chcesz stworzyć
+w pełni funkcjonalny pakiet, zbuduj go za pomocą polecenia:
 
 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
-%{base_name}.install --with license_agreement ftp://ftp.pld-linux.org/dists/ac/PLD/<your_arch>/PLD/RPMS/%{base_name}-{version}-{release}.src.rpm
 %endif
 
 %prep
@@ -65,76 +69,32 @@ w pe
 /usr/bin/unzip -L %{SOURCE0}
 /usr/bin/unzip -L %{SOURCE1}
 /usr/bin/unzip -L %{SOURCE2}
-install %{SOURCE3} ./
+# ugly hack, to work with -installer package, when it may not fetch this file
+# from CVS with builder (-nc, -ncs)
+install %{_datadir}/%{base_name}/Bitstream-Cyberfonts-licence.txt .
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%if ! %{with license_agreement}
+%if !%{with license_agreement}
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
 
-cat <<EOF >$RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
-#!/bin/sh
-if [ "\$1" = "--with" -a "\$2" = "license_agreement" ]
-then
-       TMPDIR=\`rpm --eval "%%{tmpdir}"\`; export TMPDIR
-       SPECDIR=\`rpm --eval "%%{_specdir}"\`; export SPECDIR
-       SRPMDIR=\`rpm --eval "%%{_srcrpmdir}"\`; export SRPMDIR
-       SOURCEDIR=\`rpm --eval "%%{_sourcedir}"\`; export SOURCEDIR
-       BUILDDIR=\`rpm --eval "%%{_builddir}"\`; export BUILDDIR
-       RPMDIR=\`rpm --eval "%%{_rpmdir}"\`; export RPMDIR
-       BACKUP_SPEC=0
-       mkdir -p \$TMPDIR \$SPECDIR \$SRPMDIR \$RPMDIR \$SRPMDIR \$SOURCEDIR \$BUILDDIR
-       if [ -f \$SPECDIR/%{base_name}.spec ]; then
-               BACKUP_SPEC=1
-               mv -f \$SPECDIR/%{base_name}.spec \$SPECDIR/%{base_name}.spec.prev
-       fi
-       if echo "\$3" | grep '\.src\.rpm$' >/dev/null; then
-               ( cd \$SRPMDIR
-               if echo "\$3" | grep '://' >/dev/null; then
-                       wget --passive-ftp -t0 "\$3"
-               else
-                       cp -f "\$3" .
-               fi
-               rpm2cpio \`basename "\$3"\` | ( cd \$TMPDIR; cpio -i %{base_name}.spec ) )
-               if ! cp -i \$TMPDIR/%{base_name}.spec \$SPECDIR/%{base_name}.spec; then
-                       exit 1
-               fi
-       else
-               if ! cp -i "\$3" \$SPECDIR; then
-                       exit 1
-               fi
-       fi
-       ( cd \$SPECDIR
-       %{_bindir}/builder -nc -ncs --with license_agreement --opts --target=%{_target_cpu} %{base_name}.spec
-       if [ "\$?" -ne 0 ]; then
-               exit 2
-       fi
-       RPMNAME=%{base_name}-%{version}-%{release}wla.noarch.rpm
-       rpm -U \$RPMDIR/\$RPMNAME || \
-               echo -e Install manually the file:\\\n   \$RPMDIR/\$RPMNAME )
-       if [ "\$BACKUP_SPEC" -eq 1 ]; then
-               mv -f \$SPECDIR/%{base_name}.spec.prev \$SPECDIR/%{base_name}.spec
-       fi
-else
-       cat %{_datadir}/%{base_name}/Microsot-EULA.txt
-       echo "
-License issues made us not to include inherent files into this package
-by default. If you want to
-create full working package please build it with the following command:
-
-\$0 --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
-"
-fi
-EOF
+sed -e '
+       s/@BASE_NAME@/%{base_name}/g
+       s/@TARGET_CPU@/%{_target_cpu}/g
+       s-@VERSION@-%{version}-g
+       s-@RELEASE@-%{release}-g
+       s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
+       s,@LICENSE@,%{_datadir}/%{base_name}/Bitstream-Cyberfonts-licence.txt,
+       s,@DATADIR@,%{_datadir}/%{base_name},g
+' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
 
 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
+install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/%{base_name}/Bitstream-Cyberfonts-licence.txt
 %else
 install -d $RPM_BUILD_ROOT%{ttffontsdir}
 install *.ttf $RPM_BUILD_ROOT%{ttffontsdir}
 %endif
-install -d $RPM_BUILD_ROOT%{_datadir}/%{base_name}
-install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/%{base_name}/Bitstream-Cyberfonts-licence.txt
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -147,7 +107,7 @@ fontpostinst TTF
 fontpostinst TTF
 
 %else
-%pre
+%post
 echo "
 If you accept the license enclosed in the file
 %{_datadir}/%{base_name}/Bitstream-Cyberfonts-licence.txt
@@ -161,8 +121,9 @@ following command:
 %files
 %defattr(644,root,root,755)
 %if %{with license_agreement}
+%doc Bitstream-Cyberfonts-licence.txt
 %{ttffontsdir}/*
 %else
 %attr(755,root,root) %{_bindir}/%{base_name}.install
-%endif
 %{_datadir}/%{base_name}
+%endif
This page took 0.133675 seconds and 4 git commands to generate.