]> git.pld-linux.org Git - packages/fontforge.git/commitdiff
- rel 3; libpng fix; update configure options. auto/th/fontforge-20090923-3
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 2 Feb 2010 21:18:45 +0000 (21:18 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    fontforge-libpng.patch -> 1.1
    fontforge.spec -> 1.15

fontforge-libpng.patch [new file with mode: 0644]
fontforge.spec

diff --git a/fontforge-libpng.patch b/fontforge-libpng.patch
new file mode 100644 (file)
index 0000000..8dd7391
--- /dev/null
@@ -0,0 +1,53 @@
+--- fontforge-20090923/gutils/gimagereadpng.c.org      2010-02-02 22:11:46.311972507 +0100
++++ fontforge-20090923/gutils/gimagereadpng.c  2010-02-02 22:12:47.331770721 +0100
+@@ -220,13 +220,13 @@
+     if ( (info_ptr->valid&PNG_INFO_tRNS) && info_ptr->num_trans>0 ) {
+       if ( info_ptr->color_type==PNG_COLOR_TYPE_RGB || info_ptr->color_type==PNG_COLOR_TYPE_RGB_ALPHA )
+           base->trans = COLOR_CREATE(
+-                  (info_ptr->trans_values.red>>8),
+-                  (info_ptr->trans_values.green>>8),
+-                  (info_ptr->trans_values.blue>>8));
++                  (info_ptr->trans_color.red>>8),
++                  (info_ptr->trans_color.green>>8),
++                  (info_ptr->trans_color.blue>>8));
+       else if ( base->image_type == it_mono )
+-          base->trans = info_ptr->trans[0];
++          base->trans = info_ptr->trans_alpha[0];
+       else
+-          base->clut->trans_index = base->trans = info_ptr->trans[0];
++          base->clut->trans_index = base->trans = info_ptr->trans_alpha[0];
+     }
+     row_pointers = galloc(info_ptr->height*sizeof(png_bytep));
+--- fontforge-20090923/gutils/gimagewritepng.c.org     2010-02-02 22:12:59.071757326 +0100
++++ fontforge-20090923/gutils/gimagewritepng.c 2010-02-02 22:13:34.171767176 +0100
+@@ -314,15 +314,15 @@
+        if ( info_ptr->num_palette<=16 )
+          png_set_packing(png_ptr);
+        if ( base->trans!=-1 ) {
+-         info_ptr->trans = galloc(1);
+-         info_ptr->trans[0] = base->trans;
++         info_ptr->trans_alpha = galloc(1);
++         info_ptr->trans_alpha[0] = base->trans;
+        }
+    } else {
+        info_ptr->color_type = PNG_COLOR_TYPE_RGB;
+        if ( base->trans!=-1 ) {
+-         info_ptr->trans_values.red = COLOR_RED(base->trans);
+-         info_ptr->trans_values.green = COLOR_GREEN(base->trans);
+-         info_ptr->trans_values.blue = COLOR_BLUE(base->trans);
++         info_ptr->trans_color.red = COLOR_RED(base->trans);
++         info_ptr->trans_color.green = COLOR_GREEN(base->trans);
++         info_ptr->trans_color.blue = COLOR_BLUE(base->trans);
+        }
+    }
+    png_write_info(png_ptr, info_ptr);
+@@ -338,7 +338,7 @@
+     png_write_end(png_ptr, info_ptr);
+-    if ( info_ptr->trans!=NULL ) gfree(info_ptr->trans);
++    if ( info_ptr->trans_alpha!=NULL ) gfree(info_ptr->trans_alpha);
+     if ( info_ptr->palette!=NULL ) gfree(info_ptr->palette);
+     png_destroy_write_struct(&png_ptr, &info_ptr);
+     gfree(rows);
index d53c9e2135e30801fc3569690c6fdad8cd7997c4..3f1fc394d5dd3dd632c738b438efe485c62e7501 100644 (file)
@@ -2,12 +2,13 @@ Summary:      An outline font editor
 Summary(pl.UTF-8):     Edytor fontów rysowanych
 Name:          fontforge
 Version:       20090923
-Release:       2
+Release:       3
 License:       BSD
 Group:         X11/Applications/Publishing
 Source0:       http://dl.sourceforge.net/fontforge/%{name}_full-%{version}.tar.bz2
 # Source0-md5: ea9d8dc38de79235fbe6add725b38ffe
 Patch0:                %{name}-sonames.patch
+Patch1:                %{name}-libpng.patch
 URL:           http://fontforge.sourceforge.net/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -48,15 +49,18 @@ FontForge wcześniej nazywał się PfaEdit.
 %setup -q
 # hardcoded in code is +- same as hardcoded at compile time
 #%patch0 -p1
-#%patch2 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
 %configure \
+       --enable-type3 \
+       --enable-devicetables \
+       --enable-longdouble \
        --with-freetype-bytecode \
-       --with-multilayer \
+       --with-regular-link \
        --without-freetype-src
 
 %{__make}
This page took 0.127681 seconds and 4 git commands to generate.