]> git.pld-linux.org Git - packages/fontconfig.git/blob - fontconfig.spec
up to 2.13.0
[packages/fontconfig.git] / fontconfig.spec
1 #
2 # Conditional build
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  doc             # don't build HTML and man docs
5 %bcond_without  tests           # don't perform make check
6
7 Summary:        Font configuration and customization tools
8 Summary(pl.UTF-8):      Narzędzia do konfigurowania fontów
9 Summary(pt_BR.UTF-8):   Ferramentas para configuração e customização do acesso a fontes
10 Name:           fontconfig
11 Version:        2.13.0
12 Release:        1
13 Epoch:          1
14 License:        MIT
15 Group:          Libraries
16 Source0:        https://www.freedesktop.org/software/fontconfig/release/%{name}-%{version}.tar.bz2
17 # Source0-md5:  60d2394a79d3b2e5db2daea55193fa47
18 Source1:        %{name}-lcd-filter.conf
19 Patch0:         %{name}-bitstream-cyberbit.patch
20 URL:            http://fontconfig.org/
21 BuildRequires:  autoconf >= 2.61
22 BuildRequires:  automake >= 1:1.11
23 %if %{with doc}
24 BuildRequires:  docbook-dtd31-sgml
25 BuildRequires:  docbook-dtd41-sgml
26 BuildRequires:  docbook-utils >= 0.6.13-3
27 %endif
28 BuildRequires:  ed
29 BuildRequires:  expat-devel
30 BuildRequires:  freetype-devel >= 2.8.1
31 BuildRequires:  gettext-tools >= 0.19.8
32 BuildRequires:  gperf
33 BuildRequires:  libtool >= 2:2.2
34 BuildRequires:  pkgconfig
35 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
36 Requires:       freetype >= 2.8.1
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Fontconfig is designed to locate fonts within the system and select
41 them according to requirements specified by applications.
42
43 This package contains tools and documentation.
44
45 %description -l pl.UTF-8
46 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
47 systemie i wybierania ich w zależności od potrzeb aplikacji.
48
49 Paket ten zawiera programy narzędziowe i dokumentację.
50
51 %description -l pt_BR.UTF-8
52 Fontconfig é uma biblioteca para configuração e customização do acesso
53 a fontes.
54
55 Este pacote contém as ferramentas e documentação.
56
57 %package libs
58 Summary:        Font configuration and customization library
59 Summary(pl.UTF-8):      Biblioteka do konfigurowania fontów
60 Summary(pt_BR.UTF-8):   Biblioteca para configuração e customização do acesso a fontes
61 Group:          Libraries
62 Requires:       freetype >= 2.1.5
63 Provides:       XFree86-fontconfig
64 Obsoletes:      XFree86-fontconfig
65 Conflicts:      fontconfig <= 1:2.2.98-1
66
67 %description libs
68 Fontconfig is designed to locate fonts within the system and select
69 them according to requirements specified by applications.
70
71 %description libs -l pl.UTF-8
72 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
73 systemie i wybierania ich w zależności od potrzeb aplikacji.
74
75 %description libs -l pt_BR.UTF-8
76 Fontconfig é uma biblioteca para configuração e customização do acesso
77 a fontes.
78
79 %package devel
80 Summary:        Font configuration and customization library - development files
81 Summary(pl.UTF-8):      Biblioteka do konfigurowania fontów - pliki dla programistów
82 Summary(pt_BR.UTF-8):   Biblioteca para configuração e customização do acesso a fontes - arquivos de desenvolvimento
83 Group:          Development/Libraries
84 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
85 Requires:       expat-devel
86 Requires:       freetype-devel >= 2.1.5
87 Provides:       XFree86-fontconfig-devel
88 Obsoletes:      XFree86-fontconfig-devel
89
90 %description devel
91 Fontconfig is designed to locate fonts within the system and select
92 them according to requirements specified by applications.
93
94 This package contains the header files needed to develop programs that
95 use these fontconfig.
96
97 %description devel -l pl.UTF-8
98 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
99 systemie i wybierania ich w zależności od potrzeb aplikacji.
100
101 Ten pakiet zawiera pliki nagłówkowe potrzebne do kompilowania
102 programów korzystających z biblioteki fontconfig.
103
104 %description devel -l pt_BR.UTF-8
105 Fontconfig é uma biblioteca para configuração e customização do acesso
106 a fontes.
107
108 Este pacote contém arquivos de desenvolvimento necessários à criação
109 de extensões baseadas na biblioteca fontconfig.
110
111 %package static
112 Summary:        Static font configuration and customization library
113 Summary(pl.UTF-8):      Statyczna biblioteka do konfigurowania fontów
114 Summary(pt_BR.UTF-8):   Biblioteca estática para configuração e customização do acesso a fontes
115 Group:          Development/Libraries
116 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
117 Provides:       XFree86-fontconfig-static
118 Obsoletes:      XFree86-fontconfig-static
119
120 %description static
121 This package contains static version of fontconfig library.
122
123 %description static -l pl.UTF-8
124 Ten pakiet zawiera statyczną wersję biblioteki fontconfig.
125
126 %description static -l pt_BR.UTF-8
127 Este pacote contém a biblioteca estática do fontconfig
128
129 %prep
130 %setup -q
131 %patch0 -p1
132
133 %build
134 %{__gettextize}
135 %{__libtoolize}
136 %{__aclocal} -I m4
137 %{__autoconf}
138 %{__autoheader}
139 %{__automake}
140
141 # don't rebuild docs by default, use prebuild ones
142 export HASDOCBOOK=no
143
144 %configure \
145         --enable-docs%{!?with_doc:=no} \
146         --disable-silent-rules \
147         --%{?with_static_libs:en}%{!?with_static_libs:dis}able-static
148 %{__make}
149
150 %{?with_tests:%{__make} check}
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154 install -d $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5},/var/cache/fontconfig} \
155
156 %{__make} install \
157         DESTDIR=$RPM_BUILD_ROOT \
158         htmldoc_DATA= \
159         doc_DATA=
160
161 install %{SOURCE1} \
162         $RPM_BUILD_ROOT%{_datadir}/%{name}/conf.avail/10-lcd-filter.conf
163
164 ln -s %{_datadir}/%{name}/conf.avail $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.avail
165
166 cp -pf conf.d/README README.confd
167
168 %find_lang %{name}
169 %find_lang %{name}-conf -a %{name}.lang
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %pretrans
175 # this needs to be a symlink
176 if [ -d %{_sysconfdir}/fonts/conf.avail ] && [ ! -L %{_sysconfdir}/fonts/conf.avail ]; then
177         mv -f %{_sysconfdir}/fonts/conf.avail{,.rpmsave}
178         install -d %{_datadir}/%{name}/conf.avail
179         ln -s %{_datadir}/%{name}/conf.avail %{_sysconfdir}/fonts/conf.avail
180         mv -f %{_sysconfdir}/fonts/conf.avail.rpmsave/*.conf %{_sysconfdir}/fonts/conf.avail/
181         rmdir %{_sysconfdir}/fonts/conf.avail.rpmsave 2>/dev/null || :
182 fi
183
184 %post
185 umask 022
186 HOME=/tmp %{_bindir}/fc-cache -f 2>/dev/null || :
187
188 %post   libs -p /sbin/ldconfig
189 %postun libs -p /sbin/ldconfig
190
191 %files -f %{name}.lang
192 %defattr(644,root,root,755)
193 %doc AUTHORS COPYING ChangeLog README README.confd doc/fontconfig-user.html
194 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/fonts.conf
195 %{_sysconfdir}/fonts/conf.avail
196 %{_sysconfdir}/fonts/conf.d/README
197 %config(noreplace,missingok) %verify(not link md5 mtime size) %{_sysconfdir}/fonts/conf.d/*.conf
198 %attr(755,root,root) %{_bindir}/fc-cache
199 %attr(755,root,root) %{_bindir}/fc-cat
200 %attr(755,root,root) %{_bindir}/fc-conflist
201 %attr(755,root,root) %{_bindir}/fc-list
202 %attr(755,root,root) %{_bindir}/fc-match
203 %attr(755,root,root) %{_bindir}/fc-query
204 %attr(755,root,root) %{_bindir}/fc-pattern
205 %attr(755,root,root) %{_bindir}/fc-scan
206 %attr(755,root,root) %{_bindir}/fc-validate
207 %dir %{_datadir}/xml/%{name}
208 %{_datadir}/xml/%{name}/fonts.dtd
209 %{_datadir}/%{name}/conf.avail/*.conf
210 %if %{with doc}
211 %{_mandir}/man1/fc-*.1*
212 %{_mandir}/man5/fonts-conf.5*
213 %endif
214 %dir /var/cache/fontconfig
215
216 %files libs
217 %defattr(644,root,root,755)
218 %attr(755,root,root) %{_libdir}/libfontconfig.so.*.*.*
219 %attr(755,root,root) %ghost %{_libdir}/libfontconfig.so.1
220
221 %files devel
222 %defattr(644,root,root,755)
223 %doc doc/fontconfig-devel/*.html
224 %attr(755,root,root) %{_libdir}/libfontconfig.so
225 %{_libdir}/libfontconfig.la
226 %{_includedir}/fontconfig
227 %{_pkgconfigdir}/fontconfig.pc
228 %{_datadir}/gettext/its/fontconfig.its
229 %{_datadir}/gettext/its/fontconfig.loc
230 %if %{with doc}
231 %{_mandir}/man3/Fc*.3*
232 %endif
233
234 %if %{with static_libs}
235 %files static
236 %defattr(644,root,root,755)
237 %{_libdir}/libfontconfig.a
238 %endif
This page took 0.049981 seconds and 3 git commands to generate.