]> git.pld-linux.org Git - packages/fontconfig.git/blob - fontconfig.spec
a0857ef2b73d45329fffd763492afb06ff3ba852
[packages/fontconfig.git] / fontconfig.spec
1 #
2 # Conditional build
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  doc             # don't build HTML and man docs
5 %bcond_without  tests           # don't perform make check
6
7 Summary:        Font configuration and customization tools
8 Summary(pl.UTF-8):      Narzędzia do konfigurowania fontów
9 Summary(pt_BR.UTF-8):   Ferramentas para configuração e customização do acesso a fontes
10 Name:           fontconfig
11 Version:        2.12.3
12 Release:        2
13 Epoch:          1
14 License:        MIT
15 Group:          Libraries
16 Source0:        https://www.freedesktop.org/software/fontconfig/release/%{name}-%{version}.tar.bz2
17 # Source0-md5:  872f757ec180e8c51918ff39705c40de
18 Source1:        %{name}-lcd-filter.conf
19 Patch0:         %{name}-bitstream-cyberbit.patch
20 URL:            http://fontconfig.org/
21 BuildRequires:  autoconf >= 2.61
22 BuildRequires:  automake >= 1:1.11
23 %if %{with doc}
24 BuildRequires:  docbook-dtd31-sgml
25 BuildRequires:  docbook-dtd41-sgml
26 BuildRequires:  docbook-utils >= 0.6.13-3
27 %endif
28 BuildRequires:  ed
29 BuildRequires:  expat-devel
30 BuildRequires:  freetype-devel >= 2.1.5
31 BuildRequires:  gperf
32 BuildRequires:  libtool >= 2:2.2
33 BuildRequires:  pkgconfig
34 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
35 Requires:       freetype >= 2.1.5
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Fontconfig is designed to locate fonts within the system and select
40 them according to requirements specified by applications.
41
42 This package contains tools and documentation.
43
44 %description -l pl.UTF-8
45 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
46 systemie i wybierania ich w zależności od potrzeb aplikacji.
47
48 Paket ten zawiera programy narzędziowe i dokumentację.
49
50 %description -l pt_BR.UTF-8
51 Fontconfig é uma biblioteca para configuração e customização do acesso
52 a fontes.
53
54 Este pacote contém as ferramentas e documentação.
55
56 %package libs
57 Summary:        Font configuration and customization library
58 Summary(pl.UTF-8):      Biblioteka do konfigurowania fontów
59 Summary(pt_BR.UTF-8):   Biblioteca para configuração e customização do acesso a fontes
60 Group:          Libraries
61 Requires:       freetype >= 2.1.5
62 Provides:       XFree86-fontconfig
63 Obsoletes:      XFree86-fontconfig
64 Conflicts:      fontconfig <= 1:2.2.98-1
65
66 %description libs
67 Fontconfig is designed to locate fonts within the system and select
68 them according to requirements specified by applications.
69
70 %description libs -l pl.UTF-8
71 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
72 systemie i wybierania ich w zależności od potrzeb aplikacji.
73
74 %description libs -l pt_BR.UTF-8
75 Fontconfig é uma biblioteca para configuração e customização do acesso
76 a fontes.
77
78 %package devel
79 Summary:        Font configuration and customization library - development files
80 Summary(pl.UTF-8):      Biblioteka do konfigurowania fontów - pliki dla programistów
81 Summary(pt_BR.UTF-8):   Biblioteca para configuração e customização do acesso a fontes - arquivos de desenvolvimento
82 Group:          Development/Libraries
83 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
84 Requires:       expat-devel
85 Requires:       freetype-devel >= 2.1.5
86 Provides:       XFree86-fontconfig-devel
87 Obsoletes:      XFree86-fontconfig-devel
88
89 %description devel
90 Fontconfig is designed to locate fonts within the system and select
91 them according to requirements specified by applications.
92
93 This package contains the header files needed to develop programs that
94 use these fontconfig.
95
96 %description devel -l pl.UTF-8
97 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
98 systemie i wybierania ich w zależności od potrzeb aplikacji.
99
100 Ten pakiet zawiera pliki nagłówkowe potrzebne do kompilowania
101 programów korzystających z biblioteki fontconfig.
102
103 %description devel -l pt_BR.UTF-8
104 Fontconfig é uma biblioteca para configuração e customização do acesso
105 a fontes.
106
107 Este pacote contém arquivos de desenvolvimento necessários à criação
108 de extensões baseadas na biblioteca fontconfig.
109
110 %package static
111 Summary:        Static font configuration and customization library
112 Summary(pl.UTF-8):      Statyczna biblioteka do konfigurowania fontów
113 Summary(pt_BR.UTF-8):   Biblioteca estática para configuração e customização do acesso a fontes
114 Group:          Development/Libraries
115 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
116 Provides:       XFree86-fontconfig-static
117 Obsoletes:      XFree86-fontconfig-static
118
119 %description static
120 This package contains static version of fontconfig library.
121
122 %description static -l pl.UTF-8
123 Ten pakiet zawiera statyczną wersję biblioteki fontconfig.
124
125 %description static -l pt_BR.UTF-8
126 Este pacote contém a biblioteca estática do fontconfig
127
128 %prep
129 %setup -q
130 %patch0 -p1
131 rm src/fcobjshash.h
132
133 %build
134 %{__libtoolize}
135 %{__aclocal} -I m4
136 %{__autoconf}
137 %{__autoheader}
138 %{__automake}
139
140 # don't rebuild docs by default, use prebuild ones
141 export HASDOCBOOK=no
142
143 %configure \
144         --enable-docs%{!?with_doc:=no} \
145         --disable-silent-rules \
146         --%{?with_static_libs:en}%{!?with_static_libs:dis}able-static
147 %{__make}
148
149 %{?with_tests:%{__make} check}
150
151 %install
152 rm -rf $RPM_BUILD_ROOT
153 install -d $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5},/var/cache/fontconfig} \
154
155 %{__make} install \
156         DESTDIR=$RPM_BUILD_ROOT \
157         htmldoc_DATA= \
158         doc_DATA=
159
160 install %{SOURCE1} \
161         $RPM_BUILD_ROOT%{_datadir}/%{name}/conf.avail/10-lcd-filter.conf
162
163 ln -s %{_datadir}/%{name}/conf.avail $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.avail
164
165 cp -pf conf.d/README README.confd
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %pretrans
171 # this needs to be a symlink
172 if [ -d %{_sysconfdir}/fonts/conf.avail ] && [ ! -L %{_sysconfdir}/fonts/conf.avail ]; then
173         mv -f %{_sysconfdir}/fonts/conf.avail{,.rpmsave}
174         install -d %{_datadir}/%{name}/conf.avail
175         ln -s %{_datadir}/%{name}/conf.avail %{_sysconfdir}/fonts/conf.avail
176         mv -f %{_sysconfdir}/fonts/conf.avail.rpmsave/*.conf %{_sysconfdir}/fonts/conf.avail/
177         rmdir %{_sysconfdir}/fonts/conf.avail.rpmsave 2>/dev/null || :
178 fi
179
180 %post
181 umask 022
182 HOME=/tmp %{_bindir}/fc-cache -f 2>/dev/null || :
183
184 %post   libs -p /sbin/ldconfig
185 %postun libs -p /sbin/ldconfig
186
187 %files
188 %defattr(644,root,root,755)
189 %doc AUTHORS COPYING ChangeLog README README.confd doc/fontconfig-user.html
190 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/fonts.conf
191 %{_sysconfdir}/fonts/conf.avail
192 %{_sysconfdir}/fonts/conf.d/README
193 %config(noreplace,missingok) %verify(not link md5 mtime size) %{_sysconfdir}/fonts/conf.d/*.conf
194 %attr(755,root,root) %{_bindir}/fc-cache
195 %attr(755,root,root) %{_bindir}/fc-cat
196 %attr(755,root,root) %{_bindir}/fc-list
197 %attr(755,root,root) %{_bindir}/fc-match
198 %attr(755,root,root) %{_bindir}/fc-query
199 %attr(755,root,root) %{_bindir}/fc-pattern
200 %attr(755,root,root) %{_bindir}/fc-scan
201 %attr(755,root,root) %{_bindir}/fc-validate
202 %dir %{_datadir}/xml/%{name}
203 %{_datadir}/xml/%{name}/fonts.dtd
204 %{_datadir}/%{name}/conf.avail/*.conf
205 %if %{with doc}
206 %{_mandir}/man1/fc-*.1*
207 %{_mandir}/man5/fonts-conf.5*
208 %endif
209 %dir /var/cache/fontconfig
210
211 %files libs
212 %defattr(644,root,root,755)
213 %attr(755,root,root) %{_libdir}/libfontconfig.so.*.*.*
214 %attr(755,root,root) %ghost %{_libdir}/libfontconfig.so.1
215
216 %files devel
217 %defattr(644,root,root,755)
218 %doc doc/fontconfig-devel/*.html
219 %attr(755,root,root) %{_libdir}/libfontconfig.so
220 %{_libdir}/libfontconfig.la
221 %{_includedir}/fontconfig
222 %{_pkgconfigdir}/fontconfig.pc
223 %if %{with doc}
224 %{_mandir}/man3/Fc*.3*
225 %endif
226
227 %if %{with static_libs}
228 %files static
229 %defattr(644,root,root,755)
230 %{_libdir}/libfontconfig.a
231 %endif
This page took 0.059101 seconds and 2 git commands to generate.