]> git.pld-linux.org Git - packages/fontconfig.git/blob - fontconfig.spec
up to 2.15.0
[packages/fontconfig.git] / fontconfig.spec
1 #
2 # Conditional build
3 %bcond_without  static_libs     # don't build static library
4 %bcond_without  doc             # don't build HTML and man docs
5 %bcond_without  tests           # don't perform make check
6
7 Summary:        Font configuration and customization tools
8 Summary(pl.UTF-8):      Narzędzia do konfigurowania fontów
9 Summary(pt_BR.UTF-8):   Ferramentas para configuração e customização do acesso a fontes
10 Name:           fontconfig
11 Version:        2.13.0
12 Release:        3
13 Epoch:          1
14 License:        MIT
15 Group:          Libraries
16 Source0:        https://www.freedesktop.org/software/fontconfig/release/%{name}-%{version}.tar.bz2
17 # Source0-md5:  60d2394a79d3b2e5db2daea55193fa47
18 Source1:        %{name}-lcd-filter.conf
19 Patch0:         %{name}-bitstream-cyberbit.patch
20 Patch1:         %{name}-constant-weight.patch
21 URL:            http://fontconfig.org/
22 BuildRequires:  autoconf >= 2.61
23 BuildRequires:  automake >= 1:1.11
24 %if %{with doc}
25 BuildRequires:  docbook-dtd31-sgml
26 BuildRequires:  docbook-dtd41-sgml
27 BuildRequires:  docbook-utils >= 0.6.13-3
28 %endif
29 BuildRequires:  ed
30 BuildRequires:  expat-devel
31 BuildRequires:  freetype-devel >= 2.8.1
32 BuildRequires:  gettext-tools >= 0.19.8
33 BuildRequires:  gperf
34 BuildRequires:  libtool >= 2:2.2
35 BuildRequires:  pkgconfig
36 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
37 Requires:       freetype >= 2.8.1
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Fontconfig is designed to locate fonts within the system and select
42 them according to requirements specified by applications.
43
44 This package contains tools and documentation.
45
46 %description -l pl.UTF-8
47 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
48 systemie i wybierania ich w zależności od potrzeb aplikacji.
49
50 Paket ten zawiera programy narzędziowe i dokumentację.
51
52 %description -l pt_BR.UTF-8
53 Fontconfig é uma biblioteca para configuração e customização do acesso
54 a fontes.
55
56 Este pacote contém as ferramentas e documentação.
57
58 %package libs
59 Summary:        Font configuration and customization library
60 Summary(pl.UTF-8):      Biblioteka do konfigurowania fontów
61 Summary(pt_BR.UTF-8):   Biblioteca para configuração e customização do acesso a fontes
62 Group:          Libraries
63 Requires:       freetype >= 2.1.5
64 Provides:       XFree86-fontconfig
65 Obsoletes:      XFree86-fontconfig
66 Conflicts:      fontconfig <= 1:2.2.98-1
67
68 %description libs
69 Fontconfig is designed to locate fonts within the system and select
70 them according to requirements specified by applications.
71
72 %description libs -l pl.UTF-8
73 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
74 systemie i wybierania ich w zależności od potrzeb aplikacji.
75
76 %description libs -l pt_BR.UTF-8
77 Fontconfig é uma biblioteca para configuração e customização do acesso
78 a fontes.
79
80 %package devel
81 Summary:        Font configuration and customization library - development files
82 Summary(pl.UTF-8):      Biblioteka do konfigurowania fontów - pliki dla programistów
83 Summary(pt_BR.UTF-8):   Biblioteca para configuração e customização do acesso a fontes - arquivos de desenvolvimento
84 Group:          Development/Libraries
85 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
86 Requires:       expat-devel
87 Requires:       freetype-devel >= 2.1.5
88 Provides:       XFree86-fontconfig-devel
89 Obsoletes:      XFree86-fontconfig-devel
90
91 %description devel
92 Fontconfig is designed to locate fonts within the system and select
93 them according to requirements specified by applications.
94
95 This package contains the header files needed to develop programs that
96 use these fontconfig.
97
98 %description devel -l pl.UTF-8
99 Fontconfig jest biblioteką przeznaczoną do lokalizowania fontów w
100 systemie i wybierania ich w zależności od potrzeb aplikacji.
101
102 Ten pakiet zawiera pliki nagłówkowe potrzebne do kompilowania
103 programów korzystających z biblioteki fontconfig.
104
105 %description devel -l pt_BR.UTF-8
106 Fontconfig é uma biblioteca para configuração e customização do acesso
107 a fontes.
108
109 Este pacote contém arquivos de desenvolvimento necessários à criação
110 de extensões baseadas na biblioteca fontconfig.
111
112 %package static
113 Summary:        Static font configuration and customization library
114 Summary(pl.UTF-8):      Statyczna biblioteka do konfigurowania fontów
115 Summary(pt_BR.UTF-8):   Biblioteca estática para configuração e customização do acesso a fontes
116 Group:          Development/Libraries
117 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
118 Provides:       XFree86-fontconfig-static
119 Obsoletes:      XFree86-fontconfig-static
120
121 %description static
122 This package contains static version of fontconfig library.
123
124 %description static -l pl.UTF-8
125 Ten pakiet zawiera statyczną wersję biblioteki fontconfig.
126
127 %description static -l pt_BR.UTF-8
128 Este pacote contém a biblioteca estática do fontconfig
129
130 %prep
131 %setup -q
132 %patch0 -p1
133 %patch1 -p1
134
135 %build
136 %{__gettextize}
137 %{__libtoolize}
138 %{__aclocal} -I m4
139 %{__autoconf}
140 %{__autoheader}
141 %{__automake}
142
143 # don't rebuild docs by default, use prebuild ones
144 export HASDOCBOOK=no
145
146 %configure \
147         --enable-docs%{!?with_doc:=no} \
148         --disable-silent-rules \
149         --%{?with_static_libs:en}%{!?with_static_libs:dis}able-static
150 %{__make}
151
152 %{?with_tests:%{__make} check || (cat test/test-suite.log && /bin/false)}
153
154 %install
155 rm -rf $RPM_BUILD_ROOT
156 install -d $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5},/var/cache/fontconfig} \
157
158 %{__make} install \
159         DESTDIR=$RPM_BUILD_ROOT \
160         htmldoc_DATA= \
161         doc_DATA=
162
163 install %{SOURCE1} \
164         $RPM_BUILD_ROOT%{_datadir}/%{name}/conf.avail/10-lcd-filter.conf
165
166 ln -s %{_datadir}/%{name}/conf.avail $RPM_BUILD_ROOT%{_sysconfdir}/fonts/conf.avail
167
168 cp -pf conf.d/README README.confd
169
170 %find_lang %{name}
171 %find_lang %{name}-conf -a %{name}.lang
172
173 %clean
174 rm -rf $RPM_BUILD_ROOT
175
176 %pretrans
177 # this needs to be a symlink
178 if [ -d %{_sysconfdir}/fonts/conf.avail ] && [ ! -L %{_sysconfdir}/fonts/conf.avail ]; then
179         mv -f %{_sysconfdir}/fonts/conf.avail{,.rpmsave}
180         install -d %{_datadir}/%{name}/conf.avail
181         ln -s %{_datadir}/%{name}/conf.avail %{_sysconfdir}/fonts/conf.avail
182         mv -f %{_sysconfdir}/fonts/conf.avail.rpmsave/*.conf %{_sysconfdir}/fonts/conf.avail/
183         rmdir %{_sysconfdir}/fonts/conf.avail.rpmsave 2>/dev/null || :
184 fi
185
186 %post
187 umask 022
188 HOME=/tmp %{_bindir}/fc-cache -f 2>/dev/null || :
189
190 %post   libs -p /sbin/ldconfig
191 %postun libs -p /sbin/ldconfig
192
193 %files -f %{name}.lang
194 %defattr(644,root,root,755)
195 %doc AUTHORS COPYING ChangeLog README README.confd doc/fontconfig-user.html
196 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fonts/fonts.conf
197 %{_sysconfdir}/fonts/conf.avail
198 %{_sysconfdir}/fonts/conf.d/README
199 %config(noreplace,missingok) %verify(not link md5 mtime size) %{_sysconfdir}/fonts/conf.d/*.conf
200 %attr(755,root,root) %{_bindir}/fc-cache
201 %attr(755,root,root) %{_bindir}/fc-cat
202 %attr(755,root,root) %{_bindir}/fc-conflist
203 %attr(755,root,root) %{_bindir}/fc-list
204 %attr(755,root,root) %{_bindir}/fc-match
205 %attr(755,root,root) %{_bindir}/fc-query
206 %attr(755,root,root) %{_bindir}/fc-pattern
207 %attr(755,root,root) %{_bindir}/fc-scan
208 %attr(755,root,root) %{_bindir}/fc-validate
209 %dir %{_datadir}/xml/%{name}
210 %{_datadir}/xml/%{name}/fonts.dtd
211 %{_datadir}/%{name}/conf.avail/*.conf
212 %if %{with doc}
213 %{_mandir}/man1/fc-*.1*
214 %{_mandir}/man5/fonts-conf.5*
215 %endif
216 %dir /var/cache/fontconfig
217
218 %files libs
219 %defattr(644,root,root,755)
220 %attr(755,root,root) %{_libdir}/libfontconfig.so.*.*.*
221 %attr(755,root,root) %ghost %{_libdir}/libfontconfig.so.1
222
223 %files devel
224 %defattr(644,root,root,755)
225 %doc doc/fontconfig-devel/*.html
226 %attr(755,root,root) %{_libdir}/libfontconfig.so
227 %{_libdir}/libfontconfig.la
228 %{_includedir}/fontconfig
229 %{_pkgconfigdir}/fontconfig.pc
230 %{_datadir}/gettext/its/fontconfig.its
231 %{_datadir}/gettext/its/fontconfig.loc
232 %if %{with doc}
233 %{_mandir}/man3/Fc*.3*
234 %endif
235
236 %if %{with static_libs}
237 %files static
238 %defattr(644,root,root,755)
239 %{_libdir}/libfontconfig.a
240 %endif
This page took 0.044917 seconds and 3 git commands to generate.