]> git.pld-linux.org Git - packages/folly.git/commitdiff
install more headers, used by hiphop-php
authorElan Ruusamäe <glen@delfi.ee>
Sun, 6 Oct 2013 00:04:38 +0000 (03:04 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sun, 6 Oct 2013 20:32:57 +0000 (23:32 +0300)
folly.spec
install-headers.patch [new file with mode: 0644]

index 57a59e831876430e26a71321d11086333fd92f1e..f60949418e4056075d68050385853327b5ab3188 100644 (file)
@@ -5,13 +5,14 @@
 Summary:       Folly is an open-source C++ library developed and used at Facebook
 Name:          folly
 Version:       0.1
-Release:       1
+Release:       0.9
 License:       Apache v2.0
 Group:         Libraries
 Source0:       https://github.com/facebook/folly/archive/master/%{name}.tar.gz
 # Source0-md5: d7ff084fbd77dc34bfd9469c7a974547
 Patch0:                https://github.com/facebook/folly/pull/29.patch
 # Patch0-md5:  8745f0742d7199a5d3b2864620812f89
+Patch1:                install-headers.patch
 URL:           https://github.com/facebook/folly/blob/master/folly/docs/Overview.md
 BuildRequires: boost-devel >= 1.20.0
 BuildRequires: double-conversion-devel
@@ -61,6 +62,7 @@ Statyczna biblioteka %{name}.
 %setup -qc
 mv folly-*/* .
 %patch0 -p1
+%patch1 -p1
 
 # this is gtest-1.6 seem to work
 ln -s %{_usrsrc}/gtest folly/test/gtest-1.6.0
diff --git a/install-headers.patch b/install-headers.patch
new file mode 100644 (file)
index 0000000..3efe2f9
--- /dev/null
@@ -0,0 +1,61 @@
+--- folly-0.1/folly/Makefile.am        2013-10-06 18:16:51.140695708 +0300
++++ folly-0.1/folly/Makefile.am        2013-10-06 18:18:18.131398586 +0300
+@@ -26,19 +26,25 @@
+       ConcurrentSkipList.h \
+       ConcurrentSkipList-inl.h \
+       Conv.h \
++      CpuId.h \
+       detail/AtomicHashUtils.h \
+       detail/BitIteratorDetail.h \
++      detail/BitsDetail.h \
+       detail/DiscriminatedPtrDetail.h \
+       detail/FingerprintPolynomial.h \
+       detail/GroupVarintDetail.h \
+       detail/SlowFingerprint.h \
++      detail/Stats.h \
+       detail/ThreadLocalDetail.h \
+       DiscriminatedPtr.h \
++      DynamicConverter.h \
++      Exception.h \
+       dynamic.h \
+       dynamic-inl.h \
+       eventfd.h \
+       FBString.h \
+       FBVector.h \
++      FileUtil.h \
+       Fingerprint.h \
+       folly-config.h \
+       Foreach.h \
+@@ -51,10 +57,13 @@
+       Histogram-inl.h \
+       IntrusiveList.h \
+       json.h \
++      Lazy.h \
+       Likely.h \
+       Logging.h \
+       Malloc.h \
+       MapUtil.h \
++      Memory.h \
++      Optional.h \
+       PackedSyncPtr.h \
+       Portability.h \
+       Preprocessor.h \
+@@ -68,6 +77,10 @@
+       sorted_vector_types.h \
+       SpookyHashV1.h \
+       SpookyHashV2.h \
++      stats/BucketedTimeSeries.h \
++      stats/Histogram-defs.h \
++      stats/Histogram.h \
++      stats/MultiLevelTimeSeries.h \
+       StlAllocator.h \
+       String.h \
+       String-inl.h \
+@@ -83,6 +96,7 @@
+       ThreadLocal.h \
+       TimeoutQueue.h \
+       Traits.h \
++      Varint.h \
+       Unicode.h
+ FormatTables.cpp: build/generate_format_tables.py
This page took 0.058782 seconds and 4 git commands to generate.