]> git.pld-linux.org Git - packages/folly.git/blame - folly.spec
- up to 0.57.0
[packages/folly.git] / folly.spec
CommitLineData
987f958e
ER
1#
2# Conditional build:
3%bcond_without static_libs # don't build static libraries
98eebf8c 4%bcond_with tests # build with tests
987f958e 5
94baf25c 6Summary: Library of C++11 components designed with practicality and efficiency in mind
987f958e 7Name: folly
b214efb1
JR
8Version: 0.57.0
9Release: 1
987f958e
ER
10License: Apache v2.0
11Group: Libraries
d4b12164 12Source0: https://github.com/facebook/folly/archive/v%{version}/%{name}-%{version}.tar.gz
b214efb1 13# Source0-md5: 226d9dc1b12819c9a53735dc6fa8cc8a
f55375ac 14Patch0: gcc5.patch
98eebf8c 15URL: https://github.com/facebook/folly
c09b0dc4
ER
16BuildRequires: autoconf
17BuildRequires: automake
987f958e
ER
18BuildRequires: boost-devel >= 1.20.0
19BuildRequires: double-conversion-devel
20BuildRequires: gflags-devel
3a553404 21BuildRequires: glog-devel
98eebf8c 22%{?with_tests:BuildRequires: gtest-devel >= 1.6.0}
c09b0dc4 23BuildRequires: libevent-devel
987f958e 24BuildRequires: libstdc++-devel
c09b0dc4
ER
25BuildRequires: libtool
26BuildRequires: m4
27BuildRequires: openssl-devel
28BuildRequires: python
29BuildRequires: python-modules
d4b12164 30BuildRequires: rpmbuild(macros) >= 1.583
423f0b7b 31ExclusiveArch: %{x8664}
987f958e
ER
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
98eebf8c
ER
34%define sover %(echo %{version} | cut -d. -f2)
35
d4b12164 36# missing openssl linking
98eebf8c 37%define skip_post_check_so libfolly.so.%{sover}.0.0
d4b12164 38
987f958e 39%description
4c898fa9
ER
40Folly (acronymed loosely after Facebook Open Source Library) is a
41library of C++11 components designed with practicality and efficiency
42in mind. It complements (as opposed to competing against) offerings
43such as Boost and of course std. In fact, we embark on defining our
44own component only when something we need is either not available, or
45does not meet the needed performance profile.
46
47Performance concerns permeate much of Folly, sometimes leading to
48designs that are more idiosyncratic than they would otherwise be (see
49e.g. PackedSyncPtr.h, SmallLocks.h). Good performance at large scale
50is a unifying theme in all of Folly.
987f958e
ER
51
52%package devel
53Summary: Header files for %{name} library
54Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
57
58%description devel
59Header files for %{name} library.
60
61%description devel -l pl.UTF-8
62Pliki nagłówkowe biblioteki %{name}.
63
64%package static
65Summary: Static %{name} library
66Summary(pl.UTF-8): Statyczna biblioteka %{name}
67Group: Development/Libraries
68Requires: %{name}-devel = %{version}-%{release}
69
70%description static
71Static %{name} library.
72
73%description static -l pl.UTF-8
74Statyczna biblioteka %{name}.
75
76%prep
d4b12164 77%setup -q
f55375ac 78%patch0 -p1
987f958e 79
d4b12164 80#ln -s %{_usrsrc}/gtest folly/test/gtest-1.7.0
987f958e
ER
81
82%build
83cd folly
84%{__libtoolize}
85%{__aclocal}
86%{__autoconf}
87%{__autoheader}
88%{__automake}
987f958e
ER
89%configure \
90 %{!?with_static_libs:--disable-static}
91%{__make}
98eebf8c 92%{?with_tests:%{__make} check}
987f958e
ER
93
94%install
95rm -rf $RPM_BUILD_ROOT
96%{__make} -C folly install \
97 DESTDIR=$RPM_BUILD_ROOT
98
99# these aren't supposed to be installed!
d4b12164 100#rm $RPM_BUILD_ROOT%{_libdir}/libgtest*
987f958e
ER
101
102%clean
103rm -rf $RPM_BUILD_ROOT
104
105%post -p /sbin/ldconfig
106%postun -p /sbin/ldconfig
107
108%files
109%defattr(644,root,root,755)
98eebf8c 110%doc README.md LICENSE
987f958e 111%attr(755,root,root) %{_libdir}/libfolly.so.*.*.*
98eebf8c 112%ghost %{_libdir}/libfolly.so.%{sover}
987f958e 113%attr(755,root,root) %{_libdir}/libfollybenchmark.so.*.*.*
98eebf8c 114%ghost %{_libdir}/libfollybenchmark.so.%{sover}
987f958e
ER
115
116%files devel
117%defattr(644,root,root,755)
118%{_libdir}/libfolly.so
119%{_libdir}/libfollybenchmark.so
987f958e
ER
120%{_libdir}/libfolly.la
121%{_libdir}/libfollybenchmark.la
987f958e
ER
122%{_includedir}/folly
123
124%if %{with static_libs}
125%files static
126%defattr(644,root,root,755)
127%{_libdir}/libfolly.a
128%{_libdir}/libfollybenchmark.a
987f958e 129%endif
This page took 0.089445 seconds and 4 git commands to generate.