]> git.pld-linux.org Git - packages/folks.git/commitdiff
- 0.2.0 auto/th/folks-0_2_0-1 auto/ti/folks-0_2_0-1
authorPatryk Zawadzki <patrys@room-303.com>
Tue, 28 Sep 2010 20:46:47 +0000 (20:46 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    folks.spec -> 1.2
    telepathy-glib-vala.patch -> 1.1

folks.spec
telepathy-glib-vala.patch [new file with mode: 0644]

index ced3aac8991111b47399f749cfebcf192ffac574..e67c64f56b87432bc307a7e2683a256bf4dfcba4 100644 (file)
@@ -1,12 +1,13 @@
 Summary:       GObject contact aggregation library
 Name:          folks
-Version:       0.1.15
+Version:       0.2.0
 Release:       1
 License:       LGPL v2+
 Group:         Libraries
 URL:           http://telepathy.freedesktop.org/wiki/Folks
-Source0:       http://download.gnome.org/sources/folks/0.1/%{name}-%{version}.tar.bz2
-# Source0-md5: cb2e04f69bf619943b9ec4b0a6ebc534
+Source0:       http://download.gnome.org/sources/folks/0.2/%{name}-%{version}.tar.bz2
+# Source0-md5: 8c66c03d942313db735f6eb375c2f71a
+Patch0:                telepathy-glib-vala.patch
 BuildRequires: libgee-devel
 BuildRequires: telepathy-glib-devel
 BuildRequires: vala >= 0.9.7
@@ -29,7 +30,7 @@ developing applications that use %{name}.
 
 %prep
 %setup -q
-
+%patch0 -p1
 
 %build
 %configure \
@@ -49,11 +50,14 @@ find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog README
+%attr(755,root,root) %{_bindir}/folks-import
 %attr(755,root,root) %{_libdir}/libfolks.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libfolks.so.0
 %attr(755,root,root) %{_libdir}/libfolks-telepathy.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libfolks-telepathy.so.0
 %{_libdir}/folks
+%{_datadir}/vala/vapi/folks.*
+%{_datadir}/vala/vapi/folks-telepathy.*
 
 %files devel
 %defattr(644,root,root,755)
diff --git a/telepathy-glib-vala.patch b/telepathy-glib-vala.patch
new file mode 100644 (file)
index 0000000..a5adbba
--- /dev/null
@@ -0,0 +1,51 @@
+diff -ur folks-0.2.0/backends/telepathy/lib/tpf-persona-store.vala folks-new/backends/telepathy/lib/tpf-persona-store.vala
+--- folks-0.2.0/backends/telepathy/lib/tpf-persona-store.vala  2010-09-18 16:44:38.000000000 +0200
++++ folks-new/backends/telepathy/lib/tpf-persona-store.vala    2010-09-28 22:40:15.895273003 +0200
+@@ -350,7 +350,7 @@
+       else if (new_status != TelepathyGLib.ConnectionStatus.CONNECTED)
+         return;
+-      var conn = this.account.get_connection ();
++      var conn = this.account.connection;
+       conn.notify["connection-ready"].connect (this.connection_ready_cb);
+       /* Deal with the case where the connection is already ready
+@@ -806,7 +806,7 @@
+         {
+           /* the changes queued above will be resolve in the NewChannels handler
+            */
+-          this.ll.connection_create_group_async (this.account.get_connection (),
++          this.ll.connection_create_group_async (this.account.connection,
+               group);
+         }
+       else
+diff -ur folks-0.2.0/backends/telepathy/lib/tpf-persona.vala folks-new/backends/telepathy/lib/tpf-persona.vala
+--- folks-0.2.0/backends/telepathy/lib/tpf-persona.vala        2010-09-18 16:44:38.000000000 +0200
++++ folks-new/backends/telepathy/lib/tpf-persona.vala  2010-09-28 22:41:22.675273004 +0200
+@@ -197,7 +197,7 @@
+         throw new Tpf.PersonaError.INVALID_ARGUMENT ("contact has an " +
+             "invalid ID");
+-      var account = account_for_connection (contact.get_connection ());
++      var account = account_for_connection (contact.connection);
+       string uid = this.build_uid ("telepathy", account.get_protocol (), id);
+       var alias = contact.get_alias ();
+@@ -293,7 +293,7 @@
+       accounts.foreach ((l) =>
+         {
+           unowned Account account = (Account) l;
+-          if (account.get_connection () == conn)
++          if (account.connection == conn)
+             {
+               account_found = account;
+               return;
+@@ -344,7 +344,7 @@
+   private void contact_notify_avatar ()
+     {
+-      var file = this.contact.get_avatar_file ();
++      var file = this.contact.avatar_file;
+       if (this.avatar != file)
+         this.avatar = file;
+     }
This page took 0.148607 seconds and 4 git commands to generate.