- made patch portable across ruby versions per suggestion from radek master
authorCaleb Maclennan <caleb@alerque.com>
Mon, 3 May 2010 10:54:56 +0000 (10:54 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    flvtool2-ruby19.patch -> 1.2

flvtool2-ruby19.patch

index bb65a00..b01e25a 100644 (file)
@@ -1,10 +1,12 @@
 --- flvtool2-1.0.6/setup.rb~   2006-10-10 23:46:57.000000000 +0300
-+++ flvtool2-1.0.6/setup.rb    2010-05-01 14:11:48.846696545 +0300
-@@ -1311,6 +1311,7 @@
++++ flvtool2-1.0.6/setup.rb    2010-05-03 13:51:01.395678449 +0300
+@@ -1311,6 +1311,9 @@
        File.open(path) {|f|
          line = f.gets
        }
-+      line.force_encoding('ASCII-8BIT')
++        if RUBY_VERSION >= "1.9"
++                line.force_encoding('ASCII-8BIT')
++        end
        return nil unless /\A#!/ =~ line
        parse(line)
      end
This page took 0.042813 seconds and 4 git commands to generate.