]> git.pld-linux.org Git - packages/flux.git/blob - flux.spec
- adapterized, pl summary
[packages/flux.git] / flux.spec
1 Summary:        Flux is a survival-through-structure library
2 Summary(pl):    Flux - biblioteka struktur danych i operacji na nich
3 Name:           flux
4 Version:        0.4.1
5 Release:        2
6 License:        GPL
7 Group:          Libraries
8 Group(de):      Libraries
9 Group(es):      Bibliotecas
10 Group(fr):      Librairies
11 Group(pl):      Biblioteki
12 Group(pt_BR):   Bibliotecas
13 Group(ru):      âÉÂÌÉÏÔÅËÉ
14 Group(uk):      â¦Â̦ÏÔÅËÉ
15 Source0:        ftp://ftp.styx.net/projects/flux/%{name}-%{version}.tar.gz
16 Patch0:         %{name}-gethostbyname_is_in_libc_aka_no_libnsl.patch
17 URL:            http://projects.simplemente.net/flux/
18 BuildRequires:  autoconf
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Flux is a survival-through-structure library, whose goal is to reduce
23 the complexity of C programming. To this end, it supplies high-level
24 functions for manipulating data and communication with specialized
25 handles, masking typically tedious programming tasks. Common
26 instruction blocks are wrapped in higher-level calls with intuitive
27 names. In short: Do it once, do it right, then forget about it.
28
29 Abstracting things this way involves speed compromises. In Flux, these
30 should be minimal, and sometimes, when superiour algorithms are easily
31 accessible, efficiency is actually gained.
32
33 Another important goal is bridging gaps between typical tasks - like
34 parsing, storage, retrieval, buffering and transfer, data structures -
35 like generic tree structures, generic network structures, XML and
36 presentation formats, and protocols - like FluxComm, Unix protocols
37 and IRC. (Note: IRC protocols are hairy and ill-defined. Unification
38 and masking is particularly useful here).
39
40 %description -l pl
41 Flux jest bibliotek± typu "survival-through-structure", której celem
42 jest redukcja z³o¿ono¶ci programowania w C. W tym celu zaprojektowano
43 funkcje wysokiego poziomu s³u¿±ce manipulacji danymi i komunikacji z
44 wyspecjalizowanymi uchwytami, ukrywaj±c nu¿±ce zazwyczaj zadania
45 programistyczne. Popularne bloki instrukcji s± zawiniête w wywo³aniach
46 wy¿szego poziomu o intuicyjnych nazwach. Mówi±c krótko: Zrób to raz,
47 zrób to dobrze i zapomnij o tym. Takie wyabstrahowywanie wymaga wielu
48 kompromisów. We Fluksie powinny byæ one ograniczone do minimum, czasem
49 za¶, kiedy ³atwo jest u¿yæ lepszych algorytmów, zyskuje siê na
50 wydajno¶ci. Inn± wa¿n± rzecz± jest stworzenie pomostu miêdzy typowymi
51 zadaniami (parsowanie, przechowywanie, wydobywanie, buforowanie i
52 transfer), strukturami danych (generyczne struktury drzew, generyczne
53 struktury sieci XML i formaty prezentacyjne) a protoko³ami (FluxComm,
54 protoko³y uniksowe i IRC. Uwaga: protoko³y ircowe s± niezgrabne i ¼le
55 zdefiniowane. Szczególnie w tym wypadku unifikacja i maskowanie
56 ukazuj± swoja warto¶æ).
57
58 %package devel
59 Summary:        Header files and development documentation for flux
60 Summary(pl):    Pliki nag³ówkowe i dokumentacja do flux
61 Group:          Development/Libraries
62 Group(de):      Entwicklung/Libraries
63 Group(es):      Desarrollo/Bibliotecas
64 Group(fr):      Development/Librairies
65 Group(pl):      Programowanie/Biblioteki
66 Group(pt_BR):   Desenvolvimento/Bibliotecas
67 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
68 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
69 Requires:       %{name} = %{version}
70
71 %description devel
72 Header files and development documentation for flux.
73
74 %description -l pl devel
75 Pliki nag³ówkowe i dokumentacja do biblioteki flux.
76
77 %package static
78 Summary:        Static flux libraries
79 Summary(pl):    Biblioteki statyczne flux
80 Group:          Development/Libraries
81 Group(de):      Entwicklung/Libraries
82 Group(es):      Desarrollo/Bibliotecas
83 Group(fr):      Development/Librairies
84 Group(pl):      Programowanie/Biblioteki
85 Group(pt_BR):   Desenvolvimento/Bibliotecas
86 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
87 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
88 Requires:       %{name}-devel = %{version}
89
90 %description static
91 Static flux libraries.
92
93 %description -l pl static
94 Biblioteki statyczne flux.
95
96 %prep
97 %setup -q
98
99 %build
100 #autoconf
101 %configure2_13
102 echo n | make
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install DESTDIR=$RPM_BUILD_ROOT
108
109 gzip -9nf AUTHORS README NEWS TODO 
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post   -p /sbin/ldconfig
115 %postun -p /sbin/ldconfig
116
117 %files
118 %defattr(644,root,root,755)
119 %attr(755,root,root) %{_libdir}/lib*.so.*.*
120
121 %files devel
122 %defattr(644,root,root,755)
123 %doc *.gz doc/*
124 %attr(755,root,root) %{_libdir}/lib*.so
125 %attr(755,root,root) %{_libdir}/lib*.la
126 %{_includedir}/*
127
128 %files static
129 %defattr(644,root,root,755)
130 %{_libdir}/lib*.a
This page took 0.082827 seconds and 4 git commands to generate.