]> git.pld-linux.org Git - packages/flux.git/blob - flux.spec
- added %description -l pl
[packages/flux.git] / flux.spec
1 Summary:        Flux is a survival-through-structure library
2 Name:           flux
3 Version:        0.4.1
4 Release:        1
5 Group:          Libraries
6 Group(pl):      Biblioteki
7 Copyright:      GPL
8 Source:         ftp://ftp.styx.net/projects/flux/%{name}-%{version}.tar.gz
9 URL:            http://projects.simplemente.net/flux/
10 BuildRoot:      /tmp/%{name}-%{version}-root
11
12 %description
13 Flux is a survival-through-structure library, whose goal is to reduce the
14 complexity of C programming. To this end, it supplies high-level functions
15 for manipulating data and communication with specialized handles, masking
16 typically tedious programming tasks. Common instruction blocks are wrapped
17 in higher-level calls with intuitive names. In short: Do it once, do it
18 right, then forget about it.
19
20 Abstracting things this way involves speed compromises. In Flux, these
21 should be minimal, and sometimes, when superiour algorithms are easily
22 accessible, efficiency is actually gained.
23
24 Another important goal is bridging gaps between typical tasks - like
25 parsing, storage, retrieval, buffering and transfer, data structures - like
26 generic tree structures, generic network structures, XML and presentation
27 formats, and protocols - like FluxComm, Unix protocols and IRC. (Note: IRC
28 protocols are hairy and ill-defined. Unification and masking is particularly
29 useful here).
30
31 %description -l pl
32 Flux jest bibliotek± typu "", której celem jest redukcja z³o¿ono¶ci
33 programowania w C. W tym celu zaprojektowano funkcje wysokiego poziomu
34 s³u¿±ce manipulacji danymi i komunikacji z wyspecjalizowanymi uchwytami,
35 ukrywaj±c nu¿±ce zazwyczaj zadania programistyczne. Popularne bloki
36 instrukcji s± zawiniête w wywo³aniach wy¿szego poziomu o intuicyjnych nazwach.
37 Mówi±c krótko: Zrób to raz, zrób to dobrze i zapomnij o tym.
38 Takie wyabstrahowywanie wymaga wielu kompromisów. We Fluksie powinny
39 byæ one ograniczone do minimum, czasem za¶, kiedy ³atwo jest u¿yæ lepszych
40 algorytmów, zyskuje siê na wydajno¶ci.
41 Inn± wa¿n± rzecz± jest stworzenie pomostu miêdzy typowymi zadaniami (parsowanie,
42 przechowywanie, wydobywanie, buforowanie i transfer), strukturami danych
43 (generyczne struktury drzew, generyczne struktury sieci XML i formaty
44 prezentacyjne) a protoko³ami (FluxComm, protoko³y uniksowe i IRC. Uwaga:
45 protoko³y ircowe s± niezgrabne i ¼le zdefiniowane. Szczególnie w tym wypadku
46 unifikacja i maskowanie ukazuj± swoja warto¶æ).
47
48
49 %package devel
50 Summary:        Header files and development documentation for flux
51 Summary(pl):    Pliki nag³ówkowe i dokumentacja do flux
52 Group:          Development/Libraries
53 Group(pl):      Programowanie/Biblioteki
54 Requires:       %{name} = %{version}
55
56 %description devel
57 Header files and development documentation for flux.
58
59 %description -l pl devel
60 Pliki nag³ówkowe i dokumentacja do biblioteki flux.
61
62 %package static
63 Summary:        Static flux libraries
64 Summary(pl):    Biblioteki statyczne flux
65 Group:          Development/Libraries
66 Group(pl):      Programowanie/Biblioteki
67 Requires:       %{name}-devel = %{version}
68
69 %description static
70 Static flux libraries.
71
72 %description -l pl static
73 Biblioteki statyczne flux.
74
75 %prep
76 %setup -q
77
78 %build
79 LDFLAGS="-s"; export LDFLAGS
80 %configure
81 echo n | make
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 make install DESTDIR=$RPM_BUILD_ROOT
87
88 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
89
90 gzip -9nf AUTHORS README NEWS TODO 
91
92 %find_lang %{name}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %attr(755,root,root) %{_libdir}/lib*.so.*.*
103
104 %files devel
105 %defattr(644,root,root,755)
106 %doc *.gz doc/*
107 %attr(755,root,root) %{_libdir}/lib*.so
108 %attr(755,root,root) %{_libdir}/lib*.la
109 %{_includedir}/*
110
111 %files static
112 %attr(644,root,root) %{_libdir}/lib*.a
113
114 %changelog
This page took 0.065934 seconds and 4 git commands to generate.