]> git.pld-linux.org Git - packages/flux.git/blob - flux.spec
- relese 3,
[packages/flux.git] / flux.spec
1 Summary:        Flux is a survival-through-structure library
2 Summary(pl):    Flux - biblioteka struktur danych i operacji na nich
3 Name:           flux
4 Version:        0.4.1
5 Release:        3
6 License:        GPL
7 Group:          Libraries
8 Group(de):      Libraries
9 Group(es):      Bibliotecas
10 Group(fr):      Librairies
11 Group(pl):      Biblioteki
12 Group(pt_BR):   Bibliotecas
13 Group(ru):      âÉÂÌÉÏÔÅËÉ
14 Group(uk):      â¦Â̦ÏÔÅËÉ
15 Source0:        ftp://ftp.styx.net/projects/flux/%{name}-%{version}.tar.gz
16 Patch0:         %{name}-gethostbyname_is_in_libc_aka_no_libnsl.patch
17 Patch1:         %{name}-acinclude_fix.patch
18 Patch2:         %{name}-am15.patch
19 URL:            http://projects.simplemente.net/flux/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  libtool
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Flux is a survival-through-structure library, whose goal is to reduce
27 the complexity of C programming. To this end, it supplies high-level
28 functions for manipulating data and communication with specialized
29 handles, masking typically tedious programming tasks. Common
30 instruction blocks are wrapped in higher-level calls with intuitive
31 names. In short: Do it once, do it right, then forget about it.
32
33 Abstracting things this way involves speed compromises. In Flux, these
34 should be minimal, and sometimes, when superiour algorithms are easily
35 accessible, efficiency is actually gained.
36
37 Another important goal is bridging gaps between typical tasks - like
38 parsing, storage, retrieval, buffering and transfer, data structures -
39 like generic tree structures, generic network structures, XML and
40 presentation formats, and protocols - like FluxComm, Unix protocols
41 and IRC. (Note: IRC protocols are hairy and ill-defined. Unification
42 and masking is particularly useful here).
43
44 %description -l pl
45 Flux jest bibliotek± typu "survival-through-structure", której celem
46 jest redukcja z³o¿ono¶ci programowania w C. W tym celu zaprojektowano
47 funkcje wysokiego poziomu s³u¿±ce manipulacji danymi i komunikacji z
48 wyspecjalizowanymi uchwytami, ukrywaj±c nu¿±ce zazwyczaj zadania
49 programistyczne. Popularne bloki instrukcji s± zawiniête w wywo³aniach
50 wy¿szego poziomu o intuicyjnych nazwach. Mówi±c krótko: Zrób to raz,
51 zrób to dobrze i zapomnij o tym. Takie wyabstrahowywanie wymaga wielu
52 kompromisów. We Fluksie powinny byæ one ograniczone do minimum, czasem
53 za¶, kiedy ³atwo jest u¿yæ lepszych algorytmów, zyskuje siê na
54 wydajno¶ci. Inn± wa¿n± rzecz± jest stworzenie pomostu miêdzy typowymi
55 zadaniami (parsowanie, przechowywanie, wydobywanie, buforowanie i
56 transfer), strukturami danych (generyczne struktury drzew, generyczne
57 struktury sieci XML i formaty prezentacyjne) a protoko³ami (FluxComm,
58 protoko³y uniksowe i IRC. Uwaga: protoko³y ircowe s± niezgrabne i ¼le
59 zdefiniowane. Szczególnie w tym wypadku unifikacja i maskowanie
60 ukazuj± swoja warto¶æ).
61
62 %package devel
63 Summary:        Header files and development documentation for flux
64 Summary(pl):    Pliki nag³ówkowe i dokumentacja do flux
65 Group:          Development/Libraries
66 Group(de):      Entwicklung/Libraries
67 Group(es):      Desarrollo/Bibliotecas
68 Group(fr):      Development/Librairies
69 Group(pl):      Programowanie/Biblioteki
70 Group(pt_BR):   Desenvolvimento/Bibliotecas
71 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
72 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
73 Requires:       %{name} = %{version}
74
75 %description devel
76 Header files and development documentation for flux.
77
78 %description -l pl devel
79 Pliki nag³ówkowe i dokumentacja do biblioteki flux.
80
81 %package static
82 Summary:        Static flux libraries
83 Summary(pl):    Biblioteki statyczne flux
84 Group:          Development/Libraries
85 Group(de):      Entwicklung/Libraries
86 Group(es):      Desarrollo/Bibliotecas
87 Group(fr):      Development/Librairies
88 Group(pl):      Programowanie/Biblioteki
89 Group(pt_BR):   Desenvolvimento/Bibliotecas
90 Group(ru):      òÁÚÒÁÂÏÔËÁ/âÉÂÌÉÏÔÅËÉ
91 Group(uk):      òÏÚÒÏÂËÁ/â¦Â̦ÏÔÅËÉ
92 Requires:       %{name}-devel = %{version}
93
94 %description static
95 Static flux libraries.
96
97 %description -l pl static
98 Biblioteki statyczne flux.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103 %patch1 -p1
104 %patch2 -p1
105
106 %build
107 rm -f missing
108 libtoolize --copy --force
109 aclocal
110 autoconf
111 automake -a -c
112 %configure
113 echo n | %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install DESTDIR=$RPM_BUILD_ROOT
119
120 gzip -9nf AUTHORS README NEWS TODO 
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files
129 %defattr(644,root,root,755)
130 %attr(755,root,root) %{_libdir}/lib*.so.*.*
131
132 %files devel
133 %defattr(644,root,root,755)
134 %doc *.gz doc/*
135 %attr(755,root,root) %{_libdir}/lib*.so
136 %attr(755,root,root) %{_libdir}/lib*.la
137 %{_includedir}/*
138
139 %files static
140 %defattr(644,root,root,755)
141 %{_libdir}/lib*.a
This page took 0.060598 seconds and 4 git commands to generate.